Кіріспе

Компьютерлік желілік протокол

Диаметр – компьютерлік желілер үшін аутентификация, авторизация және есепке алу протоколы. Ол RADIUS протоколының бұрынғы нұсқасынан дамыған. Ол Интернет протоколы жиынтығындағы қолданбалық қабатқа жататын протоколдардың бірі. Диаметр қолданбалары базалық протоколды жаңа командалар мен/немесе атрибуттарды қосу арқылы кеңейтеді, мысалы, кеңейтілген аутентификация протоколымен (EAP) қолдану үшін.

Тарих

Диаметр протоколын 1998 жылы Пат Р. Калхун, Глен Зорн және Пинг Пан RADIUS-тің шектеулерін жеңе алатын аутентификация, авторизация және есептік (AAA) жүйесін құру үшін әзірледі. RADIUS сенімділік, кеңейтімділік, қауіпсіздік және икемділік мәселелеріне тап болды. RADIUS қашықтан кіру, IP мобильділігі және саясатты басқарумен тиімді күресе алмайды. Диаметр протоколы клиенттер Policy, AAA және ресурстарды басқару үшін пайдаланатын саясат протоколын анықтайды. Бұл бір серверге көптеген қызметтердің саясатын басқаруға мүмкіндік береді. RADIUS сияқты, Диаметр де AAA функционалдығын қамтамасыз етеді, бірақ UDP орнына TCP және SCTP қолданады, демек байланыс мәселелерін анықтау және шешуді осы протоколдарға жүктейді. Диаметр протоколы 3-ші буын серіктестік жобасының (3GPP) IP мультимедиалық кіші жүйесін (IMS) дамыту арқылы одан әрі жетілдірілді. Диаметр қолданбалары S6a, S6b, Gx, Gy, Sy, Rx, Cx, Dh, Dx, Rf, Ro, Sh және Zh интерфейстерін қолдайды. Протокол кеңейтімдерді пайдалану арқылы проксилерді, брокерлерді, күшті қауіпсіздікті, мобильді IP, желіге кіру серверлерін (NASREQ), есептеу және ресурстарды басқаруды қолдау үшін кеңейтілген.

Хаттаманың сипаттамасы

Диаметрлік базалық протокол RFC 6733 (Ескірген: RFC 3588 және RFC 5719) арқылы анықталады және AAA протоколы үшін минималды талаптарды белгілейді. Diameter қолданбалары базалық протоколды жаңа командалар, атрибуттар немесе олардың комбинациясы арқылы кеңейте алады. Диаметр қауіпсіздігі IPsec немесе TLS протоколдарымен қамтамасыз етіледі. IANA, RFC 6733 стандартының 11.4 бөлімінде көрсетілгендей, Diameter үшін TCP және SCTP порттарының 3868 нөмірін бекітті.

Пакет пішімі

Пакет диаметр хабарламасына қатысты ақпаратты қамтитын, диаметр тақырыбынан және өзгеретін саны бар Атрибут-Мән Жұптарынан (AVP) тұрады. Диаметр тақырыбы битінің ығысуы 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 0 нұсқасы хабарлама ұзындығы 32 R P E T команда коды 64 қолданба ID 96 қадам-қадам ID 128 бастан-басқа ID 160 AVP.

Нұсқасы

Бұл өріс Diameter негізгі протоколының нұсқасын көрсетеді. 2014 жылға дейін тек 1 мәні қолдау көрсетіледі.

Хабардың ұзындығы

Хабар ұзындығы өрісі Диаметр хабарламасының байттармен өлшенген ұзындығын, бас өрістері мен толтырылған AVP-лерді қоса, көрсетеді.

Командалық жалаушалар

"R" (Request) биті – Егер орнатылса, хабарлама сұрау болып табылады. Егер жойылса, хабарлама жауап болып саналады. "P" (Proxiable) биті – Егер орнатылса, хабарлама прокси арқылы жіберілуі, қайта таратылуы немесе қайта бағытталуы мүмкін. Егер жойылса, хабарлама жергілікті түрде өңделуі керек. "E" (Error) биті – Егер орнатылса, хабарламада протокол қатесі бар және хабарлама осы команда үшін сипатталған CCF стандартына сәйкес келмейді. "E" биті орнатылған хабарламалар көбінесе қателік хабарламалары деп аталады. Бұл бит сұрау хабарламаларында орнатылмауы тиіс. "T" (Қайта жіберілуі мүмкін хабарлама) биті – Бұл белгі сілтеме ауысу процедурасынан кейін қойылады, бұл қайталама сұрауларды жоюға көмектеседі. Сілтеме бұзылған жағдайда мүмкін болатын қайталанудың көрсеткіші ретінде әлі расталмаған сұрауларды қайта жібергенде орнатылады.

Командалар

Әр командаға сұрау/жауап жұбы команда коды тағайындалады. Сұрау немесе жауап екені, қабылдаушының басқатырған "R" биті арқылы, қабылдаушының басқатырған "Command Flags" өрісі арқылы анықталады. 0–255 мәндері RADIUS жүйесімен кері үйлесімділік үшін резервтелген. 256–16777213 мәндері IANA бөліп берген тұрақты, стандартты командаларға арналған. 16777214 және 16777215 (16 жақтық 0xFFFFFE және 0xFFFFFF) мәндері тәжірибелік және сынақтар үшін резервтелген. Командалық код нақты хабарлама үшін қандай әрекет орындалуы керектігін анықтау үшін пайдаланылады. Протоколдың (негізгі және қосымшалар) ішінде анықталған кейбір жалпы Diameter командалары:

Команда атыҚысқарту.КодҚолданылуы AA сұрауAAR265Diameter NAS қосымшасы RFC 7155 AA жауабыAAA265Diameter NAS қосымшасы RFC 7155 Diameter EAP сұрауыDER268Diameter EAP қосымшасы RFC 4072 Diameter EAP жауабыDEA268Diameter EAP қосымшасы RFC 4072 Сеансты тоқтату сұрауыASR274Diameter негізгі Сеансты тоқтату жауабыASA274Diameter негізгі Есептеу сұрауыACR271Diameter негізгі Есептеу жауабыACA271Diameter негізгі Несиелік бақылау сұрауыCCR272Diameter Несиелік бақылау қосымшасы RFC 8506 (RFC 4006-ны ескіртеді) Несиелік бақылау жауабыCCA272Diameter Несиелік бақылау қосымшасы RFC 8506 (RFC 4006-ны ескіртеді) Қабілеттерді алмасу сұрауыCER257Diameter негізгі Қабілеттерді алмасу жауабыCEA257Diameter негізгі Құрылғы сақшысы сұрауыDWR280Diameter негізгі Құрылғы сақшысы жауабыDWA280Diameter негізгі Пірді ажырату сұрауыDPR282Diameter негізгі Пірді ажырату жауабыDPA282Diameter негізгі Жаңадан авторизациялау сұрауыRAR258Diameter негізгі Жаңадан авторизациялау жауабыRAA258Diameter негізгі Сеансты аяқтау сұрауыSTR275Diameter негізгі Сеансты аяқтау жауабыSTA275Diameter негізгі Пайдаланушыны авторизациялау сұрауыUAR283Diameter SIP қосымшасы RFC 4740 Пайдаланушыны авторизациялау жауабыUAA283Diameter SIP қосымшасы RFC 4740 Серверді тағайындау сұрауыSAR284Diameter SIP қосымшасы RFC 4740 Серверді тағайындау жауабыSAA284Diameter SIP қосымшасы RFC 4740 Орналасқан жер туралы ақпарат сұрауыLIR285Diameter SIP қосымшасы RFC 4740 Орналасқан жер туралы ақпарат жауабыLIA285Diameter SIP қосымшасы RFC 4740 Мультимедиа авторизациясы сұрауыMAR286Diameter SIP қосымшасы RFC 4740 Мультимедиа авторизациясы жауабыMAA286Diameter SIP қосымшасы RFC 4740 Тіркеуді аяқтау сұрауыRTR287Diameter SIP қосымшасы RFC 4740 Тіркеуді аяқтау жауабыRTA287Diameter SIP қосымшасы RFC 4740 Профильді жіберу сұрауыPPR288Diameter SIP қосымшасы RFC 4740 Профильді жіберу жауабыPPA288Diameter SIP қосымшасы RFC 4740 Пайдаланушыны авторизациялау сұрауыUAR300Diameter негізгі (3GPP) RFC 3589 Пайдаланушыны авторизациялау жауабыUAA300Diameter негізгі (3GPP) RFC 3589 Серверді тағайындау сұрауыSAR301Diameter негізгі (3GPP) RFC 3589 Серверді тағайындау жауабыSAA301Diameter негізгі (3GPP) RFC 3589 Орналасқан жер туралы ақпарат сұрауыLIR302Diameter негізгі (3GPP) RFC 3589 Орналасқан жер туралы ақпарат жауабыLIA302Diameter негізгі (3GPP) RFC 3589 Мультимедиа авторизациясы сұрауыMAR303Diameter негізгі (3GPP) RFC 3589 Мультимедиа авторизациясы жауабыMAA303Diameter негізгі (3GPP) RFC 3589 Тіркеуді аяқтау сұрауыRTR304Diameter негізгі (3GPP) RFC 3589 Тіркеуді аяқтау жауабыRTA304Diameter негізгі (3GPP) RFC 3589 Профильді жіберу сұрауыPPR305Diameter негізгі (3GPP) RFC 3589 Профильді жіберу жауабыPPA305Diameter негізгі (3GPP) RFC 3589 Пайдаланушы деректері сұрауыUDR306Diameter негізгі (3GPP) RFC 3589 Пайдаланушы деректері жауабыUDA306Diameter негізгі (3GPP) RFC 3589 Профильді жаңарту сұрауыPUR307Diameter негізгі (3GPP) RFC 3589 Профильді жаңарту жауабыPUA307Diameter негізгі (3GPP) RFC 3589 Жазылу хабарламаларын сұрауSNR308Diameter негізгі (3GPP) RFC 3589 Жазылу хабарламаларын жауабуSNA308Diameter негізгі (3GPP) RFC 3589 Пуш хабарламасын сұрауPNR309Diameter негізгі (3GPP) RFC 3589 Пуш хабарламасын жауабуPNA309Diameter негізгі (3GPP) RFC 3589 Бастапқы ақпарат сұрауыBIR310Diameter негізгі (3GPP) RFC 3589 Бастапқы ақпарат жауабыBIA310Diameter негізгі (3GPP) RFC 3589 Хабарламаны өңдеу сұрауыMPR311Diameter негізгі (3GPP) RFC 3589 Хабарламаны өңдеу жауабыMPA311Diameter негізгі (3GPP) RFC 3589 Орналасқан жерін жаңарту сұрауыULR316 3GPP TS 29.272 [RFC 5516] Орналасқан жерін жаңарту жауабыULA316 3GPP TS 29.272 [RFC 5516] Орналасқан жерін жою сұрауыCLR317 3GPP TS 29.272 [RFC 5516] Орналасқан жерін жою жауабыCLA317 3GPP TS 29.272 [RFC 5516] Растау ақпараты сұрауыAIR318 3GPP TS 29.272 [RFC 5516] Растау ақпараты жауабыAIA318 3GPP TS 29.272 [RFC 5516] Абонент деректерін қосу сұрауыIDR319 3GPP TS 29.272 [RFC 5516] Абонент деректерін қосу жауабыIDA319 3GPP TS 29.272 [RFC 5516] Абонент деректерін жою сұрауыDSR320 3GPP TS 29.272 [RFC 5516] Абонент деректерін жою жауабыDSA320 3GPP TS 29.272 [RFC 5516] UE-ні тазарту сұрауыPER321 3GPP TS 29.272 [RFC 5516] UE-ні тазарту жауабыPEA321 3GPP TS 29.272 [RFC 5516] Хабарлау сұрауыNR323 3GPP TS 29.272 [RFC 5516] Хабарлау жауабыNA323 3GPP TS 29.272 [RFC 5516] Орналасқан жерін беру сұрауыPLR83886203GPP LCS SLg (Application ID 16777255) Орналасқан жерін беру жауабыPLA83886203GPP LCS SLg (Application ID 16777255) Бағыттық ақпарат сұрауыRIR83886223GPP LCS SLh (Application ID 16777291) Бағыттық ақпарат жауабыRIA83886223GPP LCS SLh (Application ID 16777291) AA мобильді түйін сұрауыAMR260 Diameter Mobile IPv4 RFC 4004 AA мобильді түйін жауабыAMA260 Diameter Mobile IPv4 RFC 4004 Үй агенті MIP сұрауыHAR262 Diameter Mobile IPv4 RFC 4004 Үй агенті MIP жауабыHAA262 Diameter Mobile IPv4 RFC 4004 Конфигурациялық ақпарат сұрауыCIR8388718 S6t per 3GPP TS 29.336 Конфигурациялық ақпарат жауабыCIA8388718 S6t per 3GPP TS 29.336 Есеп беру ақпараты сұрауыRIR8388719 S6t per 3GPP TS 29.336 Есеп беру ақпараты жауабыRIA8388719 S6t per 3GPP TS 29.336 NIDD ақпараты сұрауыNIR8388726 S6t per 3GPP TS 29.336 NIDD ақпараты жауабыNIA8388726 S6t per 3GPP TS 29.336

Қолданбаның ID

Қолданба идентификаторы хабарламаның қай Diameter қолданбасына қатысты екенін анықтау үшін қолданылады. Қолданба аутентификация, есептеу немесе сатушыға тән қолданба бола алады. Diameter-дің белгілі бір кеңейтуіне сәйкес келетін Diameter агенттері, Capabilities Exchange Request (CER) және Capabilities Exchange Answer (CEA) командаларындағы Auth Application Id атрибутында нақты мәнді қосу арқылы оны қолдайтынын жариялайды. Кабельдік бөлімдегі Application ID өрісінің мәні, хабарламадағы тиісті Application Id AVP-мен бірдей болады. Мысалы, Diameter Credit Control қолданбасы үшін Credit Control Request (CCR) және Credit Control Answer (CCA) командаларындағы Application ID және Auth Application Id атрибутының мәні 4-ке тең. Қолданба IDAbbr. Толық атауы Пайдалану 0BaseDiameter Ортақ хабарламалар Diameter протоколының байланысын орнату/үзу/сақтау 16777216Cx/Dx3GPP Cx/DxIMS I/S CSCF-тен HSS интерфейсіне 16777217Sh3GPP ShVoIP/IMS SIP Application Server-ден HSS интерфейсіне 16777236Rx3GPP RxСаясат және төлемді басқару 16777238Gx3GPP GxСаясат және төлемді басқару 16777251S6a/S6d3GPP S6a/S6dLTE Роуминг сигналдауы 16777252S133GPP 13EIR мен MME арасындағы интерфейс 16777255SLg3GPP LCS SLgОрналасқан жерге қатысты қызметтер 16777345S6t3GPP S6tSCE және HSS арасындағы интерфейс.

Хоп-на-хоп идентификаторы

Hop by Hop идентификаторы – сұрауларды олардың жауаптарымен сәйкестендіру үшін қолданылатын қол қойылмаған 32 биттік бүтін сан өрісі (желілік байт ретімен), себебі сұраудағы сол мән жауапта да пайдаланылады. Диаметр протоколы қайта жіберу және прокси-серверлер транзакция күйін сақтауын қажет етеді, ол қателерді жою мақсатында қолданылады. Транзакция күйі дегеніміз, сұранысты жіберген кезде оның Hop by Hop идентификаторы сақталады; бұл өріс жергілікті түрде бірегей идентификатормен алмастырылады, ал тиісті жауап алынғанда бастапқы мәніне қайта орналастырылады. Жауап алынғаннан кейін сұрау күйі босатылады. Белгілі Hop by Hop идентификаторымен сәйкес келмейтін алынған жауаптар Диаметр агентімен қарастырылмайды. Қайта бағыттаушы агенттер үшін Hop by Hop идентификаторы Диаметр агенті жауап хабарымен жауап берген кезде тақырыпта сақталады.

Толық идентификатор

End to End Identifier - 32 биттік қолтаңбасыз бүтін сан өрісі (желілік байт ретімен) болып, ол Origin Host AVP жиынтығымен бірге қайталанатын хабарламаларды анықтау үшін пайдаланылады. Сұрау жасалғанда, End to End Identifier жергілікті түрде бірегей мәнге орнатылады. End to End Identifier ешқандай Диаметр агенттерімен өзгертілмейді, ал сәйкес сұраудағы сол мән жауапта қолданылады.

Мемлекеттік машиналар

RFC 3588 peer-лер арасындағы қосылыстарды сақтау және хабарламаларды өңдеу үшін негізгі күй машинасының жұмыс істеуін анықтайды. Бұл негізгі протоколдың функционалдығының бір бөлігі болып табылады және барлық стектер оны қолдауы тиіс, осылайша байланысқа қатысты операциялардан абстракция жасалады. Сонымен қатар, қолданбаға арналған күй машиналары кейінірек немесе жоғары деңгейдегі абстракция қабатында енгізілуі мүмкін. RFC 3588 авторизация және есептеу күй машиналарын анықтайды.

Хабар ағындары

Екі диаметрлік теңдестің арасындағы байланыс тасымалдау қосылысын (TCP немесе SCTP) орнатудан басталады. Бастамашы одан кейін екінші теңдеске қабілеттер алмасу сұрауын (CER) жібереді, ал ол қабілеттер алмасу жауабымен (CEA) жауап береді. RFC3588 стандатына сәйкес келетін теңдестер үшін TLS (Transport Layer Security) қауіпсіздігі опциялық түрде келісілуі мүмкін. RFC6733 стандатына сәйкес келетін теңдестер үшін TLS келіссөздері CER/CEA алдында жүзеге асуы мүмкін. Содан кейін қосылыс қосымша хабарламаларды алмасуға дайын болады. Егер біраз уақыт бойы хабарлама алмасылмаса, екі жақ та құрылғының жұмыс істеуін тексеру сұрауын (DWR) жіберуі мүмкін, ал екінші теңдес құрылғының жұмыс істеуін тексеру жауабымен жауап беруге міндетті. Кез келген жақ байланысты аяқтау үшін Қосылысты үзу сұрауын (DPR) жіберуі мүмкін, ал екінші теңдес Қосылысты үзу жауабымен жауап беруге тиіс. Одан кейін тасымалдау қосылысын үзуге болады.

RFC-тер

Диаметр протоколы қазіргі уақытта келесі IETF RFC-де анықталған: Ескірген RFC-лер сызылып көрсетілген. # Атауы Жарияланған күні Қатысты мақала Ескірген: Ескертулер RFC 3588 Diameter Base Protocol. 2003 жылдың қыркүйегі RFC 6733 RFC 3589 Diameter Command Codes for Third Generation Partnership Project (3GPP) Release 5. 2003 жылдың қыркүйегі RFC 4004 Диаметр Мобильді IPv4 қосымшасы. 2005 жылғы тамыз RFC 4005 Diameter Network Access Server Application. 2005 жылғы тамыз RFC 7155RFC 4006 Диаметрлік кредиттік бақылау қосымшасы. 2005 жылғы тамыз Диаметрлік кредиттік бақылау қосымшасы RFC 8506 RFC 4072 Диаметрлік кеңейтілген аутентификация протоколы (EAP) қосымшасы. 2005 жылғы тамыз RFC 4740 Диаметр сессиясын бастау протоколы (SIP) қосымшасы. М. 2006 жылғы қараша RFC 5224 Диаметр саясатын өңдеу қосымшасы. Наурыз 2008 RFC 5431 Диаметр ITU T Rw саясатын қолдану интерфейсі. Наурыз 2009 RFC 5447 Diameter Mobile IPv6: Желілік қолжетімділік серверінен Диаметр серверімен өзара әрекеттесуді қолдау. 2009 жылғы ақпан RFC 5516 Үшінші буын серіктестік жобасының (3GPP) эволюцияланған пакеттік жүйесіне (EPS) арналған Диаметр командалық кодын тіркеу. Сәуір 2009 RFC 5624 Диаметрмен пайдалану үшін қызмет сапасы параметрлері. 2009 жылғы тамыз RFC 5719 Диаметр командалық кодтарын бөлуге қатысты IANA ескертулері жаңартылды. Қаңтар 2010 RFC 6733 Диаметр базалық протоколы. Қазан 2012 RFC 6737 Диаметр мүмкіндіктерін жаңарту қосымшасы. Қазан 2012 RFC 7155 Диаметр желілік қолжетімділік сервері қосымшасы. 2014 жылғы сәуір RFC 8506 Диаметрлік кредиттік бақылау қосымшасы. 2019 жылғы наурыз