Кіріспе

Forward confirmed reverse DNS (FCrDNS), сондай-ақ толық шеңберлі кері DNS, қос кері DNS немесе iprev деп аталады, бұл белгілі бір IP-адрестің бір-біріне сәйкес келетін Domain Name System (DNS) жазбалары бар (атауынан мекенжайына) және кері (мекенжайынан аты) бар желілік параметрлерді конфигурациялау болып табылады. Бұл көптеген DNS-ке тәуелді протоколдарды қолдайтын Интернет стандарттары күтетін стандартты конфигурация. Дэвид Барр RFC 1912 (Ақпараттық) құжатында оны DNS әкімшілері үшін ең жақсы тәжірибе ретінде ұсынатын пікір жариялады, бірақ DNS стандартының өзінде осы талаптар ресми түрде кодификацияланбаған. FCrDNS тексеруі домендік атаудың иесі мен IP-адресті алған желінің иесі арасындағы жарамды байланыс бар екенін растаудың әлсіз түрін жасауы мүмкін. Бұл аутентификация әлсіз болғанымен, спамшылар мен фишерлер электрондық пошта адрестарын жалғандау үшін зомби-компьютерлерді қолданғанда осы тексеруден өте алмайтындықтан, оны ақ тізімге енгізу үшін жеткілікті күшті. Яғни, кері DNS расталуы мүмкін, бірақ әдетте ол талап етілген домендік атаудан өзге доменнің бөлігі болады. ISP-нің пошта серверін реле ретінде пайдалану кері DNS мәселесін шеше алады, себебі жіберу релесі үшін алға және кері іздеу сәйкес келуі керек, бірақ ол ретрансляцияланатын хабарламалардың "From" өрісіне немесе жіберу доменіне байланысты болуы міндетті емес. Электрондық поштада IP-адресті және доменді байланыстырудың басқа әдістері – Sender Policy Framework (SPF) және MX жазбасы. Кері DNS-ді конфигурациялай алмайтын немесе конфигурациялауға құзыретсіз ISP-лер өз желілеріндегі хосттар үшін мәселелер тудырады, себебі олар кері DNS-ті тиісті A (немесе AAAA) жазбасымен сәйкес келуді талап ететін қосымшаларды немесе протоколдарды қолдауға қабілетсіз болады. Кері DNS-ді ұсына алмайтын немесе ұсынудан бас тартатын ISP-лер, нәтижесінде өз клиенттеріне ұсынатын интернет-қызметтерді тиімді және қауіпсіз пайдалану мүмкіндігін шектейді.

Қолданбалар

Электрондық поштаны жіберу агенттерінің (серверлік бағдарламалық қамтамасыз ету) көпшілігі FCrDNS тексеруін қолданады және егер жарамды домендік атау болса, оны "Қабылданды:" іздеу баслығының өрісіне қосады. Кейбір электрондық поштаны жіберу агенттері SMTP HELO және EHLO командаларында берілген домендік атау бойынша FCrDNS тексеруін жүргізеді. Бұл RFC 2821 талаптарын бұзуы мүмкін, сондықтан электрондық пошта әдетте автоматты түрде қабылданбайды. Sender Policy Framework электрондық поштаның жалғандығына қарсы жүйесі өзінің "ptr:" механизмінде FCrDNS тексеруін пайдаланады. Дегенмен, SPF-тің 2006 жылғы алғашқы стандартталуынан (RFC 4408) бері осы "ptr:" механизмін пайдалану ұсынылмайды. Кейбір электрондық пошта спам сүзгілері FCrDNS тексерулерін домендік атауларды аутентификациялау үшін немесе RFC 8601 стандартына сәйкес, ақ тізімге қосу мақсатында қолданады. SpamCop FCrDNS тексеруін қолданады, бұл кейде SpamCop пайдаланушыларына, сонымен қатар пошта серверлері үшін дұрыс сәйкес келмейтін DNS және rDNS жазбаларын ұсынылмайтын Интернет-провайдерлерінің клиенттеріне проблема тудырады. Кейбір FTP, Telnet және TCP Wrapper серверлері FCrDNS тексерулерін жүргізеді. Кейбір IRC серверлері FCrDNS тексеруін зәулімдіктің алдын алу үшін жүргізеді.