Кіріспе

Желілік басқару протоколы

Желілік конфигурация протоколы (NETCONF) – IETF ұйымы әзірлеген және стандарттаған желілік басқару протоколы. Ол NETCONF жұмыс тобында әзірленді және 2006 жылдың желтоқсанында RFC 4741 ретінде, ал кейін 2011 жылдың маусымында қайта қаралып RFC 6241 ретінде жарияланды. NETCONF протоколының сипаттамасы – Интернет стандарттарының қадағалау құжаты. NETCONF желілік құрылғылардың конфигурациясын орнату, өзгерту және жою механизмдерін ұсынады. Оның операциялары қарапайым қашықтықтан процедура шақыру (RPC) қабатының үстінде іске асырылады. NETCONF протоколы конфигурациялық деректер және протокол хабарлары үшін кеңейтілген таңбалау тіліне (XML) негізделген деректерді кодтауды қолданады. Протокол хабарлары қауіпсіз тасымалдау протоколы арқылы алмасылады. NETCONF протоколын тұжырымдық тұрғыдан төрт қабатқа бөлуге болады:

Мазмұн қабаты конфигурациялық деректер мен хабарлама деректерінен тұрады. Операциялар қабаты конфигурациялық деректерді алу және өңдеу үшін негізгі протокол операцияларының жиынтығын анықтайды. Хабарламалар қабаты қашықтықтан процедура шақыруларын (RPC) және хабарламаларды кодтау механизмін қамтамасыз етеді. Қауіпсіз тасымалдау қабаты клиент пен сервер арасындағы хабарламаларды қауіпсіз және сенімді түрде тасымалдауды қамтамасыз етеді. NETCONF протоколы маршрутизаторлар мен коммутаторлар сияқты желілік құрылғыларда кейбір ірі жабдық өндірушілері тарапынан іске асырылған. NETCONF-тың ерекше күші – бірнеше құрылғыны қамтитын транзакцияларды пайдалана отырып, конфигурацияны сенімді түрде өзгертуді қолдауы.

Тарих

IETF 1980-ші жылдардың соңында Simple Network Management Protocol (SNMP) протоколын жасады, ол өте танымал желілік басқару протоколы болды. XXI ғасырдың басында SNMP бастапқы мақсатына қарамастан, желілік жабдықтарды конфигурациялау үшін емес, көбінесе желіні бақылау үшін қолданылатыны анықталды. 2002 жылдың маусым айында Интернет архитектурасы кеңесі (IAB) және IETF желілік басқару қауымдастығының өкілдері желі операторларымен ахуалды талқылау үшін жиналды. Осы жиынның нәтижелері RFC 3535 құжатында жазылған. Көрсетілгендей, әрбір желі операторы өз құрылғыларын конфигурациялау үшін әртүрлі, меншікке тиесілі командалық қатар интерфейсін (CLI) пайдаланды. Бұл операторларға ұнаған бірнеше артықшылықтары бар еді, соның ішінде BER кодталған SNMP-ге қарағанда мәтіндік форматта болуы. Сонымен қатар, көптеген жабдық өндірушілер SNMP арқылы құрылғыларын толыққанды конфигурациялау мүмкіндігін ұсынбады. Операторлар әдетте құрылғыларын басқаруға көмектесетін скрипттерді жазуды қалағандықтан, SNMP CLI-нің кемшіліктері көп екенін байқады. Ең маңыздысы – нәтижелердің болжамсыздығы. Шығыс мазмұны мен пішімі алдын ала болжаусыз өзгерістерге ұшырауы мүмкін еді. Осы кезеңде Juniper Networks XML негізіндегі желілік басқару тәсілін қолданды. Бұл тәсіл IETF-ке ұсынылып, кеңінен қауымдастықпен бөлісті. Аталған екі оқиғаның нәтижесінде IETF 2003 жылдың мамырында NETCONF жұмыс тобын құрды. Бұл жұмыс тобы желі операторлары мен жабдық өндірушілерінің қажеттіліктерін қанағаттандыратын желілік конфигурация протоколын жасаумен айналысуға міндеттелді. NETCONF протоколының алғашқы нұсқасы 2006 жылдың желтоқсан айында RFC 4741 ретінде жарияланды. Келесі жылдары бірнеше толықтырулар жарияланды (хабарламалар RFC 5277, 2008 жылдың шілдесінде; ішінара құлыптаулар RFC 5717, 2009 жылдың желтоқсанында; әдепкілер RFC 6243, 2011 жылдың маусымында; жүйелік хабарламалар RFC 6470, 2012 жылдың ақпанында; қол жеткізуді бақылау RFC 6536, 2012 жылдың наурызында). NETCONF протоколының жаңартылған нұсқасы 2011 жылдың маусым айында RFC 6241 ретінде жарияланды.

Мазмұны

NETCONF операцияларының мазмұны дұрыс құрылған XML форматында болады. Мазмұнның көп бөлігі желілік басқаруға қатысты. Кейіннен JavaScript Object Notation (JSON) түрінде кодтауға қолдау да қосылды. NETMOD жұмыс тобы операциялық деректердің, конфигурациялық деректердің, хабарламалардың және операциялардың семантикасын анықтау үшін "адамға түсінікті" модельдеу тілін анықтау жұмысын аяқтады, осы тіл YANG деп аталады. YANG RFC 6020 (1-нұсқа) және RFC 7950 (1.1-нұсқа) стандартында сипатталған, ал RFC 6991 стандартында "жалпы YANG дерек түрлері" келтірілген. 2010 жылдың жазында NETMOD жұмыс тобы негізгі конфигурациялық модельдер (жүйе, интерфейс және маршрутизациялау) бойынша жұмыс істеу және SNMP модельдеу тілімен үйлесімділікті қамтамасыз ету үшін қайта құрылды.