Кіріспе
Принтерлер үшін байланыс протоколы
Интернет-баспа протоколы (IPP) – клиенттік құрылғылар (компьютерлер, ұялы телефондар, планшеттер және т.б.) мен принтерлер (немесе баспа серверлері) арасындағы байланыс үшін арналған мамандандырылған байланыс протоколы. Ол клиенттерге желіге қосылған принтерге немесе баспа серверіне бір немесе бірнеше басып шығару тапсырмасын жіберуге, сондай-ақ принтердің күйін сұрау, басып шығару тапсырмаларының күйін алу немесе жеке басып шығару тапсырмаларын жою сияқты операцияларды орындауға мүмкіндік береді. IP-негізделген барлық протоколдар сияқты, IPP жергілікті желіде немесе Интернет арқылы жұмыс істей алады. Басқа басып шығару протоколдарынан өзгеше, IPP кіруге бақылау, аутентификация және шифрлауды да қолдайды, бұл оны ескі протоколдарға қарағанда әлдеқайда мүмкіндігі жоғары және қауіпсіз басып шығару механизмі етеді. IPP бірнеше принтер логотипін сертификаттау бағдарламаларының негізі болып табылады, оның ішінде AirPrint, IPP Everywhere және Mopria Alliance, және бүгінгі күні сатылатын принтерлердің 98%-дан астамы оны қолдайды.
The Internet Printing Protocol (IPP) is a specialized communication protocol for communication between client devices (computers, mobile phones, tablets, etc.) and printers (or print servers). It allows clients to submit one or more print jobs to the network attached printer or print server, and perform tasks such as querying the status of a printer, obtaining the status of print jobs, or cancelling individual print jobs. Like all IP based protocols, IPP can run locally or over the Internet. Unlike other printing protocols, IPP also supports access control, authentication, and encryption, making it a much more capable and secure printing mechanism than older ones. IPP is the basis of several printer logo certification programs including AirPrint, IPP Everywhere, and Mopria Alliance, and is supported by over 98% of printers sold today.
Тарих
IPP 1996 жылы Novell компаниясының Интернет-басып шығару протоколын құру жөніндегі ұсынысы ретінде бастау алды. Нәтижесінде Novell және Xerox компаниялары ECMA 140: Document Printing Application (DPA) бағдарламасынан туындаған Lightweight Document Printing Application (LDPA) деп аталатын жобаны жасады. Шамамен сол кезде Lexmark HyperText Printing Protocol (HTPP) деп аталатын бір нәрсені ұсынды, ал HP және Microsoft Windows 2000 болып табылатын жаңа басып шығару қызметтерін әзірлеуді бастады. Компаниялардың әрқайсысы Printer Working Group (PWG) аясында ортақ Интернет-басып шығару протоколын бастауды шешті және Интернет-инженерлік тобындағы (IETF) Қолданбалар аймағы директорларымен IPP бірдей мақсаттағы (немесе BOF) сессиясын келісті. 1996 жылғы желтоқсанда өткен BOF сессиясы басып шығару протоколын әзірлеуге жеткілікті қызығушылықты көрсетті, бұл 2005 жылы аяқталған IETF Интернет-басып шығару протоколы (ipp) жұмыс тобының құрылуына әкелді. IPP бойынша жұмыс PWG Интернет-басып шығару протоколы жұмыс тобында 23 кандидаттық стандартты, 1 жаңа және 3 жаңартылған IETF RFC-ні жариялау арқылы жалғасты, сондай-ақ IPP-ті кеңейтуге және 3D басып шығару, сканерлеу, факсимиль, бұлтқа негізделген қызметтер және жалпы жүйе мен ресурстарды басқару сияқты әртүрлі қызметтерді қолдауға арналған бірнеше тіркеу және ең жақсы тәжірибелер құжаттарымен жалғасты. IPP/1.0 1999 жылы эксперименталдық құжаттар сериясы ретінде жарияланды (RFC 2565, RFC 2566, RFC 2567, RFC 2568, RFC 2569 және RFC 2639). IPP/1.1 2000 жылы жоба стандарты ретінде, ал 2001, 2003 және 2015 жылдары қолдау құжаттарымен (RFC 2910, RFC 2911, RFC 3196, RFC 3510 RFC 7472) бірге жарияланды. IPP/1.1 2017 жылғы қаңтарда ұсынылатын стандарт ретінде жаңартылды (RFC 8010, RFC 8011) және 2018 жылғы маусымда Internet Standard 92 (STD 92) ретінде қабылданды. IPP 2.0 2009 жылы PWG кандидаттық стандарты ретінде жарияланды (PWG 5100.10 2009) және IPP 1.1-ден асып түсетін қосымша сәйкестік талаптары бар екі жаңа IPP нұсқасын (2.0 принтерлер үшін және 2.1 басып шығару серверлері үшін) анықтады. 2011 жылы оны өндірістік принтерлер үшін қосымша 2.2 нұсқасын анықтайтын кандидаттық стандарт алмастырды (PWG 5100.12 2011). Бұл ерекшелік 2015 жылы толық PWG стандарты (PWG 5100.12 2015) ретінде жаңартылды және бекітілді. IPP Everywhere 2013 жылы жарияланды және клиенттік құрылғылардан «драйверсіз» басып шығаруды қолдайтын принтерлерге ортақ базаны қамтамасыз етеді. Ол IPP негізінде құрылған және принтерлер қолдауы тиіс құжат пішімдерінің тізімі сияқты өзара іс-қимылдың қосымша ережелерін анықтайды. 2016 жылы тиісті өзін-өзі сертификаттау нұсқаулығы және құралдар жинағы жарияланды, бұл принтер өндірушілері мен басып шығару серверлерін жүзеге асырушыларға өз шешімдерін жарияланған спецификацияға сәйкес сертификаттауға және PWG-нің IPP Everywhere принтерлері бетінде тізімге енгізуге мүмкіндік берді.