Кіріспе

Мобильді IP (немесе MIP) – Интернет-инженерлік жұмыс тобының (IETF) стандартты байланыс протоколы, ол мобильді құрылғы пайдаланушыларына тұрақты IP-мекенжайды сақтай отырып, бір желіден екінші желіге көшуге мүмкіндік береді. IPv4 үшін Мобильді IP IETF RFC 5944-те сипатталған, ал кеңейтулер IETF RFC 4721-де анықталған. Мобильді IPv6, келесі буын Интернет протоколы IPv6 үшін IP мобильділігін іске асыру, RFC 6275-те сипатталған.

Кіріспе

Мобильді IP Интернетте IP-датаграммаларды орналасуға тәуелсіз маршруттап жіберуге мүмкіндік береді. Әрбір мобильді түйін өзінің ағымдағы орнына қарамастан, үй мекенжайымен анықталады. Үй желісінен алыс болғанда, мобильді түйін өзінің қазіргі орнын көрсететін күтім мекенжайымен байланыстырылады, ал оның үй мекенжайы үй агентіне тоннельдің жергілікті нүктесімен байланыстырылады. Мобильді IP мобильді түйіннің үй агентімен қалай тіркелетінін және үй агентінің тоннель арқылы мобильді түйінге датаграммаларды қалай бағыттайтынын көрсетеді.

Қолданбалар

Көптеген қолданбаларда (мысалы, VPN, VoIP) желілік байланыстың және IP-адрестің күрт өзгеруі мәселе тудыруы мүмкін. Мобильді IP үздіксіз және бірқалыпты Интернет байланысын қамтамасыз ету үшін әзірленген. Мобильді IP көбінесе пайдаланушылар өздерінің мобильді құрылғыларын бірнеше LAN поджелілерінде тасымалдауы қажет болатын сымды және сымсыз ортада қолданылады. Мысалдарға, IP-ні DVB, WLAN, WiMAX және BWA арқылы, бірін-бірі жабатын сымсыз жүйелер арасындағы роуминг жатады. 3G сияқты ұялы жүйелерде интернет қолданушылары ұялы мұнаралар арасында көшкен кезде деректер байланысы деңгейінде қолдау және роуминг механизмдерін қамтамасыз ететіндіктен, Мобильді IP қажет емес. Дегенмен, ол көбінесе 3G жүйелерінде әртүрлі пакеттік деректерді қызметке беру түйіні (PDSN) домендері арасында үздіксіз IP мобильділігін қамтамасыз ету үшін қолданылады.

Даму

Мобильді IP техникасының жетілдірілуі, мысалы RFC 5380-де анықталған Мобильді IPv6 және Иерархиялық Мобильді IPv6 (HMIPv6), белгілі бір жағдайларда процестерді қауіпсіз және тиімді ету арқылы мобильді байланысты жақсарту мақсатында жасалып жатыр. Мобильді IPv6 үшін жылдам қолдау алмасу IETF RFC 5568-де сипатталған. Зерттеушілер қазіргі МИП-тің қажет ететіндей, алдын ала орналастырылған инфрақұрылымсыз мобильді желілерді қолдауды құруда. Мұндай мысалдың бірі – Мобильді желілер үшін интерактивті протокол (IPMN), ол желінің шеттерінен интеллектуалды сигнализация арқылы, IP нүктелері мен қосымша қабат модулі арасындағы байланыс арқылы, қалыпты IP желісінде мобильділікті қолдауға мүмкіндік береді, соның ішінде қызмет сапасын жақсартады. Зерттеушілер Мобильді IPv6 қолдауымен бүкіл кішіжелілер арасындағы мобильді желілерді қолдау үшін де жұмыс істеп жатыр. Мұндай мысалдың бірі – IETF Network Mobility Working Group тобының Желілік мобильділік негізгі қолдау протоколы (NEMO), ол жылжып тұратын және Интернеттегі әртүрлі нүктелерге қосылатын мобильді желілердің мобильділігін қолдайды. Бұл протокол Мобильді IPv6-ның кеңейтімі болып табылады және желі жылжыған кезде мобильді желідегі әрбір түйін үшін сессияның үздіксіздігін қамтамасыз етеді.

Терминдердің анықтамасы

Үйдегі желі Мобильді құрылғының үй желісі – құрылғы өзінің анықтамалық IP-мекенжайын (үй мекенжайын) алатын желі. Үй мекенжайы Мобильді құрылғының үй мекенжайы – құрылғыға оның үй желісінде тағайындалған IP-мекенжай. Шетелдік желі Шетелдік желі – мобильді құрылғы үй желісінен алыс болғанда жұмыс істейтін желі. Қамқорлық мекенжайы Мобильді құрылғының қамқорлық мекенжайы – құрылғы шетелдік желіде жұмыс істеген кездегі желілік IP-мекенжайы. Үй агенті Үй агенті – мобильді құрылғының үй желісіндегі маршрутизатор, ол құрылғы үйден тыс жерде болғанда оған деректерді жеткізу үшін туннельдейді. Ол құрылғының ағымдағы орналасқан жері (IP-мекенжайы) туралы ақпаратты сақтайды және бір немесе бірнеше шетелдік агенттермен бірге қолданылады. Шетелдік агент Шетелдік агент – өзінің желісіне кіретін мобильді құрылғылар туралы ақпаратты сақтайтын маршрутизатор. Шетелдік агенттер сондай-ақ Mobile IP пайдаланатын қамқорлық мекенжайларын жариялайды. Байланыс Байланыс – үй мекенжайының қамқорлық мекенжайымен байланыстырылуы.