Введение

Стандартный протокол связи Internet Engineering Task Force. Mobile IP (или MIP) — это стандартный протокол связи, разработанный Internet Engineering Task Force (IETF) и предназначенный для обеспечения возможности перемещения пользователей мобильных устройств между сетями с сохранением постоянного IP-адреса. Мобильный IP для IPv4 описан в IETF RFC 5944, а расширения к нему — в IETF RFC 4721. Мобильный IPv6, реализация мобильности IP для следующего поколения протокола Интернет IPv6, описана в RFC 6275.

Введение

Мобильный IP обеспечивает маршрутизацию IP-датаграмм в Интернете независимо от местоположения. Каждый мобильный узел идентифицируется своим домашним адресом, вне зависимости от его текущего местоположения в сети Интернет. Находясь за пределами своей домашней сети, мобильный узел ассоциируется с адресом ухода (care-of address), который указывает его текущее местоположение, а его домашний адрес ассоциируется с локальным концом туннеля к его домашнему агенту. Мобильный IP определяет процедуру регистрации мобильного узла у своего домашнего агента и способ маршрутизации датаграмм домашним агентом к мобильному узлу через этот туннель.

Приложения

Во многих приложениях (например, VPN, VoIP) внезапные изменения сетевого подключения и IP-адреса могут вызывать проблемы. Мобильный IP был разработан для обеспечения бесшовной и непрерывной связи с Интернетом. Мобильный IP чаще всего используется в проводных и беспроводных средах, где пользователям необходимо перемещать свои мобильные устройства между различными подсетями LAN. Примеры использования включают роуминг между перекрывающимися беспроводными системами, такими как IP через DVB, WLAN, WiMAX и BWA. Мобильный IP не требуется в сотовых системах, например, 3G, для обеспечения прозрачности при перемещении пользователей Интернета между сотовыми вышками, поскольку эти системы предоставляют собственные механизмы передачи данных и роуминга. Однако он часто применяется в системах 3G для обеспечения бесшовной мобильности IP между различными доменами узлов обслуживания пакетной передачи данных (PDSN).

Разработка

Разрабатываются усовершенствования технологии Mobile IP, такие как Mobile IPv6 и Hierarchical Mobile IPv6 (HMIPv6), определенные в RFC 5380, для улучшения мобильной связи в определенных ситуациях за счет повышения безопасности и эффективности процессов. Быстрая передача управления для Mobile IPv6 описана в IETF RFC 5568. Исследователи разрабатывают поддержку мобильных сетей, не требующую предварительно развернутой инфраструктуры, как это необходимо в настоящее время для MIP. Одним из примеров является Interactive Protocol for Mobile Networking (IPMN), который обещает обеспечить поддержку мобильности в обычной IP-сети, используя интеллектуальную сигнализацию между IP-адресами на конечных точках и модулем прикладного уровня, что улучшает качество обслуживания. Также ведутся работы по созданию поддержки мобильных сетей для целых подсетей с использованием Mobile IPv6. Одним из примеров является Network Mobility (NEMO) Basic Support Protocol, разработанный рабочей группой IETF Network Mobility, который поддерживает мобильность для целых мобильных сетей, перемещающихся и подключающихся к различным точкам в Интернете. Этот протокол является расширением Mobile IPv6 и обеспечивает непрерывность сеансов для каждого узла в мобильной сети во время ее перемещения.

Определение терминов

Домашняя сеть Домашняя сеть мобильного устройства – это сеть, в которой устройство получает свой идентификационный IP-адрес (домашний адрес). Домашний адрес Домашний адрес мобильного устройства – это IP-адрес, присвоенный устройству в его домашней сети. Иностранная сеть Иностранная сеть – это сеть, в которой мобильный узел работает, находясь за пределами своей домашней сети. Care of address – адрес ухода, сетевой IP-адрес устройства, когда оно работает в иностранной сети. Домашний агент Домашний агент – это маршрутизатор в домашней сети мобильного узла, который создает туннель для передачи пакетов данных мобильному узлу, когда он находится за пределами домашней сети. Он хранит актуальную информацию о местоположении (IP-адрес) мобильного узла и используется с одним или несколькими иностранными агентами. Иностранный агент Иностранный агент – это маршрутизатор, который хранит информацию о мобильных узлах, посещающих его сеть. Иностранные агенты также предоставляют адрес ухода, который используется протоколом Mobile IP. Связь (Binding) Связь – это ассоциация между домашним адресом и адресом ухода.