Кіріспе
Интернет-инженерлік жұмыс тобы жариялаған стандарт
Компьютерлік желілер инженерлігінде Интернет-стандарт – Интернетке қолданылатын технологияның немесе әдістеменің нормативтік сипаттамасы. Интернет стандарттарын Интернет-инженерлік жұмыс тобы (IETF) жасайды және жариялайды. Олар әртүрлі көздерден алынған аппараттық және бағдарламалық қамтамасыз етудің өзара жұмыс істеуіне мүмкіндік береді, бұл интернеттердің жұмыс істеуіне жағдай жасайды. Интернет жаһандық масштабқа жеткенде, Интернет стандарттары бүкіл әлемдік коммуникацияның лингва-франкасына айналды. IETF-ке инженерлік үлестер Интернет-жоба ретінде басталады, пікір сұрау ретінде жаңартылуы мүмкін және ақырында Интернет стандартына айналуы мүмкін. Интернет стандарты техникалық толыққандылығымен және пайдалылығымен сипатталады. IETF сондай-ақ Ұсынылған стандартты, толыққандылығы жетілмеген, бірақ тұрақты және жақсы қарастырылған сипаттама ретінде анықтайды. Стандарт жобасы 2011 жылы тоқтатылған аралық деңгей болды. Стандарт жобасы – Ұсынылған стандарттан кейін, бірақ Интернет стандартынан бұрынғы аралық қадам. RFC 2026-да айтылғандай: Жалпы алғанда, Интернет стандарты – тұрақты және жақсы түсінілетін, техникалық тұрғыдан тиімді, маңызды операциялық тәжірибесі бар бірнеше тәуелсіз және өзара жұмыс істей алатын іске асырылымдарға ие, кеңінен қолдауға және Интернеттің кейбір немесе барлық бөліктерінде пайдалы болып табылатын сипаттама.
Шолу
Интернет стандарты «Пікірлер туралы сұрау» (RFC) немесе RFC жиынтығы арқылы құжатталады. Стандартқа немесе стандарттың бөлігіне айналатын сипаттама Интернет жобасы ретінде басталады, және кейіннен, әдетте бірнеше түзетуден кейін, RFC редакторымен RFC ретінде қабылданып, жарияланады және «Ұсынылатын стандарт» деп белгіленеді. Кейіннен, жетілгендік деңгейі қанағаттанарлық болған кезде RFC қосымша реттік нөмірмен Интернет стандарты ретінде жаңартылады. Бұл сатылар «Стандарттар жолы» деп аталады және RFC 2026 және RFC 6410-да анықталған. «Тарихи» белгісі, «Стандарттар жолы» құрылмас бұрын жарияланған ескірген «Стандарттар жолы» құжаттарына немесе ескірген RFC-ларға қолданылады. Тек IETF, Интернет-инженерлік басқару тобы (IESG) арқылы, «Стандарттар жолы» RFC-ларын мақұлдай алады. Интернет стандарттарының толық тізімі Ресми Интернет протоколы стандарттарында сақталады. Бұрын STD 1 осы тізімнің қысқаша көрінісін сақтап келген.
Стандарттау процесі
Стандартқа ие болу – бұл Интернет стандарттау процесіндегі екі кезеңді процесс: Ұсынылған стандарт және Интернет стандарты. Бұл деңгейлер "жетілу деңгейлері" деп аталады, ал процесс "Стандарттар жолы" деп аталады. Егер RFC Стандарттар жолындағы ұсыныстың бөлігі болса, онда бірінші кезеңде стандарт ұсынылады, содан кейін ұйымдар осы Ұсынылған стандартты жүзеге асыруға бола ма деген шешім қабылдайды. RFC 6410-дағы критерийлер орындалғаннан кейін (екі жеке жүзеге асыру, кең қолданыс, қателердің болмауы және т.б.), RFC Интернет стандартына көтерілуі мүмкін. Интернет стандарттау процесі бірнеше "Ең жақсы қазіргі тәжірибе" құжаттарында, әсіресе BCP 9 (қазіргі RFC 2026 және RFC 6410) сипатталған. Бұрын үш стандарттық деңгей болған: Ұсынылған стандарт, Жоба стандарт және Интернет стандарты. RFC 6410 осы санды екі деңгейге дейін азайтты.
Ұсынылған стандарт
RFC 2026 бастапқыда ұсынылатын стандарттарды дамымаған сипаттамалар ретінде қарастырды, бірақ бұл көзқарас RFC 7127 арқылы күшін жойды. Ұсынылатын стандарт сипаттамасы тұрақты, белгілі дизайн шешімдері қабылданған, қоғамдық кең ауқымды қарастырудан өткен және оған қоғамдық қызығушылық жеткілікті деңгейде деп есептеледі. Әдетте, спецификацияны ұсынылатын стандарт деп тану үшін іске асыру немесе тәжірибелік қолданыс талап етілмейді. Ұсынылатын стандарттардың сапасы Интернетке енгізілуіне мүмкіндік береді. Дегенмен, барлық техникалық сипаттамалардағыдай, егер мәселелер анықталса немесе жақсырақ шешімдер табылатын болса, сондай-ақ осындай технологияларды кеңінен қолдану тәжірибесі жиналғанда, ұсынылатын стандарттар қайта қаралуы мүмкін. Көптеген ұсынылатын стандарттар шындығында Интернетте қолданылады және тұрақты протоколдар ретінде кеңінен пайдаланылады. Көрсетілген тәжірибе бойынша, стандарттар деңгейлерінің тізбесі бойынша толық даму әдетте өте сирек кездеседі, ал IETF-тің көптеген танымал протоколдары ұсынылатын стандарт деңгейінде қалады.
Стандарттың жобасы
2011 жылдың қазан айында RFC 6410 екінші және үшінші деңгейлерін бір Стандарт жобасына біріктірді. Алдыңғы Стандарт жобалары бұл классификациясын сақтайды. IESG екі жыл өткен соң (2013 жылдың қазанында) ескі Стандарт жобасын Ұсынылған Стандарт ретінде қайта жіктеуге құқылы.
Интернет стандарты
Интернет стандарты жоғары техникалық деңгейімен және аталған протокол немесе қызмет Интернет қауымдастығына маңызды пайда әкеледі деген жалпы сеніммен сипатталады. Әдетте, Интернет стандарттары протоколдарды, хабарлама форматтарын, схемаларды және тілдерді анықтау арқылы Интернеттегі жүйелердің өзара үйлесімділігін қамтиды. Интернет стандарты әртүрлі өндірушілер жасаған аппараттық және бағдарламалық құралдардың бірге жұмыс істеуін қамтамасыз етеді. Стандарттың болуы әртүрлі желілерді байланыстыратын бағдарламалық және аппараттық құралдарды әзірлеуді жеңілдетеді, себебі бағдарламалық және аппараттық құралдарды қабаттар бойынша дамытуға болады. Көбінесе деректерді жіберуде қолданылатын стандарттар протоколдар деп аталады. Барлық Интернет стандарттарына ЖҚТБ (STD) сериясы бойынша нөмір беріледі. Бұл серия 2013 жылға дейін өзінің алғашқы құжаты STD 1 (RFC 5000) арқылы жинақталды, бірақ бұл тәжірибе RFC 7100-де тоқтатылды. Интернет стандарттарының толық тізімін қазір RFC редакторы жүргізеді. IETF редакторына ұсынылған және RFC ретінде қабылданған құжаттар қайта қарастырылмайды; егер құжатты өзгерту қажет болса, ол қайтадан ұсынылады және жаңа RFC нөмірі тағайындалады. RFC Интернет стандартына (STD) айналғанда оған STD нөмірі беріледі, бірақ оның RFC нөмірі сақталады. Интернет стандарты жаңартылғанда оның нөмірі өзгермейді, бірақ ол басқа RFC немесе RFC жиынтығына сілтеме жасайды. Мысалы, 2007 жылы RFC 3700 Интернет стандарты (STD 1) болды, ал 2008 жылдың мамырында ол RFC 5000-мен алмастырылды. RFC 3700 тарихи мәртебе алды, ал RFC 5000 STD 1 болды. Интернет стандарттарының тізімі бастапқыда STD 1 ретінде жарияланған, бірақ бұл тәжірибе тоқтатылып, RFC редакторы жүргізетін онлайн тізімге ауыстырылды.
Интернет-инженерлік жұмыс тобы
Интернет-инженерлік жұмыс тобы (IETF) – интернет стандарттарын дамытатын басты ұйым. Ол интернет стандарттарын белгілеу үшін ашық және толыққанды құжатталған процестерді сақтайды. IETF ұсынатын ресурстарға RFC, интернет жобалары, IANA функциялары, интеллектуалдық меншік құқықтары, стандарттау процесі, сондай-ақ RFC-ні жариялау және оған қол жеткізу мүмкіндігі кіреді.
RFC-тер
Интернетке арналған техникалық ерекшеліктер мен түсіндірмелерді қамтитын құжаттар. RFC аббревиатурасы бастапқыда "Request For Comments" деген сөз тіркесінен туындаған, бірақ қазір бұл атау қолданылмайды және олар жай ғана RFC деп аталады. RFC Editor веб-сайты – интернет стандарттарының, жоба стандарттарының және ұсынылып отырған стандарттардың ресми архиві.
Зияткерлік меншік құқықтары
IETF стандарттарының бәрі тегін қарауға және оқуға қолжетімді, және оларды кез келген адам рұқсат алусыз немесе төлем жасаусыз жүзеге асыруға болады.
Стандарттау процесі
Стандартты құру процесі түзу – техникалық ереже Интернет қауымдастығы тарапынан жан-жақты қарастырылып, тәжірибе негізінде толықтырылады.
RFC жариялау және оларға қол жеткізу
Интернет жобалары қарау процесін сәтті аяқтады. Жариялану үшін RFC редакторына ұсынылды.
Интернет стандарттарының түрлері
Интернет стандарты екі жолмен қалыптасады және оларды келесілердің бірі ретінде жіктеуге болады: "де-юре" стандарттары және "де-факто" стандарттары. "Де-факто" стандарт – технологиялық қауымдастықта кеңінен қолданылу арқылы стандартқа айналады. "Де-юре" стандартты ресми стандартты әзірлейтін ұйымдар ресми түрде жасайды. Техникалық сипаттама – хаттаманың, қызметтің, процедураның, келісімнің немесе форматтың барлық қатысты аспектілерін сипаттайтын мәлімдеме. Олар браузер мен веб-сервер арасындағы деректерді беруді, веб-беттің мазмұны мен құрылымын және веб-бет идентификаторларының мағынасын анықтайды.
Интернет стандарттарының болашағы
Интернет ашық ойын алаңы ретінде қарастырылды, оны адамдар еркін пайдалануға және қауымдастықтар бақылауға мүмкіндік берілді. Дегенмен, ірі компаниялар оны өздерінің қажеттіліктеріне сәйкес етіп өзгертіп, қалыптастырды. Интернет стандарттарының болашағы да осыдан өзгеше болмайды. Қазіргі таңда Border Gateway Protocol (BGP) және Domain Name System (DNS) сияқты кеңінен қолданылатын, бірақ қауіпсіз емес протоколдар бар. Бұл, қауіпсіздікке қарағанда жаңаруға көбірек мән берілетін қалыпты жағдайды көрсетеді. Компаниялар осы мәселелерді жақсартуға қабілетті. Интернет индустрияның қолында болғандықтан, пайдаланушылар осы стандарттардағы осалдықтарды қорғау үшін бизнеске сенеуге тиіс. Пайдаланушылар мен компаниялар маршруттарды жіберіп, басқа пайдаланушылардың маршруттарын қауіпсіздігі тұрғысынан тексереді. Егер RPKI кеңінен қолданылса, одан да көп маршруттар қосылып, расталуы мүмкін. Алайда, RPKI үдеп келеді. 2020 жылдың желтоқсанына дейін, технологиялық алып Google өзінің 99% маршрутын RPKI арқылы тіркеді. Кейбір компаниялар интернет протоколдарын қорғауға бастама көтерді. Осыны одан әрі тарату қалғандарының міндеті.