Кіріспе

1500 байттан асатын пайдалы жүктемесі бар Ethernet фреймі. Компьютерлік желілерде, jumbo фреймдер – IEEE 802.3 стандартымен белгіленген 1500 байттан асатын пайдалы жүктемесі бар Ethernet фреймдері. Jumbo фреймдер үшін жүктеме шегі өзгеріп отырады: ең көп қолданылатыны 9000 байт, бірақ одан кіші және үлкен шектер де бар. Көптеген Gigabit Ethernet коммутаторлары мен Gigabit Ethernet желілік интерфейс контроллерлері, сондай-ақ кейбір Fast Ethernet коммутаторлары мен Fast Ethernet желілік интерфейс карталары jumbo фреймдерді қолдай алады.

Құрылуы

Әрбір Ethernet фреймі желі арқылы өтетін кезде өңделуі керек. Бір үлкен фреймнің мазмұнын өңдеу, сол мазмұн кішкентай фреймдерге бөлініп өңделгеннен жақсырақ, себебі бұл үзілістерді азайту арқылы қолданыстағы CPU уақытын тиімдірек пайдаланады. Бұл сондай-ақ қосымша байттар санын азайтады және өңдеуді қажет ететін фреймдердің санын кемітеді. Бұл, әрқайсысы бір парақтан тұратын бірнеше конверттердің орнына қағаздар жиынтығын физикалық түрде поштамен жіберуге ұқсас, конверттерді үнемдеп, сұрыптауға кететін уақытты қысқартады. Jumbo фреймдер 1998 жылы Alteon WebSystems оларды ACEnic Gigabit Ethernet адаптерлерінде енгізген кезде кеңінен танымал болды. Көптеген басқа да өндірушілер осы өлшемді қабылдады; алайда, jumbo фреймдер ресми IEEE 802.3 Ethernet стандартының құрамына кірмейді.

Бала асырап алу

Jumbo фреймдер үстірткі шығындарды және процессор циклдарын азайтуға мүмкіндік береді және соңынан соңына дейінгі TCP өнімділігіне оң әсер етеді. Jumbo фреймдердің болуы желілік задердеуге, әсіресе, төмен өткізу қабілеті бар желілерде кері әсер етуі мүмкін. Соңынан соңына дейінгі қосылымда қолданылатын кадр мөлшері әдетте аралық сілтемелердегі ең кішкентай кадр мөлшерімен шектеледі. 802.5 Token Ring 4464 байт MTU-мен фреймдерді қолдай алады, FDDI 4352 байт, ATM 9180 байт және 802.11 7935 байт MTU-мен тасымалдай алады. IEEE 802.3 Ethernet стандарты бастапқыда 1500 байт MTU фреймдерін, 1518 байт жалпы кадр мөлшерін (1522 байт IEEE 802.1Q VLAN/QoS таңбасымен) қолдауға міндетті болды. IEEE 802.3as жаңартуы көптеген жалпы тақырыптарды, тіркемелерді және капсулаларды біріктіріп, 482 байтқа дейін тақырып пен тіркемелерді қамтитын «қаптама» тұжырымын жасады, соның нәтижесінде IEEE 802.3 қолдаған ең үлкен Ethernet фреймі 2000 байтқа дейін жетті. Jumbo фреймдер үшін 9000 байтты артықшылықты жүктеме мөлшері ретінде пайдалану Internet2 бірлескен инженерлік тобы мен АҚШ федералды үкіметтік желілері арасындағы талқылаулардың нәтижесінде туындады. Олардың ұсынысын барлық басқа ұлттық ғылыми-зерттеу және білім беру желілері қабылдады. Өндірушілер де 9000 байтты стандартты MTU мөлшері ретінде қабылдады, ethernet тақырыптарын қоса алғанда, жалпы jumbo фреймі 9014 және 9022 байт арасында. Көптеген Ethernet құрылғылары 9216 байтқа дейінгі jumbo фреймдерді қолдай алады. IEEE 802.1AB 2009 және IEEE 802.3bc 2009 стандартты Ethernet-ке ең үлкен кадр ұзындығын анықтау үшін LLDP ашуын қосты (TLV 4-ші түрі). Бұл портта екі октеттік өріс арқылы кадр ұзындығын анықтауға мүмкіндік береді. IEEE 802.3 2015 нұсқасына сәйкес, рұқсат етілген мәндер: 1518 (тек негізгі фреймдер), 1522 (802.1Q таңбасы бар фреймдер) және 2000 (көп таңбасы бар, қаптама фреймдер).

Қателерді анықтау

Жұмбас фреймдердегі қателер Ethernet-тің қарапайым CRC32 қателерді анықтау және UDP мен TCP-нің қарапайым қосымша тексеру сомаларымен байқалмай қалуы мүмкін: пакет өлшемі ұлғайған сайын бірнеше қателердің бір-бірін жою ықтималдығы артады. IETF ұсынған тәсілдердің бірінде жұмбас фреймдерді қолдану үшін Ethernet-тен жоғары желілік протокол қабатында қосымша CRC есептеу арқылы қызмет деректерінің тұтастығын сақтау керек. Ағын бақылауды жеткізу протоколы (SCTP) (RFC 4960) және iSCSI (RFC 7143) Castagnoli CRC полиномын пайдаланады. Castagnoli полиномы 0x1EDC6F41 бір Ethernet MTU-дан (деректер сөзінің ұзындығы 16,360 битке дейін) HD=6 Хамминг қашықтығына және 114,663 битке дейін HD=4-ке жетеді, бұл Ethernet MTU ұзындығынан 9 еседен астам. Бұл Ethernet CRC стандартты полиномымен салыстырғанда MTU өлшемді деректер сөзінде қателерді анықтау мүмкіндігіне екі қосымша бит қосады, ал 72 кбит-ке дейінгі және одан да үлкен деректер сөздері үшін HD=4 мүмкіндігінен бас тартпайды. Деректер бөліктерін өңдеуге арналған жалпы мақсаттағы тасымалдауда және SCSI деректерін тасымалдауға арналған TCP тасымалдауында Castagnoli CRC полиномын қолдау, Ethernet MTU-ның ұлғаюы қателерді анықтаудың айтарлықтай төмендеуіне әкелетін жағдайда да, қателерді анықтау деңгейін жақсартады.

Конфигурациясы

Желілік жабдықтарда ең үлкен jumbo фреймінің мөлшері жабдықтың конфигурация интерфейсіне байланысты, ең үлкен фрейм мөлшері (ең үлкен 2-деңгей пакетінің мөлшері, фрейм тақырыбын қоса) немесе ең үлкен тарату бірлігі (ең үлкен 3-деңгей пакетінің мөлшері, фрейм тақырыбын қоспай) арқылы көрсетілуі мүмкін. Jumbo фреймдерге конфигурацияланған және конфигурацияланбаған құрылғылардың қосымша желісінде өнімділік мәселелері туындауы мүмкін.

Жарық кеңістігінің тиімділігі

Jumbo фреймдер хосттардағы Ethernet және желілік өңдеудің тиімділігін протоколдың үстеме шығынын азайту арқылы арттыра алады, келесі мысалда көрсетілгендей, IPv4 арқылы TCP-де. Хосттардың өңдеуге жұмсалатын шығыны пайдалы жүктеме өлшеміне қарай азаюы мүмкін (осы мысалда шамамен алты есе жақсарады). Бұл маңызды ма, жоқ па, бұл хосттағы пакеттердің қалай өңделуіне байланысты. Желілік интерфейс контроллерінің TCP жүктемесін қолданатын хост, өзінің процессормен фреймдерді өңдейтін хостқа қарағанда аз пайда алады. Жолақтық кеңдігі тиімділігі бойынша өткізу қабілеті 4,4%-ға өседі. + IPv4 арқылы TCP үшін фрейм деңгейіндегі жолақтық кеңдігі тиімділігі Фрейм түрі MTU 1-ші қабаттағы шығын 2-ші қабаттағы шығын 3-ші қабаттағы шығын 4-ші қабаттағы шығын Пайдалы жүктеме көлемі Жалпы берілген көлем – пайдалы жүктеме көлемі мен барлық үстеме өлшемдерінің қосындысы. Тиімділік Тиімділік пайдалы жүктеме көлемін жалпы берілген көлемге бөлу арқылы есептеледі. Стандарт 1500 preamble8 байт IPG12 байт фрейм басқарышы14 байт FCS4 байт IPv4 басқарышы20 байт TCP басқарышы20 байт 1460 байт 1538 байт 94.93% Jumbo 9000 preamble8 байт IPG12 байт фрейм басқарышы14 байт FCS4 байт IPv4 басқарышы20 байт TCP басқарышы20 байт 8960 байт 9038 байт 99.14% Сілтеме үшін басқа фрейм өлшемдері IEEE 802.11 A MSDU 7935 PLCP preamble & header24 байт IPG өзгеріп отырады фрейм басқарышы & қауіпсіздік үстемесі52 байт FCS4 байт IPv4 басқарышы20 байт TCP басқарышы20 байт 7895 байт 8015 байт + IPG көлемі < 98.5% IEEE 802.11 стандартты Ethernet-ке қосылған 1500 PLCP preamble & header24 байт IPG өзгеріп отырады фрейм басқарышы & қауіпсіздік үстемесі52 байт FCS4 байт IPv4 басқарышы20 байт TCP басқарышы20 байт 1460 байт 1580 байт + IPG көлемі < 92.4%

Желілік деректердің өткізу қабілетінің пакеттерді жіберу жылдамдығына қатысты салыстырмалы масштабталуы, пакет көлеміндегі пайдалы жүктеме мөлшерімен күрделі байланысты. Теориялық тұрғыдан алғанда, желілік бит жылдамдығы артқан сайын, эквивалентті уақыт параметрлерін сақтау үшін пакеттердің пайдалы жүктемесі тікелей пропорционалды түрде ұлғаюы керек. Дегенмен, бұл желілік жол бойындағы көптеген аралық логикалық тізбектерді қажетті ең үлкен кадр өлшемін қамтамасыз ету үшін масштабтауды білдіреді.

Үлкен кішкентай бала аяқ киімдері

Baby giant немесе baby jumbo фреймдер – IEEE Ethernet стандарттарында рұқсат етілген өлшемнен сәл ғана үлкен Ethernet фреймдері. Қосымша MPLS және Ethernet тақырыптарының көбеюі Carrier Ethernet желілерінде 1600 байтқа дейінгі фреймдерді қолдауды талап етеді. PPPoE үшін jumbo фреймдер RFC 4638 стандартында анықталған, оның мақсаты – ескі 1492 байттық шектеуді жою (алғашқыда PPP 8 байт қосымша тақырыпты қажет еткендіктен белгіленген), соның арқасында қалыпты 1500 байттық Ethernet фреймдері бөлшектеусіз жұмыс істей алады. "PPP Max Payload" таңбасы әлі де үлкен, baby jumbo емес фреймдерді қабылдай алады.

Супер-джамбо-рекеттер

Супер-джамбо фреймдер (SJF) – 9000 байттан аспайтын пайдалы жүктеме мөлшеріне ие фреймдер. Жоғары өнімділікті ұлттық ғылыми-зерттеу және білім беру желілерінің жол MTU-ын 1500 байттан 9000 байтқа дейін ұлғайту салыстырмалы түрде қиын және көбінесе ұзақ процесс болғандықтан, оны одан әрі, мүмкін 64000 байтқа дейін ұлғайту қарастырылуда. Басты фактор – жол бойындағы барлық аралық сақтау механизмдерінде қол жетімді жад буферінің мөлшерін ұлғайту. Тағы бір маңызды фактор – CRC32-нің тіпті үлкен фреймдердегі қателерді анықтау тиімділігін одан әрі азайту. IPv4-тің жалпы ұзындық өрісі және IPv6-ның пайдалы жүктеме ұзындық өрісінің әрқайсысы 16 бит көлемде, осылайша IPv6 джамбо пайдалы жүктеме опциясы 4 ГБ (2<sup>32</sup> байт) дейін деректерді жіберуге мүмкіндік береді. Дегенмен, Интернет протоколының (IP) MTU-ының бұл теориялық шектеріне тек тиісті желілік қабат инфрақұрылымына ие желілерде ғана қол жеткізіледі.

Баламалық тәсіл

Үлкен жіберу және үлкен қабылдау жүктемесі, әрбір кадрды өңдеу арқылы процессордың жүктемесін кадрдың көлеміне тәуелді емес етеді. Бұл - әрбір пакетке кететін қосымша жүкені жоюдың тағы бір тәсілі, осы мақсатта үлкен кадрлар (jumbo frames) қолданылады. Жолақтылық тұрғысынан қарағанда, үлкен кадрлар әлі де пайдалы, себебі олар дерек емес, жүктемеге жұмсалатын жолақтылық мөлшерін азайтады.