Кіріспе
Internet Protocol Flow Information Export (IPFIX) - IETF протоколы, сонымен қатар протоколды айқындайтын IETF жұмыс тобының атауы. Ол интернеттік протокол ағыны туралы ақпаратты маршрутизаторлардан, зондтардан және басқа да құрылғылардан экспорттаудың ортақ, әмбебап стандартына негізделіп құрылды, ол медиация жүйелерінде, есеп / есеп айырысу жүйелерінде және желілік басқару жүйелерінде өлшеу, есеп және есеп айырысу сияқты қызметтерді жеңілдету үшін қолданылады. IPFIX стандарты IP ағыны туралы ақпаратты экспорттаушыдан коллекторға қалай форматтау және беру керектігін айқындайды. Бұрын көптеген дерек желісі операторлары Cisco Systems-тің меншік NetFlow технологиясына трафик ағыны туралы ақпараттарды экспорттау үшін сүйенген. IPFIX стандарттарының талаптары бастапқы RFC 3917-де көрсетілген. Cisco NetFlow 9 нұсқасы IPFIX-тің негізі болды. IPFIX-тің негізгі спецификациялары RFC 7011-ден RFC 7015-ке дейін және RFC 5103-ке құжатталған.
Internet Protocol Flow Information Export (IPFIX) is an IETF protocol, as well as the name of the IETF working group defining the protocol. It was created based on the need for a common, universal standard of export for Internet Protocol flow information from routers, probes and other devices that are used by mediation systems, accounting/billing systems and network management systems to facilitate services such as measurement, accounting and billing. The IPFIX standard defines how IP flow information is to be formatted and transferred from an exporter to a collector. Previously many data network operators were relying on Cisco Systems' proprietary NetFlow technology for traffic flow information export. The IPFIX standards requirements were outlined in the original RFC 3917. Cisco NetFlow Version 9 was the basis for IPFIX. The basic specifications for IPFIX are documented in RFC 7011 through RFC 7015, and RFC 5103.
Хаттама
NetFlow протоколына ұқсас, IPFIX ағыны белгілі бір уақыт аралығында байқалған және бірқатар қасиеттерді бөлісетін кез келген сан деп санайды, мысалы, "бірдей көз, бірдей мақсат, бірдей протокол". IPFIX-ті қолдану арқылы маршрутизаторлар сияқты құрылғылар орталық бақылау станциясына әлеуетті түрде үлкен желі туралы өздерінің көзқарасы туралы хабарлай алады. IPFIX - бұл түрткілеу протоколы, яғни әрбір жіберуші IPFIX хабарламаларын қабылдаушымен ешқандай әрекеттесусіз конфигурацияланған қабылдаушыларға мерзімді түрде жібереді. IPFIX хабарламаларындағы деректердің нақты құрамы көбінесе жіберушіге байланысты. IPFIX арнайы үлгiлер көмегiмен осы хабарламалардың құрамын қабылдаушыға таныстырады. Жіберуші өзінің хабарламаларында пайдаланушы анықтаған дерек түрлерін еркін пайдалана алады, сондықтан протокол еркін кеңейтіледі және әртүрлі сценарийлерге бейімделуі мүмкін. IPFIX өзінің тасымалдау қабаты протоколы ретінде Stream Control Transmission Protocol (SCTP) протоколын артық көреді, бірақ Transmission Control Protocol (TCP) немесе User Datagram Protocol (UDP) протоколын пайдалануға да мүмкіндік береді.