Введение
Internet Protocol Flow Information Export (IPFIX) - это протокол IETF, а также название рабочей группы IETF, определяющей протокол. Он был создан на основе необходимости общего, универсального стандарта экспорта информации о потоках Интернет-протокола с маршрутизаторов, зондов и других устройств, которые используются системами посредничества, системами учета/счета и системами управления сетью для облегчения таких услуг, как измерения, учет и выставление счетов. Стандарт IPFIX определяет, как информация о потоке IP должна быть отформатирована и передана от экспортера коллектору. Ранее многие операторы сетей передачи данных полагались на запатентованную технологию NetFlow от Cisco Systems для экспорта информации о потоке трафика. Требования стандартов IPFIX были изложены в оригинальном RFC 3917. Cisco NetFlow версия 9 была основой для IPFIX. Основные спецификации IPFIX задокументированы в RFC 7011 через RFC 7015 и RFC 5103.
Internet Protocol Flow Information Export (IPFIX) is an IETF protocol, as well as the name of the IETF working group defining the protocol. It was created based on the need for a common, universal standard of export for Internet Protocol flow information from routers, probes and other devices that are used by mediation systems, accounting/billing systems and network management systems to facilitate services such as measurement, accounting and billing. The IPFIX standard defines how IP flow information is to be formatted and transferred from an exporter to a collector. Previously many data network operators were relying on Cisco Systems' proprietary NetFlow technology for traffic flow information export. The IPFIX standards requirements were outlined in the original RFC 3917. Cisco NetFlow Version 9 was the basis for IPFIX. The basic specifications for IPFIX are documented in RFC 7011 through RFC 7015, and RFC 5103.
Протокол
Как и протокол NetFlow, IPFIX рассматривает поток как любое количество пакетов, наблюдаемых в определенном временном интервале и имеющих ряд общих свойств, например, "один источник, одно назначение, один протокол". Используя IPFIX, устройства, такие как маршрутизаторы, могут информировать центральную станцию мониторинга о своем представлении о потенциально большей сети. IPFIX является протоколом "push", то есть каждый отправитель периодически отправляет сообщения IPFIX на конфигурированные приемники без какого-либо взаимодействия со стороны приемника. Фактический состав данных в сообщениях IPFIX в значительной степени зависит от отправителя. IPFIX представляет получателю структуру этих сообщений с помощью специальных шаблонов. Отправитель также может использовать в своих сообщениях пользовательские типы данных, поэтому протокол свободно расширяется и может адаптироваться к различным сценариям. IPFIX предпочитает протокол передачи управления потоком (SCTP) в качестве протокола транспортного слоя, но также позволяет использовать протокол управления передачей (TCP) или протокол пользовательской датграммы (UDP).