Кіріспе

Интернет пошта протоколдары отбасы

Есептеу техникасында, Пошта кеңсесі протоколы (POP) – электрондық пошта клиенттері электрондық пошта серверінен электрондық поштаны алу үшін пайдаланатын интернет стандартты протокол. Бүгінде POP-тың 3-ші нұсқасы (POP3) ең көп қолданылатын нұсқа болып табылады. IMAP протоколымен бірге, электрондық поштаны алу үшін ең көп таралған протоколдардың бірі болып есептеледі.

Мақсаты

Пошта протоколы Интернет протоколы (IP) желісі арқылы пайдаланушы клиенттік бағдарламасына пошта серверінде сақталатын пошта жәшігіне (maildrop) қол жеткізуді қамтамасыз етеді. Протокол хаттар үшін тізімдеу, алу және жою операцияларын қолдайды. POP3 клиенттері қосылады, барлық хабарламаларды алады, оларды клиенттік компьютерге сақтайды және соңында серверден жояды. POP және оның процедураларының бұл дизайны пайдаланушылардың уақытша Интернет қосылыстарының болуымен, мысалы, телефондық қосылым арқылы қол жеткізумен байланысты болды, бұл пайдаланушыларға қосылғанда электрондық поштаны алуға және кейіннен оффлайн режимінде алынған хабарламаларды қарауға және өңдеуге мүмкіндік берді. POP3 клиенттері хабарламаларды серверде қалдыру опциясына да ие, ал бұл режимде клиенттер UIDL командасын (бірегей идентификатор тізімі) пайдаланып анықталған жаңа хабарламаларды ғана жүктейді. Керісінше, Интернеттік хабар алмасу протоколы (IMAP) әдетте барлық хабарламаларды серверде қалдыру үшін жасалған, бұл бірнеше клиенттік бағдарламалармен басқаруға және онлайн және оффлайн режимдерін қолдауға мүмкіндік береді. POP3 сервері қызмет сұрауларын 110 нөміріндегі порт арқылы қабылдайды. POP3 үшін шифрланған байланыс протокол басталганнан кейін, қолдау көрсетілсе, STLS командасын пайдалану арқылы немесе POP3S арқылы сұралады, ол серверге Transport Layer Security (TLS) немесе Secure Sockets Layer (SSL) арқылы 995 нөміріндегі TCP порты арқылы қосылады. Клиентке қол жетімді хабарламалар POP3 сессиясы пошта жәшігін ашқанда анықталады және сол сессияға тән хабарлама нөмірімен немесе, мүмкіндігі болса, POP сервері хабарламаға тағайындаған бірегей идентификатормен анықталады. Бұл бірегей идентификатор тұрақты және пошта жәшігі үшін бірегей болып табылады, бұл клиентке әртүрлі POP сессияларында бірдей хабарламаға қол жеткізуге мүмкіндік береді. Хабарламалар алынып, жою үшін хабарлама нөмірімен белгіленеді. Клиент сессиядан шыққанда жоюға белгіленген хабарламалар пошта жәшігінен жойылады.

Тарих

Пошта протоколының алғашқы нұсқасы POP1, 1984 жылы RFC 918-де Джойс К. Рейнольдспен анықталған. POP2 1985 жылы RFC 937-де сипатталған. POP3 – ең көп қолданылатын нұсқа. Ол 1988 жылы RFC 1081-ден бастау алды, бірақ ең соңғы спецификациясы RFC 1939 болып табылады, ол кеңейту механизмімен (RFC 2449) және RFC 1734-тегі аутентификация механизмімен жаңартылды. Бұл Pine, POPmail және басқа да ерте пошта клиенттері сияқты көптеген POP іске асыруларына әкелді. POP3-тің бастапқы спецификациясы тек шифрланбаған USER/PASS кіру механизмін немесе Беркли rhosts қолжетімділік бақылауын қолдаса, бүгінде POP3 пайдаланушының электрондық поштасына рұқсатсыз қол жеткізуден қорғаудың әртүрлі деңгейлерін қамтамасыз ету үшін бірнеше аутентификация әдістерін қолдайды. Көбісі POP3 кеңейту механизмдері арқылы қамтамасыз етіледі. POP3 клиенттері AUTH кеңейтуі арқылы SASL аутентификация әдістерін қолдайды. MIT Project Athena сондай-ақ Kerberized нұсқасын жасады. RFC 1460 APOP-ты негізгі протоколға енгізді. APOP – бұл MD5 хэш-функциясын пайдаланатын, қайта ойнату шабуылдары мен ортақ құпияны ашуды болдырмауға бағытталған жауап-шақыру протоколы. APOP-ты іске асыратын клиенттерге Mozilla Thunderbird, Opera Mail, Eudora, KMail, Novell Evolution, RimArts' Becky!, Windows Live Mail, PowerMail, Apple Mail және Mutt кіреді. RFC 1460 RFC 1725-пен ескірді, ал RFC 1939 оны ескірген деп жариялады.

POP4

POP4 тек қана негізгі папкаларды басқару, көп бөлімді хабарламаларды қолдау және IMAP-пен бәсекелесу үшін хабарламалардың белгілерін басқаруды қамтитын бейресми ұсыныс ретінде ғана бар; алайда, оның дамуы 2003 жылдан бері тоқтап қалды. Қазіргі таңда екі POP4 серверлік іске асырылуы белгілі. 2013 жылдың қазан айынан бастап POP4.org домені мен веб-сайты simbey.com компаниясымен басқарылады, ол басқа POP4 серверін де іске асырады.

Кеңейтулер мен ерекшеліктер

RFC 2449-да жалпы кеңейтулерді қолдауға және TOP және UIDL сияқты қосымша командаларға қолдау көрсетуді ұйымдастырылған түрде жариялау үшін кеңейту механизмі ұсынылды. RFC кеңейтулерді қолдауға шақыруды көздемеді және POP3-тің негізгі қызметі пошта жәшігін басқарудың жүктеу және жою қажеттіліктерін қарапайым түрде қолдау екенін қайта растады. Кеңейтулер мүмкіндіктер деп аталады және CAPA командасы арқылы тізімделеді. APOP-тан басқа, қосымша командалар бастапқы мүмкіндіктер жинамына енгізілді. ESMTP (RFC 5321) үлгісімен, X әрпімен басталатын мүмкіндіктер жергілікті мүмкіндіктерді көрсетеді.

СТАРТТЛС

STARTTLS кеңейтуі Transport Layer Security (TLS) немесе Secure Sockets Layer (SSL) қауіпсіздігін стандартты POP3 порты арқылы STLS командасын қолдану арқылы келісуге мүмкіндік береді, балама портты пайдаланудың орнына. Кейбір клиенттер мен серверлер TCP 995 портын (POP3S) қолданатын баламалы порт әдісін пайдаланады.

SDPS

Demon Internet POP3-ке доменде бірнеше шотты пайдалануға мүмкіндік беретін кеңейтулер енгізді және осылайша Standard Dial up POP3 Service (SDPS) деп белгілі болды. Әр шотқа кіру үшін пайдаланушы аты хост атауын қамтиды, мысалы, john@hostname немесе john+hostname. Google Apps та осы әдісті қолданады.

Керберлік пошта кеңсесі протоколы

Компьютерлік есептеуде жергілікті электрондық пошта клиенттері TCP/IP қосылысы арқылы қашықтағы серверден электрондық поштаны алу үшін Kerberized Post Office Protocol (KPOP) – қосымша қабаттағы интернет стандартты протоколын пайдалана алады. KPOP протоколы POP3 протоколы негізінде құрылған, ерекшелігі – ол Kerberos қауіпсіздігін қосады және әдепкі бойынша 110 портының орнына 1109 TCP порты арқылы жұмыс істейді. Пошта серверінің бағдарламалық жасақтамасының бір түрі Cyrus IMAP серверінде табылады.