Введение
Канадский разработчик программного обеспечения, специалист по веб-стандартам. Соавтор спецификации XML. Работал в Amazon Web Services с декабря 2014 года по май 2020 года, после чего уволился из-за опасений по поводу увольнения сотрудников, сообщающих о нарушениях. Ранее работал в Google, Sun Microsystems и Digital Equipment Corporation (DEC). Брей также основал или был соучредителем нескольких стартапов, таких как Antarctica Systems.
Web standards
Co author of XML specification He worked for Amazon Web Services from December 2014 until May 2020 when he quit due to concerns over the terminating of whistleblowers. Previously he has been employed by Google, Sun Microsystems and Digital Equipment Corporation (DEC). Bray has also founded or co founded several start ups such as Antarctica Systems.
Образование и ранние годы жизни
Брей родился 21 июня 1955 года в Альберте, Канада, где его отец работал в Службе экспериментальных ферм Доминиона в Форт-Вермильоне. Он вырос в Бейруте, Ливан, и вернулся в Канаду, чтобы учиться в Университете Гюльф в Гюльфе, Онтарио. Он окончил университет в 1981 году, получив степень бакалавра наук с двойной специализацией по математике и информатике. В 2009 году он вернулся в Гюльф, чтобы получить почетную докторскую степень. Тим так объяснил свой переход от математики к информатике: "В математике я изнурительно работал, чтобы получить оценки "C", а в информатике работал гораздо меньше и получал "A" – и понял, что за это хорошо платят".
Карьера
Брей присоединился к Digital Equipment Corporation (DEC) в Торонто в качестве специалиста по программному обеспечению. В 1983 году Брей покинул DEC и перешел в Microtel Pacific Research. В 1987 году он присоединился к проекту "Новый Оксфордский словарь английского языка" (OED) в Университете Ватерлоо в качестве менеджера. В это время Брей работал с SGML, технологией, которая впоследствии стала ключевой как для Open Text Corporation, так и для его работы по стандартизации XML и Atom. С начала 2004 года до начала 2010 года Брей занимал должность директора по веб-технологиям в Sun Microsystems. Он покинул Google в марте 2014 года, отказавшись переезжать в Силиконовую долину из Ванкувера. В декабре 2014 года он начал работать в Amazon Web Services (AWS). Брей покинул AWS в мае 2020 года, разочарованный отношением компании к информаторам, выразившим обеспокоенность по поводу безопасности работников складов в связи с пандемией COVID-19. Брей занимал должность вице-президента, отметив в своем блоге, что "вице-президенты не должны публично идти против компании", и высоко оценивал AWS, однако был недоволен увольнением своих коллег. В настоящее время он занимается консалтингом в области веб- и издательских технологий. В 1999 году он был привлечен Netscape вместе с Раманатаном В. Гухой для работы над Xml.com, который предложил улучшить пользовательский опыт веб-клиентов и производительность веб-серверов посредством архитектуры Transform Aggregate send XML Interact – эта предлагаемая система очень похожа на парадигму Ajax, получившую широкое распространение примерно в 2005 году.
W3C TAG
В период с 2001 по 2004 год он был назначен Тимом Бернерсом-Ли в Техническую архитектурную группу W3C.
Атом
До октября 2007 года Брей был сопредседателем рабочей группы Atompub в Internet Engineering Task Force вместе с Полом Хоффманом. Atom — это формат веб-синдикации, разработанный для решения проблем, выявленных в формате RSS 2.0.
JSON
Брей работал с рабочей группой IETF JSON в 2013 и 2014 годах, будучи редактором RFC 7159 – спецификации формата обмена данными JSON, которая заменила RFC 4627 и освещала лучшие практики обеспечения совместимости, выпущенной в марте 2014 года. Он также отредактировал RFC 8259, представляющую собой дальнейшую редакцию спецификации JSON.
Программное обеспечение
Брей разработал программные приложения, включая Bonnie, которая послужила вдохновением для Bonnie++, инструмента для тестирования производительности файловой системы Unix; Lark, первый процессор XML; и APE, средство для тестирования протокола Atom.
Экологизм
Начиная с 2018 года Брей заявил о себе как защитник окружающей среды в связи со спором вокруг трубопровода Trans Mountain. 18 апреля 2018 года он был арестован за нарушение судебного предписания во время демонстрации на объекте Trans Mountain в Бернаби, Канада. Он также подписал открытое письмо от лидеров бизнеса правительству Британской Колумбии и впоследствии стал публично выступать против этого проекта. В 2019 году Брей был единственным вице-президентом Amazon, подписавшим письмо акционерам Amazon с призывом прекратить поддержку Amazon Web Services в области добычи нефти.