Кіріспе

Канадалық бағдарламалық құралдарды жасаушы. Веб стандарттары. XML спецификациясының бірлескен авторы. Ол 2014 жылдың желтоқсанынан 2020 жылдың мамырына дейін Amazon Web Services компаниясында жұмыс істеді, бірақ хабар берушілерді қызметтен босату туралы алаңдаулар туындаған соң жұмыстан кетті. Бұрын ол Google, Sun Microsystems және Digital Equipment Corporation (DEC) компанияларында қызмет еткен. Брей сонымен қатар Антарктида жүйелері сияқты бірнеше стартаптарды немесе олардың құрылуына қатысқан.

Білім және ерте өмір

Брей 1955 жылғы 21 маусымда Канаданың Альберта провинциясында дүниеге келді, онда оның әкесі Форт Вермилиондағы Dominion Experimental Farm Service қызметінде жұмыс істеді. Ол Бейрут, Ливан қаласында өсті және Канадаға оқуға оралып, Онтарионың Гюльф қаласындағы Гюльф университетінде білім алды. 1981 жылы математика және компьютер ғылымдары мамандықтары бойынша ғылым бакалавры дәрежесін алды. 2009 жылы ол Гюльфке қайта оралып, құрметті докторлық диплом алды. Тим математикадан компьютер ғылымына ауысуын былай түсіндірді: "Математикада мен "C" бағасы үшін тырысып еңбек еттім, ал компьютер ғылымында "A" бағасы үшін одан әлдеқайда аз жұмыс істедім – және осы еңбегің үшін жақсы ақы алатыныңды білдім".

Мансап

Брей Торонтодағы Digital Equipment Corporation (DEC) компаниясына бағдарламалық қамтамасыз ету маманы ретінде жұмысқа орналасты. 1983 жылы Брей DEC компаниясынан Microtel Pacific Research компаниясына өтті. 1987 жылы ол Ватерлоо университетіндегі "Жаңа Оксфорд ағылшын сөздігі" (OED) жобасына менеджер ретінде қосылды. Осы кезеңде Брей SGML технологиясымен жұмыс істеді, бұл технология кейіннен Open Text Corporation және оның XML және Atom стандарттау жұмысының маңызды бөлігіне айналды. Брей 2004 жылдың басынан 2010 жылдың басына дейін Sun Microsystems компаниясында Веб-технологиялар директоры болып қызмет етті. 2014 жылдың наурызында Ванкуверден Кремнийлік аңғарға көшуге ниеті болмағандықтан Google компаниясынан кетті. 2014 жылдың желтоқсанында Amazon Web Services (AWS) компаниясында жұмыс істей бастады. Брей 2020 жылдың мамырында COVID-19 пандемиясы кезінде қойма қызметкерлерінің қауіпсіздігі туралы алаңдаушылық білдірген ашық айтқандарға AWS-тің жауабына көңілі толмағандықтан AWS-тен кетті. Брей вице-президент лауазымын атқарды, блогында "Вице-президенттер жария түрде наразылық білдірмеуі керек" деп жазды, сонымен қатар AWS-ті жоғары бағалады, бірақ әріптестерінің жұмыстан босатылуына риза болмады. Ол веб және баспа технологиялары саласындағы консалтингтік қызметпен айналысады. 1999 жылы Netscape компаниясымен және Раманатан В. Гухамен бірге Xml.com жобасы бойынша келісімшарт жасады, бұл жоба веб-клиенттердің қолданушы тәжірибесін және веб-сервер жүйесінің өнімділігін Transform Aggregate send XML Interact архитектурасы арқылы жақсартуға бағытталған болатын – бұл ұсынылған жүйе шамамен 2005 жылы танымал болған Ajax парадигмасына өте ұқсас.

W3C TAG-ы

2001 және 2004 жылдар аралығында ол Тим Бернерс Ли тағайындаған W3C Техникалық Архитектура Тобында қызмет етті.

Атом

2007 жылдың қазанына дейін Брей Пол Хоффманмен бірге Интернет-инженерлік еңбек тобының Атомға бағытталған Atompub жұмыс тобының бірлескен төрағасы болды. Atom – RSS 2.0 форматындағы кемшіліктерді жою мақсатымен жасалған веб-тарату форматы.

JSON

Брей 2013 және 2014 жылдары IETF JSON жұмыс тобымен жұмыс істеді, 2014 жылғы наурызда жарияланған RFC 7159 спецификациясының редакторы болды. Бұл спецификация RFC 4627-ні жаңартып, JSON дерек алмасу форматын және өзара үйлесімділіктің ең жақсы тәжірибелерін көрсетеді. Ол сондай-ақ JSON-ның келесі редакциясы – RFC 8259-ды өңдеді.

Бағдарламалық жасақтама

Брей бағдарламалық қолданбалар жазды, оның ішінде Бонни – Unix файлдық жүйесін сынау құралы Бонни++ үшін үлгі болған; Lark – алғашқы XML өңдегіші; және APE – Atom Protocol Exerciser.

Экология

2018 жылдан бастап Брей Транс-Маунтин құбыр жолына қатысты дау кезінде қоршаған ортаны қорғаушы ретінде таныла бастады. 2018 жылдың 18 сәуірінде ол Канаданың Бернаби қаласындағы Транс-Маунтин нысанында өткен наразылық акциясында сотқа бағынбағаны үшін қамауға алынды. Ол сондай-ақ Британдық Колумбия үкіметіне бизнес көшбасшыларының ашық хатына қол қойып, кейіннен жобаға қарсы пікір білдірді. 2019 жылы Брей Amazon компаниясының вице-президенті лауазымындағы жалғыз қызметкер болып, Amazon Web Services компаниясының мұнай өндіруді қолдауын тоқтатуға шақыратын Amazon акционерлеріне хатқа қол қойды.