Введение

Это частичный список RFC (Request for Comments – запрос комментариев). Запрос комментариев (RFC) – это публикация в серии, выпускаемая основными организациями, занимающимися технической разработкой и стандартизацией для Интернета, в частности, Internet Engineering Task Force (IETF). По состоянию на февраль 2022 года существует более 9151 RFC, однако данный список включает только те RFC, которые имеют соответствующие статьи. Полный список доступен на веб-сайте IETF. Содержание.

Цифровой список

# Заголовок Дата публикации Связанная статья Устарело заменой Примечания RFC 20 Формат ASCII для сетевого обмена 16 октября 1969 ASCII RFC 42 Типы данных сообщений 31 марта 1970 RFC 768 Протокол пользовательских дейтаграмм 28 августа 1980 UDP RFC 783 ПРОТОКОЛ TFTP (ПЕРЕСМОТР 2) Июнь 1981 TFTP RFC 1350 RFC 791 Интернет-протокол Сентябрь 1981 IPv4 RFC 792 ПРОТОКОЛ УПРАВЛЕНИЯ СООБЩЕНИЯМИ INTERNET Сентябрь 1981 ICMP RFC 793 ПРОТОКОЛ УПРАВЛЕНИЯ ПЕРЕДАЧЕЙ Сентябрь 1981 TCP RFC 9293 RFC 826 Протокол разрешения Ethernet-адресов Ноябрь 1982 ARP RFC 854 СПЕЦИФИКАЦИЯ ПРОТОКОЛА TELNET Май 1983 Telnet RFC 855 СПЕЦИФИКАЦИИ ОПЦИЙ TELNET Май 1983 RFC 862 Протокол Echo Май 1983 Echo RFC 863 Протокол Discard Май 1983 DISCARD RFC 864 Протокол генератора символов Май 1983 CHARGEN RFC 868 Протокол времени Май 1983 TIME RFC 903 Протокол обратного разрешения адресов Июнь 1984 RARP RFC 937 ПОЧТОВЫЙ ПРОТОКОЛ ВЕРСИИ 2 Февраль 1985 POP v 2 RFC 951 ПРОТОКОЛ ЗАГРУЗКИ (BOOTP) Сентябрь 1985 BOOTP RFC 959 ПРОТОКОЛ ПЕРЕДАЧИ ФАЙЛОВ (FTP) Октябрь 1985 FTP RFC 1034 ДОМЕННЫЕ ИМЕНА КОНЦЕПЦИИ И ВОЗМОЖНОСТИ Ноябрь 1987 DNS RFC 1035 ДОМЕННЫЕ ИМЕНА РЕАЛИЗАЦИЯ И СПЕЦИФИКАЦИЯ Ноябрь 1987 DNS RFC 1036 Стандарт для обмена сообщениями USENET Декабрь 1987 Usenet RFC 1055 Нестандарт для передачи IP-дейтаграмм по последовательным линиям: SLIP Июнь 1988 SLIP RFC 1058 Протокол маршрутной информации Июнь 1988 RIP v 1 RFC 1059 Спецификация и реализация сетевого протокола времени (версия 1) Июль 1988 NTP v 1 RFC 1087 Этика и Интернет Январь 1989 Интернет-этика RFC 1118 Путеводитель автостопом по Интернету Сентябрь 1989 Путеводитель автостопом по Интернету RFC 1119 Спецификация и реализация сетевого протокола времени (версия 2) Сентябрь 1989 NTP v 2 RFC 1149 Стандарт для передачи IP-дейтаграмм на птичьих носителях 1 апреля 1990 IP over Avian Carriers RFC 1157 Простой протокол управления сетью (SNMP) Май 1990 SNMP v1 RFC 1176 ПРОТОКОЛ ИНТЕРАКТИВНОГО ДОСТУПА К ПОЧТЕ ВЕРСИИ 2 Август 1990 IMAP v 2 RFC 1305 Спецификация, реализация и анализ протокола сетевого времени (версия 3) Март 1992 NTP v 3 RFC 5905 Устаревает RFC 1119, RFC 1059, RFC 958 RFC 1321 Алгоритм хеширования сообщений MD5 Апрель 1992 MD5 RFC 1350 ПРОТОКОЛ TFTP (ПЕРЕСМОТР 2) Июль 1992 TFTP Устаревает RFC 783 RFC 1436 Протокол Internet Gopher Март 1993 Gopher RFC 1441 Введение в версию 2 стандартной структуры управления сетью Интернета Апрель 1993 SNMP v 2 RFC 1459 Протокол Internet Relay Chat Май 1993 IRC RFC 1730 ПРОТОКОЛ ДОСТУПА К СООБЩЕНИЯМ INTERNET ВЕРСИИ 4 Декабрь 1994 IMAP v 4 RFC 1777 Протокол доступа к легковесным каталогам Март 1995 LDAP RFC 1855 Руководство по сетевому этикету Октябрь 1995 Сетевой этикет RFC 1918 Распределение адресов для частных Интернетов Февраль 1996 Частная сеть RFC 1928 Протокол SOCKS версии 5 Март 1996 SOCKS5 RFC 1939 Почтовый протокол ВЕРСИИ 3 Май 1996 POP v 3 RFC 1945 Протокол передачи гипертекста — HTTP/1.0 Май 1996 HTTP v 1.0 RFC 1948 Защита от атак по номерам последовательностей Май 1996 IP спуфинг RFC 1950 Спецификация формата сжатых данных ZLIB версии 3.3 Май 1996 Zlib v 3.3 RFC 1951 Спецификация формата сжатых данных DEFLATE версии 1.3 Май 1996 DEFLATE v 1.3 RFC 1952 Спецификация формата файла GZIP версии 4.3 Май 1996 Gzip v 4.3 RFC 1964 Механизм GSS API Kerberos версии 5 Июнь 1996 Kerberos; GSSAPI RFC 2080 RIPng для IPv6 Январь 1997 RIP v ng RFC 2119 Ключевые слова для использования в RFC для указания уровней требований Март 1997 Request for Comments Обновлено RFC 8174 RFC 2131 Протокол динамической конфигурации хоста Март 1997 DHCP RFC 2177 Команда IMAP4 IDLE Июнь 1997 IMAP IDLE RFC 2195 Расширение IMAP/POP AUTHorize для простой аутентификации по вызову-ответу Сентябрь 1997 CRAM MD5 RFC 2228 Расширения безопасности FTP Октябрь 1997 FTP RFC 2230 Запись делегирования обмена ключами для DNS Ноябрь 1997 Безопасный DNS RFC 2246 Протокол TLS версии 1.0 Январь 1999 TLS 1.0 RFC 2251 Протокол доступа к легковесным каталогам (v3) Декабрь 1997 LDAP v 3 RFC 2252 Протокол доступа к легковесным каталогам (v3): определения синтаксиса атрибутов RFC 2253 Протокол доступа к легковесным каталогам (v3): представление строк UTF 8 для различающихся имен RFC 2254 Строковое представление фильтров поиска LDAP RFC 2255 Формат URL LDAP RFC 2256 Краткое изложение схемы пользователей X.500(96) для использования с LDAPv3 RFC 2326 Протокол потоковой передачи в реальном времени (RTSP) Апрель 1998 RTSP RFC 2327 SDP: протокол описания сеанса Апрель 1998 SDP RFC 2328 OSPF версия 2 Апрель 1998 OSPF RFC 2351 Отображение трафика авиабронирования, продажи билетов и обмена сообщениями по IP Май 1998 MATIP RFC 2362 Протокол многопротокольной мультивещательной рассылки в разреженном режиме (PIM SM) Июнь 1998 PIM RFC 2397 Схема URL "data" Август 1998 Data: URI scheme RFC 2407 Интернет-домен интерпретации безопасности IP для ISAKMP. Ноябрь 1998 IKE RFC 2408 Протокол ассоциации безопасности Интернета и управления ключами (ISAKMP) RFC 2409 Обмен ключами Интернета (IKE) RFC 2427 Многопротокольная взаимосвязь через Frame Relay Сентябрь 1998 Frame Relay 1294, 1490 RFC 2453 RIP версия 2 Ноябрь 1998 RIP v 2 RFC 2460 Интернет-протокол, версия 6 (IPv6) Спецификация Декабрь 1998 IPv6 RFC 8200 RFC 2549 IP через Avian Carriers с качеством обслуживания 1 апреля 1999 IP через Avian Carriers RFC 2555 30 лет RFC7 апреля 1999 Прослеживает историю RFC RFC 2570 Введение в версию 3 стандартной структуры управления сетью Интернета Апрель 1999 SNMP v3 RFC 2595 Использование TLS с IMAP, POP3 и ACAP Июнь 1999 STARTTLS для IMAP, POP3 и ACAP RFC 2606 Зарезервированные имена DNS верхнего уровня Июнь 1999 Фиктивный доменное имя example. com, test, RFC 2740 OSPF для IPv6 Декабрь 1999 OSPF RFC 2743 Универсальный интерфейс прикладного программирования службы безопасности (GSS API) версии 2, обновление 1 Январь 2000 GSSAPI v 2 RFC 2744 Универсальный интерфейс прикладного программирования службы безопасности (GSS API) версии 2: привязки C RFC 2801 Интернет-протокол открытой торговли IOTP версии 1.0 Апрель 2000 Интернет-протокол открытой торговли RFC 2802 Цифровые подписи для протокола открытой торговли в Интернете (IOTP) версии 1.0 Апрель 2000 Интернет-протокол открытой торговли RFC 2810 Интернет-протокол ретрансляции чата: архитектура Апрель 2000 IRC RFC 2811 Интернет-протокол ретрансляции чата: управление каналами RFC 2812 Интернет-протокол ретрансляции чата: протокол клиента RFC 2813 Интернет-протокол ретрансляции чата: протокол сервера RFC 2853 Универсальный интерфейс прикладного программирования службы безопасности (GSS API) версии 2: привязки Java Июнь 2000 GSSAPI v 2 RFC 2865 Служба аутентификации пользователей по запросу (RADIUS) Июнь 2000 RADIUS RFC 2866 Учет RADIUS Июнь 2000 RFC 2935 Интернет-протокол открытой торговли (IOTP) Дополнение HTTP Сентябрь 2000 Интернет-протокол открытой торговли RFC 2974 Протокол объявления сеанса Октябрь 2000 SAP RFC 3504 Интернет-протокол открытой торговли (IOTP), версия 1, исправления Март 2003 Интернет-протокол открытой торговли RFC 3022 Традиционный сетевой транслятор IP-адресов (Traditional NAT) Январь 2001 NAT RFC 3031 Архитектура многопротокольной переадресации меток (MPLS) Январь 2001 MPLS RFC 3053 IPv6 Tunnel Broker Январь 2001 Tunnel Broker RFC 3056 Подключение IPv6-доменов через IPv4-облака Февраль 2001 6to4 RFC 3080 Основной протокол обмена блоками (BEEP) Март 2001 BEEP RFC 3162 RADIUS и IPv6 Август 2001 RADIUS (IPv6) RFC 3207 Расширение службы SMTP для безопасного SMTP через транспортный уровень TLS Февраль 2002 STARTTLS для SMTP RFC 3261 SIP: протокол инициации сеанса Июнь 2002 SIP RFC 3284 VCDIFF Универсальный дифференциал...

Список тематических вопросов

Устаревшие RFC указаны перечеркнутым текстом. Протокол разрешения адресов — RFC 826 Блоки Extensible Exchange Protocol — RFC 3080 Bidirectional Forwarding Detection — RFC 5880, RFC 5881 BOOTP — RFC 951 CRAM MD5 — RFC 2195 Дата и время в Интернете (ISO 8601) — RFC 3339 DEFLATE — RFC 1951 DISCARD — RFC 863 Domain Name System — RFC 1034, RFC 1035, RFC 2606, RFC 7871 Dynamic Delegation Discovery System — RFC 2168, RFC 2915, RFC 3401, RFC 3402, RFC 3403, RFC 3404, RFC 3405 Dynamic Host Configuration Protocol — RFC 1531, RFC 1541, RFC 2131, RFC 3315 (IPv6) Extensible Messaging and Presence Protocol — RFC 3920 RFC 3921 RFC 3922 ECHO protocol — RFC 862 Фictitious domain name — RFC 2606 File Transfer Protocol — RFC 114, RFC 172, RFC 265, RFC 354, RFC 765, RFC 959, RFC 2228, RFC 4217 Frame Relay — RFC 1294, RFC 1490, RFC 2427 Generic Security Services Application Program Interface — RFC 1508, RFC 1509, RFC 1964, RFC 2078, RFC 2743, RFC 2744, RFC 2853 gzip — RFC 1952 HyperText Transfer Protocol — RFC 1945 (v 1.0), RFC 2616 (v 1.1), RFC 7230 (v 1.1), RFC 7231 (v 1.1), RFC 7232 (v 1.1), RFC 7233 (v 1.1), RFC 7234 (v 1.1), RFC 7235 (v 1.1) Internet Control Message Protocol — RFC 792 Internet Group Management Protocol — RFC 966 (v 0), RFC 988 (v 0), RFC 1054 (v 1), 1112 (v 1), RFC 2236 (v 2), RFC 3376 (v 3) Internet Key Exchange — IKE RFC 2409, RFC 2407 (ISAKMP), RFC 2408 (ISAKMP), IKEv2 RFC 4306, IKEv2 RFC 4301, RFC 4310 (DNS) Internet Message Access Protocol — RFC 1176 (v 2), RFC 1730 (v 4), RFC 2060 (v 4r1), RFC 3501 (v 4r1) Internet Protocol — см. IPv4 и IPv6 IP over Avian Carriers — RFC 1149, RFC 2549 IPv4 — RFC 760, RFC 790, RFC 791 IPv6 — RFC 1883, RFC 2460, RFC 8200 IPv6 addressing — RFC 2373, RFC 3513, RFC 4291 Internet Relay Chat — RFC 1459, RFC 2810, RFC 2811, RFC 2812, RFC 2813 Internet Open Trading Protocol — RFC 2801, RFC 3504, RFC 2802, RFC 2935, RFC 3538, RFC 3867 ISCSI — RFC 3720, RFC 3783 Kerberos — RFC 1964 Lightweight Directory Access Protocol — RFC 1487, RFC 1777, RFC 2251, RFC 2252, RFC 2253, RFC 2254, RFC 2255, RFC 2256, RFC 4510, RFC 4511, RFC 4512, RFC 4513, RFC 4514, RFC 4515, RFC 4516, RFC 4517, RFC 4518, RFC 4519, RFC 4520, RFC 4521, RFC 4522, RFC 4523, RFC 4524, RFC 4525, RFC 4526, RFC 4527, RFC 4528, RFC 4529, RFC 4530, RFC 4531, RFC 4532, RFC 4533, RFC 4534 Microsoft Point to Point Encryption — RFC 2118, RFC 3078 MIKEY — RFC 3830, RFC 4650, RFC 4738, RFC 6043, RFC 6267, RFC 6509 MD5 — RFC 1321 Multiprotocol Label Switching — RFC 3031 Multipurpose Internet Mail Extensions — RFC 2045 RFC 2046 RFC 2047 RFC 2049 Network address translation — RFC 1631, RFC 2663, RFC 2993, RFC 3022, RFC 3027, RFC 3234, RFC 3489, RFC 4787, RFC 5389 Network File System — RFC 1094, RFC 1813 (v.3), RFC 3010 (v.4), RFC 3530 (v.4) Network News Transfer Protocol — RFC 977, RFC 3977 Network Time Protocol — RFC 1059 (v.1), RFC 1119 (v.2), RFC 1305 (v.3), RFC 5905 (v.4) Open Shortest Path First — RFC 1131 (v.1), RFC 1247 (v.2), RFC 1583 (v.2), RFC 2178 (v.2), RFC 2328, RFC 2740 (IPv6), RFC 5340 (IPv6) Pretty Good Privacy — RFC 1991, RFC 2440, RFC 4880 Protocol Independent Multicast — RFC 2117, RFC 2362 (SM), RFC 4602 (SM) Reverse Address Resolution Protocol — RFC 903 QUIC — RFC 9000 Post Office Protocol — RFC 918 (v.1), RFC 937 (v.2), RFC 1081 (v.3), RFC 1225 (v.3), RFC 1460 (v.3), RFC 1725 (v.3), RFC 1939 (v.3) RADIUS — RFC 2058, RFC 2059, RFC 2138, RFC 2139, RFC 2865, RFC 2866, RFC 2867, RFC 2868, RFC 2869, RFC 3162 (IPv6) Real time Transport Protocol — RFC 1889 Real Time Streaming Protocol — RFC 2326 Routing Information Protocol — RFC 1058 (v.1), RFC 1388 (v.2), RFC 1723 (v.2), RFC 2453 (v.2), RFC 2080 (v. ng) Sender Policy Framework — RFC 4408 Secure Shell 2 — RFC 4251 Session Announcement Protocol — RFC 2974 Session Description Protocol — RFC 2327 Session Initiation Protocol — RFC 3261 SHA hash functions — RFC 3174, RFC 4634 Simple Authentication and Security Layer — RFC 2222, RFC 4422 Simple Mail Transfer Protocol, Internet Message Format — RFC 196, RFC 772, RFC 821, RFC 822, RFC 2821, RFC 2822, RFC 5321, RFC 5322 Simple Network Management Protocol — RFC 1067, RFC 1098, RFC 1157 (v.1), RFC 1441 (v.2) RFC 2570 (v.3) Stream Control Transmission Protocol — RFC 2960, RFC 4960, RFC 3286 Tag URI scheme — RFC 4151 TELNET — RFC 15, RFC 854, RFC 855 Transmission Control Protocol — RFC 675, RFC 793, RFC 9293 Transport Layer Security 1.0 — RFC 2246 Trivial File Transfer Protocol — RFC 783, RFC 1350 Usenet — RFC 850, RFC 1036 Uniform Resource Identifier — RFC 3986 User Datagram Protocol — RFC 768 UTF 8 — RFC 3629 zlib — RFC 1950