Кіріспе

Уильям Ричард (Рич) Стивенс (5 ақпан 1951 – 1 қыркүйек 1999) – Солтүстік Родезияда туған американдық компьютер ғылымы саласы бойынша кітаптар авторы, әсіресе Unix және TCP/IP тақырыбындағы кітаптарымен танымал.

Өмірбаян

Ричард Стивенс 1951 жылы Солтүстік Родезияда (қазіргі Замбия) Луаншья қаласында дүниеге келген. Оның әкесі мыс өнеркәсібінде жұмыс істеген. Кейін отбасы Солт-Лейк-Сити (Юта штаты), Хёрли (Нью-Мексико штаты), Вашингтон (округ), және Фалаборова (Оңтүстік Африка) қалаларына көшіп барды. Стивенс Вирджиния штатының Уэйнсборо қаласындағы Фишберн әскери мектебінде оқыған. 1973 жылы Мичиган университетінен аэроғарыш инженері мамандығы бойынша бакалавр, 1978 жылы Аризона университетінен жүйелік инженері мамандығы бойынша магистр және 1982 жылы докторлық дәрежесін алды. 1975 жылы Тусон қаласына көшіп келіп, 1982 жылға дейін Китт Пик ұлттық обсерваториясында компьютерлік бағдарламашы болып жұмыс істеді. 1982 жылдан 1990 жылға дейін Нью-Хейвендегі (Коннектикут штаты) Health Systems International компаниясының есептеу қызметтерінің вице-президенті болды. Стивенс 1990 жылы Тусонға қайтып келді, онда автор және кеңесші ретінде мансабын жалғастырды. Ол сонымен қатар 1970 жылдары ұшуға құштар болған және жартылай уақыт ұшу нұсқаушысы болған. Стивенс 1999 жылы 48 жасында дүние салды. 2000 жылы ол қайтыс болғаннан кейін USENIX ұйымының өмір бойына жеткен үлкен жетістіктері үшін сыйлығымен марапатталды.

RFC-тер

Стивенс сонымен қатар Интернеттің "техникалық және ұйымдық ескертпелерін" тарату жолымен жүзеге асыратын Интернет Инженерлік Тобына (IETF) бірнеше Сұраныс Комментарийлері (RFC) құжаттарын бірлесіп жазды. Стивенс жазған RFC құжаттары IPv6 үшін Беркли сокеттері API-ына жаңартулармен, сондай-ақ TCP сессиялары үшін қанағаттандыруды басқарудың стандартты әдісімен айналысты. Стивенс, В. Р., және Томас, М. 1998. "IPv6 үшін кеңейтілген сокеттер API-ы", RFC 2292
Гилллиган, Р. Е., Томсон, С., Баунд, Дж., және Стивенс, В. Р. 1999. "IPv6 үшін негізгі сокет интерфейсінің кеңейтімдері", RFC 2553
Аллман, М., Паксон, В., Стивенс, В. Р. 1999. "TCP қанағаттандыруды басқару", RFC 2581