Введение

Уильям Ричард (Рич) Стивенс (5 февраля 1951 года – 1 сентября 1999 года) – американский писатель, автор книг по информатике, особенно по Unix и TCP/IP, родившийся в Северной Родезии.

Биография

Ричард Стивенс родился в 1951 году в Луаншиа, Северная Родезия (ныне Замбия), где его отец работал в медной промышленности. Позже семья переехала в Солт-Лейк-Сити (штат Юта), Херли (штат Нью-Мексико), Вашингтон (округ Колумбия) и Фалабору (Южная Африка). Стивенс учился в военной школе Фишберн в Уэйнесборо, штат Вирджиния. Он получил степень бакалавра в области аэрокосмической техники в Университете Мичигана в 1973 году, а также степень магистра (в 1978 году) и доктора философии (в 1982 году) в области системной инженерии в Университете Аризоны. В 1975 году он переехал в Тусон, где до 1982 года работал компьютерным программистом в Национальной обсерватории Китт Пик. С 1982 по 1990 год он занимал должность вице-президента по вычислительным сервисам в компании Health Systems International в Нью-Хейвене, штат Коннектикут. В 1990 году Стивенс вернулся в Тусон, где продолжил карьеру как автор и консультант. Он также был увлеченным пилотом и подрабатывал инструктором по полетам в 1970-х годах. Стивенс умер в 1999 году в возрасте 48 лет. В 2000 году он посмертно был удостоен премии USENIX Lifetime Achievement Award.

RFC

Стивенс также был соавтором нескольких документов запроса комментариев (RFC) для рабочей группы по инженерии Интернета, процесса, посредством которого распространяются "технические и организационные примечания" Интернета. RFC, разработанные Стивенсом, охватывали обновления API сокетов Berkeley для IPv6, а также стандартный метод контроля перегрузки для TCP-соединений. Стивенс, У. Р., и Томас, М. 1998. "Advanced Sockets API for IPv6," RFC 2292
Гиллиган, Р. Э., Томсон, С., Баунд, Дж., и Стивенс, В. Р. 1999. "Basic Socket Interface Extensions for IPv6," RFC 2553
Оллман, М., Паксон, В., Стивенс, У. Р. 1999. "TCP Congestion Control," RFC 2581