Кіріспе
Компьютерлік желіге қосылған құрылғыға тағайындалған атау. Компьютерлік желіде хост атауы (көнеше node name) – компьютерлік желіге қосылған құрылғыға тағайындалатын және оны электрондық байланыстың түрлі формаларында, мысалы, Дүниежүзілік желіде анықтау үшін қолданылатын атау. Хост атаулары бір сөзден немесе сөз тіркесінен тұратын қарапайым атаулар болуы мүмкін, не олар құрылымдалған болуы мүмкін. Әрбір хост атауы әдетте өнімділік және басқа да себептермен маршруттандыру пакеттері үшін кемінде бір сандық желілік мекенжаймен байланыстырылады. Интернеттегі хост атаулары домендік атаулар жүйесінің (DNS) атауын қоса алған болуы мүмкін. Хост атауының толығымен, шектеу белгілерімен бірге, ең көп дегенде 253 ASCII символынан тұруы мүмкін. Интернет стандарттарында (Request for Comments) белгілерде тек ASCII әріптері a-дан z-ға дейін (жазылу тіліне сезімтал емес), 0-ден 9-ға дейінгі сандар және минус белгісі ('-') болуы мүмкін екендігі көрсетілген. Хост атауларының бастапқы нұсқасы белгілердің әріппен басталуын және минуспен аяқталмауын талап еткен. Алайда, кейінгі нұсқа белгілердің сандармен басталуына рұқсат берді. Халықаралық домендік атаулар домендік атаулар жүйесінде ASCII тізбегі ретінде Punycode транскрипциясын пайдалана отырып сақталады. Хост атауында басқа символдар болмауы мүмкін, мысалы, астыңғы сызық (_), бірақ басқа DNS атауларында астыңғы сызық болуы мүмкін. Бұл шектеу RFC 2181 арқылы алынып тасталды. DomainKeys және қызмет жазбалары сияқты жүйелер олардың арнайы символдары хост атауларымен шатастырылмауы үшін астыңғы сызықты пайдаланады. Мысалы, http.sctp.www.example.com SCTP-ге қабілетті веб-сервер хостына (www) қызмет көрсетуші сілтемені көрсетеді. Стандартқа қарамастан, Chrome, Firefox, Internet Explorer, Edge және Safari хост атауларында астыңғы сызықтарға рұқсат береді, бірақ IE-дегі cookie файлдары хост атауының кез келген бөлігінде астыңғы сызық болса дұрыс жұмыс істемейді. Алайда, астыңғы сызықтан тұратын хост атауын шешуге тырысу дұрыс. Мысалы, example.com. Бұл RFC 7816 итеративтік сұраныс кезінде аралық DNS серверлеріне қолжетімді ақпарат мөлшерін азайту үшін қолданылады. Сұрауды азайту мүмкіндігі BIND 9.14.0 нұсқасында әдепкі бойынша қосылған. Хост атауы en.wikipedia.org DNS белгілерінен тұрады: en (хост атауы немесе жапырақ домені), wikipedia (екінші деңгейдегі домен) және org (жоғарғы деңгейдегі домен). 2600 және 3abc сияқты белгілер хост атауларында қолданылуы мүмкін, бірақ hi, HI және *hi* жарамсыз. Хост атауы толық білікті домендік атау (FQDN) болып есептеледі, егер барлық белгілер жоғарғы деңгейдегі домен атауына (TLD) дейін көрсетілген болса. Хост атауы en.wikipedia.org жоғарғы деңгейдегі домен org-пен аяқталады және осылайша толық білікті. Операциялық жүйенің DNS бағдарламалық қамтамасы бойынша, білікті емес хост атауы жүйеге конфигурацияланған әдепкі домендік атаумен автоматты түрде біріктіріліп, толық білікті домендік атауды толықтыруы мүмкін. Мысалы, MIT студенті "joe@csail" поштасына хат жіберіп, оны пошта жүйесі joecsail.mit.edu-ға жіберу үшін автоматты түрде біліктілікке ие болуы мүмкін. Жақсы хост атауын таңдау туралы жалпы ережелер RFC 1178-де сипатталған.
In computer networking, a hostname (archaically nodename) is a label that is assigned to a device connected to a computer network and that is used to identify the device in various forms of electronic communication, such as the World Wide Web. Hostnames may be simple names consisting of a single word or phrase, or they may be structured. Each hostname usually has at least one numeric network address associated with it for routing packets for performance and other reasons. Internet hostnames may have appended the name of a Domain Name System The entire hostname, including the delimiting dots, has a maximum of 253 ASCII characters. The Internet standards (Request for Comments) for protocols specify that labels may contain only the ASCII letters a through z (in a case insensitive manner), the digits 0 through 9, and the hyphen minus character (' '). The original specification of hostnames required that labels start with an alpha character, and not end with a hyphen. However, a subsequent specification permitted hostname labels to start with digits. Internationalized domain names are stored in the Domain Name System as ASCII strings using Punycode transcription. While a hostname may not contain other characters, such as the underscore character ( ), other DNS names may contain the underscore. This restriction was lifted by RFC 2181. Systems such as DomainKeys and service records use the underscore as a means to assure that their special character is not confused with hostnames. For example, http. sctp. www. example. com specifies a service pointer for an SCTP capable webserver host (www) in the domain example. com. Notwithstanding the standard, Chrome, Firefox, Internet Explorer, Edge and Safari allow underscores in hostnames, although cookies in IE do not work correctly if any part of the hostname contains an underscore character. However, it is valid to attempt to resolve a hostname that consists of an underscore. E. g. example. com. This is used by RFC 7816 to reduce the amount of information that is made available to intermediate DNS servers during an iterative query. The Query Name Minimisation feature is enabled by default in BIND 9.14.0. The hostname en. wikipedia. org is composed of the DNS labels en (hostname or leaf domain), wikipedia (second level domain) and org (top level domain). Labels such as 2600 and 3abc may be used in hostnames, but hi , hi and *hi* are invalid. A hostname is considered to be a fully qualified domain name (FQDN) when all labels up to and including the top level domain name (TLD) are specified. The hostname en. wikipedia. org terminates with the top level domain org and is thus fully qualified. Depending on the operating system DNS software implementation, an unqualified hostname may be automatically combined with a default domain name configured into the system, in order to complete the fully qualified domain name. As an example, a student at MIT may be able to send mail to "joe@csail" and have it automatically qualified by the mail system to be sent to joecsail. mit. edu. General guidelines on choosing a good hostname are outlined in RFC 1178.
Мысал
Сатурн және Юпитер – PC деп аталатын желіге қосылған екі құрылғының хост атаулары болуы мүмкін. PC желісінде құрылғылар өз хост атаулары арқылы анықталады. Құрылғылардың домендік атаулары сәйкесінше және болып табылады. Егер PC Интернетте екінші деңгейлі домендік атау ретінде тіркелсе, мысалы, , онда хосттар толыққанды домендік атаулармен және арқылы анықталуы мүмкін.