Введение

Название, присваиваемое устройству, подключенному к компьютерной сети.

В компьютерных сетях имя хоста (устаревшее название — nodename) — это метка, присваиваемая устройству, подключенному к компьютерной сети, используемая для идентификации этого устройства в различных формах электронной связи, таких как Всемирная паутина. Имена хоста могут быть простыми, состоящими из одного слова или фразы, или структурированными. Каждое имя хоста обычно связано как минимум с одним числовым сетевым адресом для маршрутизации пакетов, повышения производительности и по другим причинам. К интернет-именам хостов может быть добавлено имя системы доменных имен. Полное имя хоста, включая разделительные точки, имеет максимальную длину 253 символа ASCII. Интернет-стандарты (Request for Comments) для протоколов определяют, что метки могут содержать только буквы ASCII от a до z (без учета регистра), цифры от 0 до 9 и символ дефиса («-»). Изначальная спецификация имен хостов требовала, чтобы метки начинались с буквы и не заканчивались дефисом. Однако последующая спецификация разрешила начинать метки имени хоста с цифр. Интернационализированные доменные имена хранятся в системе доменных имен в виде строк ASCII, используя транскрипцию Punycode. Хотя имя хоста не может содержать другие символы, такие как символ подчеркивания («_»), другие DNS-имена могут содержать подчеркивание. Это ограничение было снято в RFC 2181. Такие системы, как DomainKeys и записи служб, используют символ подчеркивания, чтобы исключить его путаницу с именами хостов. Например, http.sctp.www.example.com указывает на указатель службы для веб-сервера, поддерживающего SCTP (www), в домене example.com. Несмотря на стандарт, Chrome, Firefox, Internet Explorer, Edge и Safari разрешают использовать подчеркивания в именах хостов, хотя файлы cookie в IE могут работать некорректно, если какая-либо часть имени хоста содержит символ подчеркивания. Однако допустимо попытаться разрешить имя хоста, содержащее символ подчеркивания, например, example.com. Это используется в RFC 7816 для уменьшения объема информации, предоставляемой промежуточным DNS-серверам во время итеративного запроса. Функция минимизации имени запроса включена по умолчанию в BIND 9.14.0. Имя хоста en.wikipedia.org состоит из DNS-меток en (имя хоста или домен-лист), wikipedia (домен второго уровня) и org (домен верхнего уровня). В именах хостов могут использоваться метки, такие как 2600 и 3abc, но hi, hi и *hi* недопустимы. Имя хоста считается полностью квалифицированным доменным именем (FQDN), когда указаны все метки, включая метку домена верхнего уровня (TLD). Имя хоста en.wikipedia.org заканчивается доменом верхнего уровня org и, следовательно, является полностью квалифицированным. В зависимости от реализации программного обеспечения DNS операционной системы неквалифицированное имя хоста может быть автоматически объединено с именем домена по умолчанию, настроенным в системе, для формирования полностью квалифицированного доменного имени. Например, студент MIT может отправить письмо на адрес "joe@csail", и почтовая система автоматически преобразует его в joecsail.mit.edu. Общие рекомендации по выбору хорошего имени хоста изложены в RFC 1178.

Пример

Сатурн и Юпитер могут быть именами хостов двух устройств, подключенных к сети с именем PC. В сети PC устройства адресуются по своим именам хостов. Доменные имена этих устройств – и , соответственно. Если PC зарегистрирован как домен второго уровня в Интернете, например, как , то хосты могут быть адресованы полными доменными именами и .