Кіріспе
Электрондық пошта жүйесінен автоматтандырылған хабарлама. "Қайтару хабары" немесе жай ғана "қайтару" – электрондық пошта жүйесінен автоматтандырылған хабарлама, ол бұрынғы хабарды жіберген адамға хабарламаның жеткізілмегенін (немесе басқа жеткізу мәселесі болғанын) хабарлайды. Бастапқы хабарлама "қайтарылған" деп айтылады. Бұл хабарлама дереу келуі мүмкін (төменде сипатталған себептердің бірі) немесе, егер жіберу жүйесі қайтадан жіберуге тырысса, осы тырысулар аяқталғаннан кейін бірнеше күннен соң келуі мүмкін. Қайтару хабарламасының ресми атаулары: "Жеткізілмеген хабарлама" немесе "Жеткізілмеген түйіндеме" (NDR), [Сәтсіз] "Жеткізу күйі туралы хабарлама" (DSN) немесе "Жеткізілмеген хабарлама" (NDN).
A bounce message or just "bounce" is an automated message from an email system, informing the sender of a previous message that the message has not been delivered (or some other delivery problem occurred). The original message is said to have "bounced". This feedback may be immediate (some of the causes described here) or, if the sending system can retry, may arrive days later after these retries end. More formal terms for bounce message include "Non Delivery Report" or "Non Delivery Receipt" (NDR), [Failed] "Delivery Status Notification" (DSN) message, or a "Non Delivery Notification" (NDN).
Жіктеу
SMTP технологиясы 30 жылдан астам уақыттан бері қолданылып келе жатқанмен, оның архитектурасы қалыпты және қажетсіз жүктемелердің өсуіне байланысты күшті күйзеліске ұшырауда. Электрондық пошта жүйелері электрондық хаттың нақты жіберушісіне байланысты беделдік жүйелермен жаңартылды, нәтижесінде протоколде бұрмаланған жіберуші ақпараты қолданылған жағдайда, алушының электрондық пошта серверлері хатты қабылдаудан бас тартады. Осыған байланысты, электрондық хаттардың екі түрі пайда болды: қайтарылмас (қатты) хаттар және уақытша (жұмсақ) хаттар. Екеуі де жіберушінің IP-адресінің беделіне әсер етеді, себебі электрондық пошта қызметтері (ESP) электрондық хатты пайдаланушының кіріс жәшігіне жібергенде жалпы қайтару көрсеткішін шешімді фактор ретінде қарастырады. Қысқасы, жалпы қайтару көрсеткіші – қайтарылмас және уақытша қайтару көрсеткіштерінің қосындысы болып есептеледі.
Қатты секірулер
Қатты кері қайтарылулар тұрақты болып табылады және жіберушінің IP-адресіне келтірілетін зиян жағынан жоғары бағаланады. Қатты кері қайтарылулар жіберушінің пошта сервері алушының қолжетімсіз екенін және оның осылай қалатынына жоғары ықтималдық бар екенін анықтағанда орын алады. Мысалы, электрондық поштаның алушылары келесі жағдайлардың бірінде болғанда қатты кері қайтарылулар болуы мүмкін: электрондық пошта мекенжайында немесе доменде қателік (жазылыс қатесі сияқты) немесе олардың сервері енді электрондық поштаны қабылдамайды. Мұндай жағдайда кері қайтарылған электрондық пошта мекенжайларын міндетті түрде жою керек.
Жұмсақ секіру
Жұмсақ кері қайтара берулер уақытша болып табылады. Кері қайтара берілген хабарламаны басқа уақытта қайта жіберуге талпыныс жасалуы мүмкін. Жұмсақ кері қайтара берулер электрондық поштаның алушысының почта жәшігі толып кеткенде, демек, басқа электрондық хатты сақтауға орын қалмағанда немесе қабылдауға рұқсат етілген электрондық хаттардың көлемі шектеліп қойғанда пайда болады. Сонымен қатар, жұмсақ кері қайтара беруге себеп болатын жағдайлар – алушының электрондық поштасына белгілі бір жіберушіні «спам» жіберуші деп белгілеу үшін немесе белгілі бір жіберушіні қара тізімге енгізу үшін қойылған блок. Алушының электрондық поштасының уақытша тоқтатылуы немесе сервердегі уақытша қате де жұмсақ кері қайтара берудің себептері болып табылады.
Жеткізу қателері
Поштаны жеткізу кезінде түрлі қателер туындауы мүмкін. Жіберуші кейде өзінің пошта серверінен хабарламаны жіберу мүмкін болмағаны туралы хабарлама немесе алушының пошта серверінен хабарлама қабылданғанымен, оны көрсетілген қолданушыға жеткізе алмағаны туралы хабарлама алуы мүмкін. Сервер хабарламаны жеткізуге қабылданған жағдайда, жеткізілмеген жағдайда кері хабарламаны жеткізуге де жауапкершілікті қабылдайды.
Дискіде орын жетіспеушілігіне байланысты қайталанбау
Электрондық пошта адресіне (мысалы, mymail.example, alice@mymail.example адресіне жібергенде), сервердің негізгі қатты дискісінде жеткіліксіз орын болса, пошта демоны хабарламаны көрсетілген пайдаланушының пошта жәшігіне сақтауға мүмкін болмайды.
Жеткізбейтін орынға байланысты қайтару
Электрондық хат жіберген кезде, хатты жіберген қызмет көздеген мекенжайға жетпеуі мүмкін. Мұндай жағдайда жіберуші өз пошта серверінен кері хабарлама алады. Пошта серверлерінің көздеген жерге жетпеуіне себеп болатын жиі кездесетін жағдайлар:
Көздеген мекенжайды анықтау мүмкін емес. Мысалы, домендік атау болмаса. Көздеген мекенжайбен байланыс орнату мүмкін емес. Мысалы, IP-адресі серверге тағайындалмаса немесе сервер өшірілген болса.
Жарамсыз хабарламадан қайту
Пайдаланушылар жібермеген хаттары туралы қате қайтару хабарламаларын алуы мүмкін. Мұндай жағдай, әсіресе электрондық спам немесе вирустар тарағанда болады, онда спамшы (жөнелтуші) басқа пайдаланушыға (спамның күтілетін алушысына) жалған хабарлама жіберіп, оны үшінші бір пайдаланушыдан (үшінші тараптан) келгендей көрсетуі мүмкін. Егер хабарлама күтілетін алушыға жеткізілмесе, онда қайтару хабарламасы спамшыға емес, үшінші тарапқа "қайтарылады". Бұл құбылыс кері шағылыс деп аталады.
Басқа себептері
Кітапхана болды. Мысал пошта сервері хабарлама жеткізілмейтінін білгенде (мысалы, егер Джиллдің онда пайдаланушы тіркелгісі болмаса), бастапқыда хабарламаны қабылдамас еді, демек, кері хабар жібермес еді. Оның орнына, SMTP қате кодымен хабарламаны қабылдамайтын еді. Бұл Джектің пошта серверіне (store.example мекенжайында) кері хабар жасау және жіберу міндетін жүктетер еді.
Терминология
Бойлық – автожауап берудің ерекше түрі. Автоматты жауаптар – бағдарламамен жіберілетін хаттар, олар адам пайдаланушысына емес, алынған хатқа жауап ретінде жіберіледі және қайтару мекенжайына жіберіледі. Автоматты жауаптардың басқа мысалдары – демалыс хаттары, сын-қатерлерге жауап беретін спам сүзгілеудің қиындықтары, тізім серверлерінен жауаптар және кері байланыс есептері. Бұл басқа автоматты жауаптар RFC 3834-те талқыланады: автоматты жауаптар автоматты жауапты тудырған алынған хатта көрсетілген қайтару жолына жіберілуі керек, ал бұл жауап әдетте бос қайтару жолымен жіберіледі; әйтпесе автоматты жауап берушілер автоматты жауаптарды кері-қайта жіберуде тұтқындалуы мүмкін. Қайтару жолы жеткізілген хатта SMTP хат жеткізу агенті (MDA) (әдетте хатты беру агентімен немесе MTA-мен біріктіріледі) енгізген Return Path бас өрісі ретінде көрінеді. MDA SMTP MAIL FROM командасындағы кері жолды Return Path-қа көшіреді. MDA сонымен қатар басқа MTA-лар енгізген жалған Return Path бас өрістерін алып тастайды; бұл бас өріс әдетте MAIL FROM командасында көрінген соңғы кері жолды көрсетуді кепілдендіреді. Бүгінгі таңда бұл жолдар әдетте қарапайым электрондық пошта мекенжайларына дейін қысқартылады, өйткені SMTP-нің ескі "көз маршруты" 1989 жылы қолданылмай қалды; кейбір тарихи мәліметтер үшін Sender Rewriting Scheme қараңыз. Жолдың бір ерекше түрі әлі де бар: бос жол MAIL FROM:<>, көптеген автоматты жауаптар үшін және әсіресе барлық бойлықтар үшін қолданылады. Қатаң мәнінде, бос емес қайтару жолымен жіберілген бойлықтар дұрыс емес. RFC 3834 бос емес қайтару жолындағы мекенжайдың жергілікті бөлігіне (@ алдында сол жақ) негізделген дұрыс емес бойлықтарды анықтау үшін кейбір эвристиканы ұсынады және тіпті автоматты жауаптарды анықтау үшін хаттың бас өрісін, Auto Submitted анықтайды. Бірақ хаттың бас жазуы хат деректерінің бір бөлігі болып табылады (SMTP командасы DATA), ал MTA әдетте хаттың ішіндегі мәліметтерге қарамайды. Олар конвертті, оның ішінде MAIL FROM мекенжайын (ә. к. а. Return Path, Envelope FROM, немесе "кері жол") бірақ RFC 2822 From хаттың бас өрісіндегі мәліметтерді қарастырмайды. Бұл мәліметтер BATV сияқты схемалар үшін маңызды. Бос қайтару жолы бар қалған бойлықтар жеткізілмеген хаттар туралы хабарламалар (NDR) немесе жеткізу күйі туралы хабарламалар (DSN) болып табылады. DSN-ді SMTP қызмет кеңейтуі арқылы нақты сұратуға болады, бірақ ол кеңінен қолданылмайды. Жеткізу сәтсіздігінің егжей-тегжейін нақты сұраулар көбінесе өзгермелі конверттің қайтару жолымен (VERP) жүзеге асырылады, ал олар үшін нақты сұраулар сирек жүзеге асырылады. NDR-лер SMTP-нің негізгі функциясы болып табылады. МТА хатты жіберу немесе жеткізу үшін қабылдағаннан кейін оны үндемей өшіре алмайды ("түсіре алмайды"); егер жіберу немесе жеткізу сәтсіз болса, ол бастаушыға қайтару хабарламасын жасап, жіберуі керек.
Қайталау немесе қайтару
MDA-ны есептемегенде, барлық MTA-лар электрондық поштаны басқа MTA-ға жібереді. Келесі MTA электрондық поштаны "пайдаланушы табылған жоқ", "квотадан асып кетті" сияқты SMTP қате хабарламасымен қабылдаудан бас тартуға құқылы. Осы кезде электрондық поштаны жіберген MTA хабарламаны кері қайтаруға міндетті, яғни оның авторына хабарлауы керек. Кері қайтару MTA бас тартпастан да пайда болуы мүмкін, немесе RFC 5321-де айтылғандай:
"Егер SMTP сервері электрондық поштаны жеткізу міндетін қабылдаса, кейіннен адресат дұрыс емес екенін немесе электрондық пошта басқа себептермен жеткізілмейтінін анықтаса, онда ол "жеткізілмеген электрондық пошта" туралы хабарлама құрастырып, оны жеткізілмеген электрондық поштаның авторына (кері жол көрсетілгендей) жіберуге тиіс". Бұл ереже SMTP үшін өте маңызды: атауынан көрініп тұрғандай, бұл "қарапайым" протокол, электрондық пошта ешқандай дабылсыз қара тесіктерге ұшып кетсе, ол сенімді жұмыс істей алмайды, сондықтан проблемаларды анықтап түзету үшін кері қайтарулар қажет.
Хабарларды үнсіз тастау
Бірақ қазір көбінесе спам-хаттар келіп түсуі мүмкін, олар әдетте жалған Return Path-тарды пайдаланады. Сонда МТА хабардың авторына хабарлау мүмкін болмайды, ал жалған Return Path-қа қайтару хаты тікелей үшінші, кінәсіз тарапқа жеткізіледі. Сонымен қатар, хабарды қабылдамаудың орнына (оны қайтаруды тіпті айтпағанда) үнсіз жоюдың артықшылықтары бар:
Эвристикалық түрде сүзгіленген спам. Спам-сүзгілер мінсіз емес. Мазмұнына қарай спамды қабылдамау, спамдерге сүзгіден өтетін мазмұнды табуға дейін әртүрлі нұсқаларды сынап көруге мүмкіндік беретін сынақ ортасын ұсынумен тең. Вирустар мен құрттар. Көбінесе олар жұқтырылған компьютерден автоматты түрде жіберіледі. Қайтару хаты құрттың көшірмесін қамтуы мүмкін, сондықтан ол оның таралуына себеп болуы мүмкін. RFC 5321-дің 6.2-бөлімін қайта келтіре отырып:
"Жоғарыда 7.8- және 7.9-бөлімдерде талқыланғандай, жөнелтушіге хабарламастан хатты жоюға рұқсат етіледі. Алайда, бұл өте қауіпті және хатты жеткізу немесе қайтару дәстүрін және қоғамдық үміттерді бұзады. Үнсіз хатты жою дұрыс қолданылмаса, Интернеттегі хат жүйелеріне сенімділіктің төмендеуіне әкелуі мүмкін. Сондықтан хабарламаларды үнсіз жою тек хабарламалардың айтарлықтай алаяқтық немесе басқаша қолайсыз екеніне өте сенімді болған жағдайларда қарастырылуы керек". Жіберушіні тексерудің болмауы – бұл бүгінгі SMTP-нің туа біткен кемшілігі, ол бұрынғы ескірген бастапқы маршруттарсыз. Бұл мәселе әртүрлі ұсыныстармен, ең тікелей BATV және SPF арқылы шешіледі.