Кіріспе

Блок шифрі

SEED – Корея ақпараттық қауіпсіздік агенттігі (KISA) әзірлеген блок шифрі. Ол Оңтүстік Корея индустриясында кеңінен қолданылады, бірақ басқа елдерде сирек кездеседі. Кореяда 40 биттік шифрлау жеткілікті күшті деп есептелмегендіктен, Корея ақпараттық қауіпсіздік агенттігі өз стандартын жасады, соның нәтижесінде SEED танымал болды. Алайда, бұл шешім Кореядағы веб-браузерлер арасындағы бәсекелестікті шектеді, себебі ешбір маңызды SSL кітапханасы немесе веб-браузер SEED алгоритмін қолдамады. Сондықтан, пайдаланушылар қауіпсіз веб-сайттарға кіру үшін Internet Explorer-де ActiveX бақылауын пайдалануға мәжбүр болды. 2015 жылдың 1 сәуірінде Ғылым, ақпараттық-коммуникациялық технологиялар және болашақ жоспарлау министрлігі (MSIP) 2017 жылға дейін елдің 100 ең ірі веб-сайтының кем дегенде 90 пайызынан ActiveX тәуелділігін жою жоспарын жариялады. Оның орнына, HTML5 негізіндегі технологиялар қолданылатын болады, себебі олар мобильді құрылғылар қоса алғанда, көптеген платформаларда жұмыс істейді. Министрлік жеке сектордан бастап, бұл шараны мемлекеттік веб-сайттарға да таратуды жоспарлап отыр.

Дизайн

SEED - бұл 128 биттік блоктар мен 128 биттік кілті бар 16 раундтық Фейстел желісі. Ол SAFER сияқты дискретті экспоненциалаудан туындаған екі 8 × 8 S-қорапты пайдаланады (бұл жағдайда x247 және x251 – сондай-ақ кейбір "үйлесімсіз операциялар"). Оның құрылымы MISTY1-ге рекурсиялық ұқсастығымен ерекшеленеді: 128 биттік толық шифр 64 биттік жартыларында жұмыс істейтін F функциясы бар Фейстел желісі, ал F функциясының өзі 32 биттік жартыларында жұмыс істейтін G функциясынан құралған Фейстел желісі. Дегенмен, рекурсия одан әрі жалғаспайды, себебі G функциясы Фейстел желісі емес. G функциясында 32 биттік сөз төрт 8 биттік байт ретінде қарастырылады, олардың әрқайсысы S-қораптарының бірі арқылы өтеді, содан кейін шығыс биті кіріс байттарының үшiне байланысты болатындай, күрделі логикалық функциялар жиынтығына біріктіріледі. SEED-де күрделі кілт кестесі бар, ол G функциясын қолдану арқылы шикі кілттің бірнеше айналымында және алтын қатынастан (TEA-дағыдай) алынған раундтық тұрақтылармен біріктіріліп, отыз екі 32 биттік кіші кілттерді жасайды.

Пайдалану және қабылдау

SEED бірнеше стандартты протоколдарда қолданылады: S/MIME (RFC 4010), TLS/SSL (RFC 4162), IPSec (RFC 4196) және ISO/IEC 18033 3:2010. Mozilla Gecko платформасындағы NSS бағдарламалық қамтамасыз ету кітапханасы SEED қолдауын жүзеге асырды, ал Mozilla Firefox 3.5.4 нұсқасынан бастап SEED-ті TLS шифры ретінде қолдайды. Алайда, Mozilla Firefox 27 және одан жоғары нұсқаларында SEED қолдауын әдепкі бойынша тоқтатуға шешім қабылдады, себебі SEED қолдауы Оңтүстік Кореяның ActiveX негізделген электрондық коммерциядан көшуіне ешқандай нақты пайда әкелмеді, сондай-ақ басқа браузерлер SEED негізделген шифрлау жиынтықтарын ұсынбайды. NSS әлі де SEED негізделген шифрлау жиынтықтарын қолдайды. Linux ядросы 2007 жылдан бері SEED-ті қолдайды. Bloombase өздерінің деректерді шифрлаудың толық жиынтығында SEED-ті қолдайды.