Кіріспе
Авторлық доменді қол қою практикасы (ADSP) – DKIM электрондық поштаның аутентификация схемасының қосымша мүмкіндігі, онда домен байланысты авторлар атынан электрондық хаттарды жіберген кезде қолданатын қол қою практикасын жариялай алады. ADSP 2009 жылдың тамызында RFC 5617 стандарты ретінде қабылданды, бірақ «соңғы 4 жылда іс жүзінде қолданылмағандықтан» 2013 жылдың қарашасында «тарихи» деп жарияланды.
is an optional extension to the DKIM E mail authentication
scheme, whereby a domain can publish the signing practices it adopts when relaying mail on behalf of associated authors. ADSP was adopted as a standards track RFC 5617 in August 2009, but declared "Historic" in November 2013 after " almost no deployment and use in the 4 years since "
Автордың мекенжайы
Автордың мекенжайы RFC 5322 стандартында анықталған тақырыптық өрісте көрсетілген. Егер бұл өрісте бірнеше мекенжай анықталған сирек жағдайларда, RFC 5322 стандарты оның орнына басқа өріс пайдалануды ұсынады. RFC 4407 стандартында сипатталған Жіберуші ID арқылы қамтылған, толыққандырақ "Жауапты мекенжай" адрестеріндегі домендер, 5322 From адрестеріндегі домендермен міндетті түрде сәйкес келе бермейді. Сондай-ақ, 5322 From мекенжайындағы домен, RFC 5321 стандартында анықталған конверт жіберушісінің мекенжайымен (SMTP MAIL FROM, конверт From, 5321 From деп те аталады) немесе RFC 7208 стандартында сипатталған SPF арқылы қорғалған мекенжаймен де міндетті түрде сәйкес келе бермейді.
Автордың домен қолтаңбасы
Авторлық домендік қолтаңба – DKIM қол қоятын ұйымның домендік атауы, яғни DKIM қолтаңбасының бас өрісіндегі "d" белгісі автор мекенжайындағы домендік атаумен сәйкес келетін жарамды DKIM қолтаңбасы. Бұл байланыс хабарламада табылған басқа жарамды қолтаңбаларға қарағанда авторлық домендік қолтаңбаларды жоғары бағалайды. Факты бойынша, бұл автордың DNS аймағын басқаратын тұлға, демек хабарлама авторына жауаптардың адресаты да автордың хабарламасын жібергенін көрсетеді. Көбінесе автор хабарламаны дұрыс хабарлама жіберу агенті арқылы жіберген болады. Мұндай хабарламаның сапасын кез келген жарияланған домендік қол қою ережесіне тәуелсіз тексеруге болады.
Қақпақ
ADSP спецификациясы тәуелсіз пайдаланушылары бар және поштаны тек белгіленген пошта серверлерінен ғана жіберуді шектемейтін пайдалану саясатына ие домендер үшін "белгісіз" жазбадан өзге жазба жариялауды нақты түрде ұсынбайды, себебі ұйымнан тәуелсіз жіберілген электрондық пошта қолтаңбаланбайды. Бұл ескерту қаншалықты айқын болса да, ADSP-нің мақсатын және шектеулерін түсіну қиын. ADSP авторларының бірі, әр доменнің өзінің саясатын жариялауына рұқсат берудің орнына, білікті адамдар ұстап тұратын, жойылатын домендердің жеке тізімін жариялаудың дұрыс екенін айтады. Спецификация сынақтан өтпеген прототип ретінде шығарылғанын мойындаған танымал ADSP іске асыру авторы ADSP статусын тәжірибелікке төмендетуді ұсынды. Кейіннен ол тарихи мәртебеге төмендетілді.
Тарих
Біршама уақыт ADSP ASP (Автордың қол қою тәжірибесі) немесе бастапқы SSP (Жөнелтушінің қол қою тәжірибесі) деп белгілі болды, протокол атауын анықтау үшін дауыс беру өткенге дейін. Domainkeys, DKIM-нің алдындағы нұсқасы, домен барлық электрондық поштаға қол қойса " ", әйтпесе "~" сияқты бір таңбадан тұратын шығыс қол қою саясатына ие болды. DKIM қол қоюшылардың саясатын қасақана ескермеді, сондықтан DKIM хабарламаның "Жіберуші" өрісін тікелей тексермейді, бірақ ол саяси бейтарап аутентификация протоколы болып табылады. Қол қоюшы мен "Жіберуші" өрісін пайдалану құқығы арасындағы байланыс, соңғы пайдаланушыларға көрінетін өріс, жеке спецификацияға берілді. Sendmail авторы Эрик Оллман IETF DKIM жұмыс тобы үшін ADSP спецификациясының редакторы болды. ADSP спецификациясының жобасы 2007 жылдың маусым айында басталды және 2009 жылдың тамызында RFC ретінде жариялануға дейін 11 қайта қараудан және ұзақ талқылаудан өтті, бірақ "соңғы 4 жылда қолданылмай қалғандықтан" 2013 жылдың қарашасында "тарихи" деп жарияланды.