Введение

В вычислительной технике, Author Domain Signing Practices (ADSP) — это необязательное расширение схемы аутентификации электронной почты DKIM, позволяющее домену публиковать правила подписи, применяемые при пересылке почты от имени связанных авторов. ADSP был принят в качестве стандарта RFC 5617 в августе 2009 года, но признан "устаревшим" в ноябре 2013 года из-за "практически полного отсутствия внедрения и использования за прошедшие 4 года".

Адрес автора

Адрес автора – это адрес, указанный в поле заголовка, определенном в RFC 5322. В редких случаях, когда в этом поле определено несколько адресов, RFC 5322 предусматривает использование другого поля. Домены в адресах «От» по RFC 5322 не обязательно совпадают с доменами в более детализированном Адресе предполагаемого ответственного, рассматриваемом в Sender ID, определенном в RFC 4407. Домен в адресе «От» по RFC 5322 также не обязательно совпадает с адресом отправителя конверта, определенным в RFC 5321, также известным как SMTP MAIL FROM, адрес отправителя конверта, «От» по RFC 5321, или, опционально, защищенным SPF, как указано в RFC 7208.

Подпись домена автора

Подпись домена автора — это допустимая DKIM-подпись, в которой доменное имя организации, подписавшей DKIM (то есть тег `d` в заголовке DKIM Signature), совпадает с доменным именем в адресе отправителя. Такая привязка придает подписям домена автора более высокий приоритет, чем другим допустимым подписям, которые могут быть найдены в сообщении. Фактически, она подтверждает, что организация, контролирующая DNS-зону отправителя, и, следовательно, получатель ответов на сообщение, обработала сообщение от имени отправителя. Вероятнее всего, отправитель отправил сообщение через соответствующий агент передачи сообщений. Подлинность такого сообщения можно проверить независимо от опубликованных практик подписания доменов.

Кавеат

Спецификация ADSP настоятельно не рекомендует публиковать запись, отличную от "неизвестной", для доменов, у которых есть независимые пользователи и политика использования, явно не ограничивающая их отправку почты только с выделенных почтовых серверов, поскольку почта, отправленная вне организации, не будет подписана. Независимо от того, насколько явно сформулировано это предупреждение, понять цель и ограничения ADSP не всегда просто. Один из авторов ADSP полагает, что лучше публиковать закрытые списки доменов, предназначенных для отклонения, которые поддерживаются компетентными специалистами, чем позволять каждому домену самостоятельно определять свою политику. Признавая, что спецификация была выпущена в виде непроверенного прототипа, автор популярной реализации ADSP предложил понизить статус ADSP до экспериментального. Впоследствии ADSP был фактически понижен до исторического статуса.

История

Некоторое время ADSP был известен как ASP (Author Signing Practices) или оригинальный SSP (Sender Signing Practices), до проведения опроса по выбору названия протокола. DomainKeys, предшественник DKIM, использовал политику исходящей подписи, состоящую из одного символа: пробел (" ") если домен подписывает все электронные письма, и тильда ("~") в противном случае. DKIM намеренно избегал учета политик подписантов, чтобы не осуществлять прямую проверку поля "От" сообщения, оставаясь политически нейтральным протоколом аутентификации. Вопрос о связи между подписантом и правом использования поля "От", видимого для конечных пользователей, был перенесен в отдельную спецификацию. Эрик Оллман, автор Sendmail, был редактором спецификации ADSP для рабочей группы IETF DKIM. Работа над проектом спецификации ADSP началась в июне 2007 года и включала 11 редакций и длительные обсуждения, прежде чем она была опубликована как RFC в августе 2009 года, но в ноябре 2013 года, спустя четыре года, была объявлена "исторической" из-за "практически полного отсутствия внедрения и использования за прошедшие 4 года".