Введение

Стандартный формат обмена простыми текстовыми данными

Формат обмена данными LDAP (LDIF) — это стандартный формат обмена простыми текстовыми данными для представления содержимого каталога Lightweight Directory Access Protocol (LDAP) и запросов на обновление. LDIF передает содержимое каталога в виде набора записей, по одной записи для каждого объекта (или элемента). Он также представляет запросы на обновление, такие как добавление, изменение, удаление и переименование, в виде набора записей, по одной записи для каждого запроса на обновление. LDIF был разработан в начале 1990-х годов Тимом Хауэсом, Марком Смитом и Гордоном Гудом, работая в Мичиганском университете. LDIF был обновлен и расширен в конце 1990-х годов для использования с версией 3 протокола LDAP. Эта более поздняя версия LDIF называется версией 1 и официально определена в RFC 2849, документе IETF Standard Track. RFC 2849 был написан Гордоном Гудом и опубликован в июне 2000 года. В настоящее время он имеет статус Предлагаемого стандарта. За прошедшие годы было предложено множество расширений для LDIF. Одно расширение было официально специфицировано IETF и опубликовано. RFC 4525, автором которого является Курт Зейленга, расширил LDIF для поддержки расширения LDAP Modify Increment. Ожидается, что в будущем IETF опубликует дополнительные расширения.

Формат записи содержимого

Каждая запись содержимого представлена в виде группы атрибутов, записи разделены друг от друга пустыми строками. Отдельные атрибуты записи представлены в виде отдельных логических строк (представленных одной или несколькими физическими строками посредством механизма переноса строк), состоящих из пар "имя: значение". Данные значений, которые не помещаются в переносимый поднабор символов ASCII, помечаются '::' после имени атрибута и кодируются в ASCII с использованием кодировки base64. Формат записи содержимого является подмножеством типа информации интернет-каталога. RFC 2425

Инструменты, использующие LDIF

Утилиты OpenLDAP включают инструменты для экспорта данных с серверов LDAP в записи формата LDIF, импорта данных из файлов LDIF на серверы LDAP и применения изменений LDIF к серверам LDAP. LDIF – один из форматов для импорта и экспорта данных адресной книги, поддерживаемый адресными книгами в Netscape Communicator и Mozilla Application Suite. Microsoft Windows 2000 Server и Windows Server 2003 включают в себя инструмент командной строки LDIFDE для импорта и экспорта информации в Active Directory. JXplorer – это кроссплатформенное приложение с открытым исходным кодом на Java, которое позволяет просматривать и выполнять базовое редактирование файлов LDIF.