Кіріспе
Стандартты қарапайым мәтіндік дерек алмасу форматы
LDAP дерек алмасу форматы (LDIF) – жеңіл каталогтық кіру протоколы (LDAP) каталогтарының мазмұнын және жаңарту сұрауларын ұсынуға арналған стандартты қарапайым мәтіндік дерек алмасу форматы. LDIF каталог мазмұнын жазбалар жиынтығы түрінде жеткізеді, әрбір нысан (немесе жазба) үшін бір жазбадан. Сондай-ақ, қосу, өзгерту, жою және қайта атау сияқты жаңарту сұрауларын да жазбалар жиынтығы түрінде көрсетеді, әрбір жаңарту сұрауы үшін бір жазбадан. LDIF 1990 жылдардың басында Тим Хауес, Марк Смит және Гордон Гуд Мичиган университетінде жұмыс істеген кезде жасалған. LDIF, LDAP-тың 3-ші нұсқасымен қолдану үшін 1990 жылдардың соңында жаңартылып, кеңейтілді. LDIF-тің осы кейінгі нұсқасы 1-ші нұсқа деп аталады және IETF Standard Track RFC – RFC 2849 стандартында ресми түрде сипатталған. RFC 2849-дың авторлары Гордон Гуд, және ол 2000 жылдың маусым айында жарияланды. Қазіргі таңда ол ұсынылып отырған стандарт болып табылады. LDIF-ті кеңейтуге қатысты бірнеше ұсыныстар жасалған. Бір кеңейту IETF тарапынан ресми түрде анықталып, жарияланды. Курт Зейленганың жазған RFC 4525, LDAP Modify Increment кеңейтуін қолдау үшін LDIF-ті кеңейтті. Болашақта IETF қосымша кеңейтулерді жариялайды деп күтілуде.
Мазмұн жазбасының пішімі
Әрбір мазмұн жазбасы атрибуттар тобы ретінде ұсынылады, ал жазбалар бір-бірінен бос жолдармен ажыратылады. Жазбаның жеке атрибуттары "атауы: мәні" жұптарынан тұратын бір логикалық жол (сызық бүктеу механизмі арқылы бір немесе бірнеше физикалық жол ретінде ұсынылады) түрінде бейнеленеді. ASCII таңбаларының портативті кіші жиынтығына жатпайтын мәліметтер атрибут атауынан кейін "::" белгісімен көрсетіледі және base64 кодтау арқылы ASCII-ге түрлендіріледі. Мазмұн жазбасы форматы Интернет-каталог ақпарат түрінің кіші жиынтығы болып табылады. RFC 2425
LDIF қолданатын құралдар
OpenLDAP құралдарына LDAP серверлерінен деректерді LDIF мазмұны жазбаларына экспорттау, LDIF мазмұны жазбаларынан деректерді LDAP серверлеріне импорттау және LDIF өзгерту жазбаларын LDAP серверлеріне қолдану құралдары кіреді. LDIF – Netscape Communicator және Mozilla Application Suite-тегі адрес кітапшалары қолдайтын адрес кітапшасы деректерін импорттау және экспорттау форматтарының бірі. Microsoft Windows 2000 Server және Windows Server 2003 Active Directory-дегі ақпаратты импорттау және экспорттау үшін LDIFDE деп аталатын LDIF-не негізделген командалық жол құралын қамтиды. JXplorer – LDIF файлдарын қарауға және қарапайым өңдеуге мүмкіндік беретін көп платформалы ашық кодты Java бағдарламалық жасақтамасы.
LDIF is one of the formats for importing and exporting address book data that the address books in Netscape Communicator and in the Mozilla Application Suite support. Microsoft Windows 2000 Server and Windows Server 2003 include an LDIF based command line tool named LDIFDE for importing and exporting information in Active Directory. JXplorer is a cross platform open source java application that can browse and do basic editing of LDIF files.