Сравнивайте с английским: нажмите на абзац — оригинал откроется в окне. Кнопка EN под абзацем показывает его прямо в тексте.
Введение
Программа операционной системы, обеспечивающая синхронизацию времени.
An operating system program that maintains time synchronization
Демон протокола сетевого времени (ntpd) — это программа операционной системы, поддерживающая синхронизацию системного времени с серверами времени посредством протокола сетевого времени (NTP).
The Network Time Protocol daemon (ntpd) is an operating system program that maintains the system time in synchronization with time servers using the Network Time Protocol (NTP).
Описание
Программа ntpd — это демон операционной системы, который устанавливает и поддерживает системное время компьютерной системы в синхронизации с серверами стандартного времени в Интернете. Это полная реализация протокола сетевого времени (NTP) версии 4, но сохраняет совместимость с версиями 1, 2 и 3, как определено в RFC 1059, RFC 1119 и RFC 1305 соответственно. ntpd выполняет большинство вычислений в 64-битной арифметике с плавающей точкой и использует 64-битные операции с фиксированной точкой только при необходимости для сохранения максимальной точности, составляющей около 232 пикосекунд. Хотя обычные рабочие станции и сети не могут достичь такой точности, будущие процессоры и сети могут потребовать её. xntpd — это программное обеспечение-демон протокола сетевого времени версии три (1992). Буква "x" была добавлена к названию, поскольку ветвь кода, которая в конечном итоге стала NTPv3, носила "экспериментальный" характер. Название программного обеспечения вернулось к "ntpd" для версии четыре, потому что изобретатель NTP, Дэйв Миллс, решил, что что-либо вряд ли должно оставаться "экспериментальным" на протяжении примерно двадцати лет без существенных изменений. ntpd использует один файл конфигурации для запуска демона в режимах сервера и/или клиента. Файл конфигурации, обычно называемый ntp.conf, находится в каталоге /etc. Другие важные файлы включают файл дрифта, который ntpd использует для коррекции погрешности аппаратных часов при отсутствии соединения с более точным сервером времени.
The ntpd program is an operating system daemon that sets and maintains a computer system's system time in synchronization with Internet standard time servers. It is a complete implementation of the Network Time Protocol (NTP) version 4, but retains compatibility with versions 1, 2, and 3 as defined by RFC 1059, RFC 1119, and RFC 1305, respectively. ntpd performs most computations in 64 bit floating point arithmetic and uses 64 bit fixed point operations only when necessary to preserve the ultimate precision, about 232 picoseconds. While ordinary workstations and networks cannot achieve the ultimate precision , future processors and networks may require it. xntpd is the Network Time Protocol version three (1992) daemon software. The "x" was added to the name because the branch of code that eventually became NTPv3 was "experimental". The name of the software changed back to "ntpd" for version four because the inventor of NTP, Dave Mills, decided that something probably should not remain "experimental" for about twenty years in the absence of dramatic change. ntpd uses a single configuration file to run the daemon in server and/or client modes. The configuration file, usually named ntp. conf, is located in the /etc directory. Other important files include the drift file, which ntpd uses to correct for hardware clock skew in the absence of a connection to a more accurate upstream time server.