Введение
Протокол маршрутизации компьютерной сети — это сетевой протокол.
a computer network protocol
Протокол Intermediate System to Intermediate System (IS-IS, также записывается как ISIS) — это протокол маршрутизации, разработанный для эффективной передачи информации в компьютерной сети, группе физически соединенных компьютеров или аналогичных устройств. Он обеспечивает это, определяя оптимальный маршрут для данных в сети с коммутацией пакетов. Протокол IS-IS определен в ISO/IEC 10589:2002 как международный стандарт в рамках эталонной модели открытых систем взаимосвязи (OSI). Internet Engineering Task Force (IETF) переиздала IS-IS в 2003 году, но этот RFC впоследствии был помечен как исторический, поскольку он переиздал черновик, а не окончательную версию стандарта ISO (Международной организации по стандартизации), что привело к путанице. В 2005 году IS-IS называли «де-факто стандартом для магистральных сетей крупных поставщиков услуг».
Описание
IS-IS – это протокол внутренней маршрутизации, предназначенный для использования в пределах административного домена или сети. Это отличается от протоколов внешней маршрутизации, в первую очередь Border Gateway Protocol (BGP), который используется для маршрутизации между автономными системами (RFC 1930). IS-IS – это протокол маршрутизации на основе состояния каналов, работающий путем надежной передачи информации о состоянии каналов по всей сети маршрутизаторов. Каждый маршрутизатор IS-IS независимо формирует базу данных топологии сети, объединяя полученную информацию о состоянии каналов. Как и протокол OSPF, IS-IS использует алгоритм Дейкстры для вычисления оптимального маршрута в сети. Затем пакеты (датаграммы) пересылаются по вычисленному оптимальному маршруту через сеть к месту назначения.
История
Протокол IS-IS был разработан командой специалистов компании Digital Equipment Corporation в рамках DECnet Phase V. Он был стандартизирован ISO в 1992 году как ISO 10589 для организации связи между сетевыми устройствами, именуемыми ISO как промежуточные системы (в отличие от оконечных систем или хостов). Целью IS-IS было обеспечение маршрутизации датаграмм с использованием стека протоколов OSI, разработанного ISO, под названием CLNS. IS-IS разрабатывался примерно одновременно с аналогичным протоколом OSPF, разрабатываемым Internet Engineering Task Force (IETF). Позднее IS-IS был расширен для поддержки маршрутизации датаграмм в протоколе Интернет (IP), протоколе сетевого уровня глобальной сети Интернет. Эта версия протокола маршрутизации IS-IS получила название Integrated IS-IS (RFC 1195).
Другие применения
IS IS также используется в качестве плоскости управления для IEEE 802.1aq Shortest Path Bridging (SPB). SPB обеспечивает пересылку по кратчайшему пути в контексте Ethernet-сети с ячеистой топологией, используя несколько равноценных путей. Это позволяет SPB поддерживать большие топологии второго уровня, обеспечивая быструю сходимость и более эффективное использование ячеистой топологии. Кроме того, SPB предоставляет централизованную настройку членства в логических соединениях. Поэтому IS IS расширяется небольшим количеством TLV и под-TLV и поддерживает два канала передачи данных с инкапсуляцией Ethernet: 802.1ad Provider Bridges и 802.1ah Provider Backbone Bridges. Для SPB не требуется изменение конечных автоматов или каких-либо существенных изменений в IS IS – достаточно нового идентификатора протокола сетевого уровня (NLPID) и набора TLV. Это расширение IS IS определено в предлагаемом стандарте IETF RFC 6329.