Кіріспе

Интернеттік хабар алмасу протоколының (IMAP) авторы Марк Рид Криспин (1956 жылғы 19 шілдеде Нью-Джерси штатының Камден қаласында дүниеге келген, 2012 жылғы 28 желтоқсанда Вашингтон штатының Пульсбо қаласында қайтыс болды) ең әйгілісі Интернеттік хабар алмасу протоколының (IMAP) авторы ретінде танымал. Ол 1985 жылы Стэнфорд білім жүйелері зертханасында жұмыс істеген кезінде оны ойлап тапты. Ол көптеген RFC-тің авторы немесе бірлескен авторы, сондай-ақ RFC 3501-де сипатталған IMAP4rev1 протоколының эталондық іске асырылымдарының бірі – UW IMAP-тың негізгі авторы болды. Ол сонымен қатар MIX пошта сақтау форматын жасады. Криспин 1977 жылы Стивенс технология институтын технология және қоғам саласы бойынша бітірді.

Мансап

1977-1988 жылдары Стэнфорд университетінде жүйелік бағдарламашы болып жұмыс істеді. Ол WAITS операциялық жүйесі үшін алғашқы PDP 10 96 биттік жетекші ARPANET желілік басқару бағдарламасын (NCP) жасады және WAITS ARPAnet протоколы жиынтығының көп бөлігін жазды немесе қайта жазды. Осыған дейін көптеген жүйелер тек бастапқы 32 биттік жетекшіні қолдаған. Сол кезде ол танымал RFC 748 құжатын жазды, ол RFC индексінде шығарылған күні көрсетілген жалғыз құжат; сондай-ақ, үйлесімсіз уақыт бөлісу жүйесі, WAITS және TOPS 20 операциялық жүйелері үшін Telnet іске асыруларының бірнеше сериясын жасады, оның қашу әрекеті 1984 жылғы сәуір айында Гай Стилдің ACM Коммуникацияларында «Телнет әні» деп мәңгілікке сақталды. 1980 жылдардың басында Стэнфорд компьютерлік ғылымдар факультетінің TOPS 20 жүйесіне жүйелік бағдарламашы болып тағайындалғаннан кейін, ол электрондық пошта бағдарламалық құралдары мен жүйелеріне қызығушылық танытты, содан кейін бұл оның басты бағыты болды. Ол TOPS 20 пошта жүйесінің негізгі әзірлеушісі болды және 2009 жылы әлі де өз үйінде TOPS 20 жүйелерін іске қосып жүргені хабарланды. IMAP алғаш рет 1985-1988 жылдар аралығында Стэнфордта жасалды. 1988 жылдан 2008 жылға дейін ол Вашингтон университетінде бағдарламалық жасақтама инженері болып жұмыс істеді, онда IMAP-ты әзірлеу және танымал ету, сондай-ақ UW IMAP-қа айналған құрылымды құру бойынша көп жұмыс атқарылды. 2008 жылдың мамыр айында UW IMAP-ты Panda IMAP-қа бөліп шығарды. UW-де жұмыс істеген кезде Марк 1992 жылдың наурыз айында іске қосылған қарапайым және портативті Unix электрондық пошта бағдарламасы Pine-ның жасаушыларының бірі болды. 2005 жылы ол RFC 4042 құжатын жазды, ол оның екінші сәуір әзілі күніне арналған RFC құжаты, онда PDP 10 үшін оңтайландырылған Unicode кодтамалары UTF 9 және UTF 18 сипатталған. 2008 жылдың тамызында Криспин Messaging Architects компаниясына аға бағдарламалық жасақтама инженері болып қосылды. Messaging Architects компаниясында ол таратылған пошта базасына негізделген жаңа IMAP серверін жасады және MIX форматын (виртуалды пошта жәшіктері механизмі арқылы) және метадеректерді қолдау үшін кеңейтті.

Өлім

2012 жылдың 19 қарашасында Криспиннің ауруының соңғы сатысында екені және ол хосписте күтімде жатқаны хабарланды, ол 2012 жылдың 28 желтоқсанында қайтыс болды.