Введение

Отец протокола доступа к сообщениям в Интернете (IMAP) Марк Рид Криспин (19 июля 1956 года в Камдене, штат Нью-Джерси – 28 декабря 2012 года в Поулсбо, штат Вашингтон) наиболее известен как создатель протокола доступа к сообщениям в Интернете (IMAP), который он изобрел в 1985 году, работая в лаборатории систем знаний Стэнфордского университета. Он является автором или соавтором многочисленных RFC и главным разработчиком UW IMAP – одной из эталонных реализаций протокола IMAP4rev1, описанного в RFC 3501. Он также разработал формат хранения почты MIX. В 1977 году Криспин получил степень бакалавра в области технологий и общества в Технологическом институте Стивенса.

Карьера

С 1977 по 1988 год он работал системным программистом в Стэнфордском университете. Он разработал первую рабочую версию ARPANET Network Control Program (NCP) для операционной системы WAITS на PDP 10 с 96-битным лидером и написал или переписал большую часть пакета протоколов WAITS ARPAnet. До этого момента большинство систем поддерживали только оригинальный 32-битный лидер. В этот период он создал широко известный RFC 748 – единственный документ в индексе RFC, содержащий указание даты выпуска, а также серию реализаций Telnet для операционных систем Incompatible Timesharing System, WAITS и TOPS 20, особенности поведения которых были в шутливой форме описаны Гаем Стилом в статье «The Telnet Song» в апрельском выпуске Communications of the ACM за 1984 год. В начале 1980-х годов, вскоре после назначения системным программистом системы TOPS 20 факультета компьютерных наук Стэнфорда, он заинтересовался программным обеспечением и системами электронной почты, что впоследствии стало его основной сферой деятельности. Он стал ведущим разработчиком почтовой системы TOPS 20 и, по сообщениям, в 2009 году продолжал использовать системы TOPS 20 у себя дома. Именно в Стэнфорде, в период с 1985 по 1988 год, был впервые разработан протокол IMAP. С 1988 по 2008 год он работал инженером-программистом в Университете Вашингтона, где велась основная работа по разработке и популяризации IMAP и созданию UW IMAP. В мае 2008 года он разветвил UW IMAP, создав Panda IMAP. Работая в Университете Вашингтона, Марк был одним из создателей простой и переносимой Unix-программы для работы с электронной почтой Pine, выпущенной в марте 1992 года. В 2005 году он написал RFC 4042, свой второй приуроченный ко Дню дураков RFC, описывающий UTF 9 и UTF 18 – кодировки Unicode, оптимизированные для PDP 10. В августе 2008 года Криспин присоединился к Messaging Architects в качестве старшего инженера-программиста. В Messaging Architects он разработал совершенно новый IMAP-сервер, основанный на распределенном хранилище электронной почты, и расширил формат MIX для поддержки стаббинга (с помощью механизма, называемого виртуальными почтовыми ящиками) и метаданных.

Смерть

19 ноября 2012 года было объявлено, что Криспин страдает от неизлечимой болезни и находится под паллиативной опекой, а скончался он 28 декабря 2012 года.