Кіріспе

Компьютерлік және телекоммуникациялық желілерде қатысу туралы ақпарат – бұл әлеуетті байланыс серіктесінің (мысалы, пайдаланушының) байланыс жасау мүмкіндігі мен ынтасын көрсететін мәртебелік көрсеткіш. Пайдаланушының клиенті желілік қосылым арқылы қатысу қызметіне қатысу туралы ақпаратты (қатысу күйі) жібереді, ол оның жеке қолжетімділік туралы жазбасында (қатысушы деп аталады) сақталады және басқа пайдаланушыларға (бақылаушылар деп аталады) байланыс үшін қолжетімділігін хабарлау үшін таратуға болады. Қатысу туралы ақпарат көптеген байланыс қызметтерінде кеңінен қолданылады және жылдам хабар алмасудың немесе IP желісі арқылы дауыс беру клиенттерінің жаңадан пайда болуының танымалдылығын арттырған инновациялардың бірі болып табылады.

Қалыптасу жағдайы

Пайдаланушы клиенті өзінің қазіргі байланыс жағдайын көрсету үшін қатысу күйін жариялай алады. Бұл жарияланған күй, пайдаланушымен байланысуға ниеттенген басқаларға оның қолжетімділігі және қарым-қатынасқа дайындығы туралы хабарлайды. Қазіргі таңда қатысудың ең көп қолданылатын түрі – дереу хабар алмасу клиенттерінде индикатор белгішесін көрсету, әдетте, мағынасын оңай жеткізе алатын графикалық символдардың таңдауы және әрбір күйдің тиісті мәтіндік сипаттамаларының тізімі. Техникалық тұрғыдан бірдей болмаса да, қосылған телефонның «құбылыста» немесе «құбылыстан тыс» күйі аналог ретінде қарастырылады, егер шалушы қолжетімді емес немесе қолжетімді екенін көрсететін ерекше сигналды естісе. Пайдаланушының қолжетімділігінің жиі кездесетін күйлері: «чатта сөйлесуге болады», «әрекетте», «қашықта», «жалмаңыз», «тамақтануға кеттім». Мұндай күйлер әртүрлі заманауи дереу хабар алмасу клиенттерінде сан алуан нұсқаларда кездеседі. Қазіргі стандарттар қатысу туралы ақпарат үшін пайдаланылатын қосымша қатысу атрибуттарының кең таңдауын қолдайды, мысалы, пайдаланушының көңіл-күйі, орналасқан жері немесе кез келген мәтіндік мәртебесі. PSTN желісіндегі бос/әрекетті сигналмен салыстыру толық емес, себебі «құбылыста» телефон күйі желінің сұрау салушы сұхбатты бастағаннан кейін абонентке жету мүмкіндігін көрсетеді. Сұрау салушы алушының қолжетімділік күйін білгенге дейін байланыс әдісіне міндетті түрде келісуі керек. Керісінше, қатысу күйі диалог басталғанға дейін көрсетіледі. Осыған ұқсас мысал ретінде, сұрау салушының алушы жұмыста ма екенін білуі қажеттігін келтіруге болады. Абоненттің қолжетімділігін тексерудің ең қарапайым жолы – оның үстеліне бару, бұл нәтижеге қарамастан, баруға міндеттілік тудырады және егер абонент үстелде болса, әдетте, біршама өзара әрекеттесуді қажет етеді. Сұрау салушы алдымен телефон арқылы хабарласып, бару қажеттігінен құтылуы мүмкін, бірақ енді телефон арқылы өзара әрекеттесуге міндетті болады. Қатысу күйі сұрау салушыға алушының жағдайын хабарлайды және сұрау салушы осы ақпаратты алушымен өзара әрекеттесу үшін немесе өзара әрекеттесуді қажет етпейтін мақсаттарда (мысалы, тізімді жүргізу) пайдалану мүмкіндігіне ие.

МОПП және бақылау арқылы қатысу

Қатысу байланыс жүйелері үшін қызығушылық тудырады, егер ол бірнеше байланыс арнасын қамтыса. Бірнеше байланыс құрылғысы пайдаланушының қатысуын жиынтық түрде көрсету үшін күйін біріктіре алатын идея Көп Нүктелі Қатысу (MPOP) деп аталады. MPOP пайдаланушының әрекеттерін пассивті түрде бақылау арқылы автоматты түрде анықталғанда одан да қуаттырақ болады. Бұл идея жедел хабар алмасу қолданушыларына таныс, егер олардың компьютерлік пернетақтасы біраз уақыт бойы белсенді болмаса, олардың күйі "Жолдас жоқ" (немесе соған ұқсас) деп белгіленеді. Басқа құрылғыларға қатысты қолдану үшін пайдаланушының ұялы телефоны қосылған-өшірілген, компьютерге кірген-кірмеген, немесе электрондық күнтізбесін тексеріп, кездесуде ме немесе демалыста ма екенін қарастыруға болады. Мысалы, егер пайдаланушының күнтізбесі кеңседен тыс деп белгіленсе және олардың ұялы телефоны қосылса, олар "Жолда жүр" күйінде деп есептелуі мүмкін. MPOP күйін кіріс хабарламаларды барлық қатысушы құрылғыларға автоматты түрде бағыттау үшін пайдалануға болады. Мысалы, "Көніс орнында емес" деген күйді барлық хабарламалар мен қоңырауларды пайдаланушының ұялы телефонына бағыттайтын жүйе деп түсіндіруге болады. "Мазаламаңыз" күйі барлық хабарламаларды кейінге сақтап, барлық телефон қоңырауларын дауыстық поштаға жіберуге мүмкіндік береді. Төменде талқыланатын XMPP, әр клиентке "ресурс" (нақты идентификатор) және әр ресурс үшін басымдық нөмірін тағайындау арқылы MPOP-ты іске асырады. Пайдаланушының идентификаторына жіберілген хабарлама ең жоғары басымдыққа ие ресурсқа жіберіледі, бірақ нақты ресурсқа хабарлама жіберу үшін user@domain/resource пішімін қолдануға болады.

Коммерциялық өнімдер

Қатысу, әсіресе MPOP, бірнеше электрондық құрылғылардың (мысалы, IM клиенті, үй телефоны, ұялы телефон және электрондық күнтізбе) және олардың әрқайсысы байланысқан қатысу қызметтерінің арасындағы ынтымақтастықты қажет етеді. Бүгінгі күнгі ең көп таралған және кең ауқымды жүзеге асырулар жабық жүйелерді пайдаланады, SPOP (бір құрылғы күйін жариялайтын жалғыз нүкте). Кейбір жеткізушілер өз қызметтерін жаңартқан, жаңа құрылғыдан серверге кіру туралы сұраныс түскен кезде, қосылған клиенттерді автоматты түрде жүйеден шығарып тастайды. MPOP қолдауымен қатысудың барлық жерде жұмыс істеуі үшін, бірнеше құрылғылар бір-бірімен байланысқа түсе білуі керек, сонымен қатар барлық басқа өзара әрекеттесетін, байланысқан қызметтер және олардың клиенттері үшін күй туралы ақпаратты дұрыс өңдеуі және MPOP схемасын қолдануы тиіс. 2.5G және одан да артық 3G ұялы телефон желілері ұялы телефон пайдаланушылары үшін қатысу туралы ақпаратты басқаруға және қол жеткізуге мүмкіндік береді. Жұмыс орнында жеке хабарлама серверлері компания немесе жұмыс тобы ішінде MPOP мүмкіндігін ұсынады.

Бизнес қоғамдастығында

Қатысу туралы ақпарат – бизнес ортасында тиімдірек және нәтижелірек коммуникацияны қамтамасыз ететін маңызды құрал. Қатысу туралы ақпарат корпоративтік желіңізде кімнің қолжетімді екенін дереу білуге мүмкіндік береді, соның арқасында қысқа мерзімді кездесулер мен конференц-байланыстарды ұйымдастыру жеңілдейді. Нәтижесінде, телефон арқылы немесе электрондық поштамен байланысудың тиімсіздігін жоққа шығаратын нақты коммуникация орнатылады. Қатысу туралы ақпараттың уақытты үнемдеуге қатысты мысалы – GPS-пен жабдықталған жүргізуші; оның орналасқан жері қадағаланып, алдағы жол жағдайы туралы хабарламалар жіберіледі, бұл уақыт пен қаржыны үнемдеуге көмектеседі. IDC жүргізген сараптамаларға сәйкес, қызметкерлер "жеке әріптестерімен тікелей қарым-қатынас жасағандағыдай, жұмыс күндеріне белгілі бір 'динамиканы' сыйлайды, оларға сұрақ қойып, келесі тапсырмаға көшуге мүмкіндік беретін жылдам жауаптар алады". Бұл құбылыс бұрынғы "су көлденеңі" әсерімен салыстырылып, "қатысу әсері" деп аталады, мұнда бұл деңгейдегі динамика тек жеке кездесулерде ғана мүмкін деп есептелді. Алайда, қатысу туралы ақпарат пайдаланушылардың жеке өміріне қатысты мәселелер тудыруы мүмкін. Мысалы, қызметкер демалыста болған кезде де желіге қосылып, оны табу оңайырақ болуы мүмкін. Сондықтан, қатысу туралы ақпаратты пайдалануда компаниялардың байланыста қалу шегін анықтау маңызды.

Стандарттау бойынша іс-қимыл

Бірнеше жұмыс топтарында қатысумен байланысты хаттамаларды стандарттау бойынша маңызды жұмыс жүргізілді және осы уақытқа дейін жалғасуда. 1999 жылы Интернет-инженерлік жұмыс тобы (IETF) ұйымында Instant Message and Presence Protocol (IMPP) жұмыс тобы (ЖТ) деп аталатын топ құрылды, мақсаты – қарапайым қатысу және жедел хабар алмасу қызметтерін іске асыру үшін протоколдар мен деректер форматтарын жасау болатын. Алайда, IMPP жұмыс тобы қатысу бойынша бірыңғай протоколға келісе алмады. Оның орнына, қатысу және жедел хабар алмасу үшін ортақ профиль (CPP) жарияланды, ол қатысу қызметтері арасында шлюздер құруды жеңілдету үшін ортақ қызметтердің семантикасын анықтады. Нәтижесінде, кез келген екі CPP-мен үйлесімді протокол жиынтығы автоматты түрде өзара іс-қимыл жасай алады. 2001 жылы IETF құрамында SIMPLE жұмыс тобы құрылды, оның мақсаты – сессия бастау протоколы (SIP) арқылы қатысу және жедел хабар алмасуға арналған CPP-ға сәйкес стандарттар жиынтығын әзірлеу еді. SIMPLE әрекеті SIP протоколының кеңейтімдерін анықтайды, олар қатысу туралы ақпаратты жариялау және жазылу механизмімен, сондай-ақ жедел хабарларды жіберумен айналысады. Бұл кеңейтімдерге бай қатысу құжаттарының форматтары, құпиялылықты басқару, «жартылай жарияланымдар» және хабарламалар, өткен және болашақ қатысу, бақылаушы туралы ақпарат және тағы да басқалары кіреді. Аты айтқандай, SIMPLE аса қарапайым емес. Ол 30-ға жуық құжаттан тұрады, олардың жалпы көлемі 1000-нан астам бетті құрайды. Бұған қоса, SIMPLE негізделген SIP протоколының өзінің күрделілігі де бар. 2001 жылдың соңында Nokia, Motorola және Ericsson компаниялары мобильді жедел хабар алмасу және қатысу қызметтері (IMPS) мен сымсыз желілер үшін қатысу қызметтеріне арналған әмбебап ережелер жиынтығын анықтау мақсатымен Wireless Village (WV) бастамасын құрды. 2002 жылдың қазан айында Wireless Village Open Mobile Alliance (OMA) ұйымына біріктірілді, ал бір айдан кейін XML негізіндегі OMA Instant Messaging and Presence Service (IMPS) протоколының бірінші нұсқасы жарияланды. IMPS жүйелік архитектураны, синтаксисті және қатысу туралы ақпаратты ұсыну семантикасын, сондай-ақ төрт негізгі мүмкіндік үшін протоколдар жиынтығын анықтайды: қатысу, IM, топтар және ортақ мазмұн. Қатысу – IMPS үшін маңызды технологияны іске қосушы құрал. XML негізіндегі XMPP немесе кеңейтілген хабарламалар мен қатысу протоколы XMPP стандарттар қорымен әзірленді және қазіргі уақытта күтіліп тұрады. Бұл IM протоколы, сенімді және кеңінен қолданылатын протокол, сонымен қатар Google Talk және Facebook Chat коммерциялық нұсқаларында қолданылады. 2004 жылдың қазан айында IETF-тегі XMPP жұмыс тобы негізгі XMPP протоколын стандарттау үшін RFC 3920, RFC 3921, RFC 3922 және RFC 3923 құжаттарын жариялады.