Введение

В компьютерных и телекоммуникационных сетях информация о присутствии – это индикатор статуса, который сообщает о возможности и готовности потенциального собеседника, например, пользователя, к общению. Клиент пользователя передает информацию о присутствии (статус присутствия) через сетевое соединение службе присутствия, где она хранится в его персональной записи о доступности (называемой сущностью присутствия) и может быть предоставлена для распространения другим пользователям (называемым подписчиками), чтобы те могли узнать о его доступности для связи. Информация о присутствии широко используется в различных коммуникационных сервисах и является одной из инноваций, способствующих популярности мгновенных сообщений и современных реализаций голосовой связи по IP.

Состояние присутствия

Клиент-пользователь может публиковать информацию о своём состоянии присутствия, чтобы указать текущий статус связи. Эта опубликованная информация сообщает другим пользователям, желающим связаться с ним, о его доступности и готовности к общению. Наиболее распространенное применение состояния присутствия сегодня – отображение индикатора на клиентах мгновенных сообщений, обычно в виде графических символов с понятным значением и соответствующего списка текстовых описаний для каждого состояния. Даже если это технически не одно и то же, состояние "на линии" или "вне линии" у вызываемого телефона можно рассматривать как аналогию, если звонящий получает отличительный сигнал, указывающий на недоступность или доступность абонента. Типичные состояния доступности пользователя включают: "свободен для чата", "занят", "отошел", "не беспокоить", "на обеде". Такие состояния представлены в различных вариациях в современных клиентах мгновенных сообщений. Современные стандарты поддерживают широкий спектр дополнительных атрибутов присутствия, которые могут использоваться для предоставления информации, например, настроение пользователя, местоположение или произвольный текстовый статус. Аналогия с сигналом "свободен/занят" в PSTN не совсем точна, поскольку состояние "на линии" отражает возможность сети установить соединение с вызываемым абонентом после того, как вызывающий инициировал вызов. Вызывающему необходимо выбрать способ соединения, прежде чем узнать о доступности вызываемого абонента. В отличие от этого, состояние присутствия показывает доступность до начала разговора. Сравнить это можно с необходимостью узнать, находится ли вызываемый абонент на рабочем месте. Самый простой способ проверить его доступность – подойти к его рабочему столу, что требует затрат времени независимо от результата и обычно предполагает взаимодействие, если абонент на месте. Можно сначала позвонить, чтобы избежать похода, но тогда вызывающий обязуется взаимодействовать по телефону. Состояние присутствия предоставляет вызывающему информацию о доступности вызываемого абонента, и вызывающий может решить, взаимодействовать с ним или использовать эту информацию для неинтерактивных целей (например, для составления списков).

МПОП и присутствие по наблюдению

Присутствие становится интересным для систем связи, когда оно распространяется на несколько различных каналов связи. Идея о том, что несколько коммуникационных устройств могут объединять информацию о своем состоянии, чтобы предоставить агрегированное представление о присутствии пользователя, получила название Multiple Points of Presence (MPOP). MPOP становится еще более эффективным, когда оно автоматически определяется на основе пассивного наблюдения за действиями пользователя. Эта концепция уже знакома пользователям мгновенных сообщений, у которых статус меняется на "Не на месте" (или аналогичный), если клавиатура компьютера неактивна в течение определенного времени. Расширение на другие устройства может включать в себя определение, включен ли мобильный телефон пользователя, подключен ли он к компьютеру, или, например, проверка его электронного календаря, чтобы узнать, находится ли он на встрече или в отпуске. Например, если в календаре пользователя указано отсутствие на рабочем месте, а его мобильный телефон включен, он может быть определен как находящийся в состоянии "В пути". Статус MPOP затем может использоваться для автоматической переадресации входящих сообщений на все участвующие устройства. Например, статус "Отсутствует на рабочем месте" может привести к тому, что система будет направлять все сообщения и звонки на мобильный телефон пользователя. Статус "Не беспокоить" может автоматически сохранять все сообщения для последующего просмотра и перенаправлять все телефонные звонки на голосовую почту. XMPP, который будет обсуждаться ниже, поддерживает MPOP, присваивая каждому клиенту "ресурс" (уникальный идентификатор) и номер приоритета для каждого ресурса. Сообщение, адресованное идентификатору пользователя, будет доставлено на ресурс с наивысшим приоритетом, хотя отправка сообщения конкретному ресурсу возможна, используя формат user@domain/resource.

Коммерческие продукты

Присутствие, особенно MPOP, требует взаимодействия между множеством электронных устройств (например, клиент мгновенных сообщений, домашний телефон, мобильный телефон и электронный календарь) и службами присутствия, к которым они подключены. На сегодняшний день наиболее распространенные и широко используемые реализации основаны на закрытых системах с SPOP (Single Point of Presence, где одно устройство публикует свой статус). Некоторые поставщики услуг обновили свои системы, чтобы автоматически отключать подключенные клиенты при поступлении нового запроса на вход с другого устройства. Для обеспечения универсальной работы присутствия с поддержкой MPOP, несколько устройств должны не только обмениваться информацией между собой, но и чтобы информация о статусе корректно обрабатывалась всеми взаимодействующими, подключенными службами присутствия и схемой MPOP для их клиентов. Сети мобильной связи 2.5G и, особенно, 3G могут поддерживать управление и доступ к службам информации о присутствии для мобильных пользователей. В корпоративной среде серверы обмена личными сообщениями предоставляют возможность использования MPOP внутри компании или рабочей группы.

В деловом сообществе

Информация о присутствии становится все более важным инструментом для повышения эффективности и результативности коммуникаций в бизнес-среде. Она позволяет мгновенно видеть, кто доступен в корпоративной сети, обеспечивая большую гибкость при организации коротких встреч и конференц-звонков. Это приводит к более точной коммуникации, практически исключающей неэффективность, связанную с попытками дозвониться или обменом электронными сообщениями. Примером экономии времени, обеспечиваемой информацией о присутствии, может служить водитель, использующий GPS: его можно отслеживать и информировать о текущей дорожной обстановке, что позволяет экономить время и деньги. Согласно исследованиям IDC, сотрудники часто отмечают, что мгновенные сообщения создают ощущение рабочего процесса, аналогичное тому, которое они испытывают, находясь непосредственно рядом с коллегами, имея возможность задавать вопросы и получать быстрые ответы, позволяющие сразу переходить к следующей задаче. Это явление получило название "эффект присутствия", в отличие от предшествующего ему "эффекта кулера", когда считалось, что подобный уровень вовлеченности возможен только при личном общении. Однако, использование информации о присутствии может вызывать вопросы конфиденциальности. Например, сотрудник, находящийся в выходной день, все равно остается подключенным к сети и может быть легко найден. Поэтому важным аспектом использования информации о присутствии является определение того, насколько далеко компании готовы зайти в поддержании постоянной связи.

Усилия по стандартизации присутствия

Была и до сих пор ведется значительная работа в нескольких рабочих группах по достижению стандартизации протоколов, связанных с определением статуса присутствия. В 1999 году в рамках организации Internet Engineering Task Force (IETF) была сформирована рабочая группа (WG) под названием Instant Message and Presence Protocol (IMPP), для разработки протоколов и форматов данных для простого определения статуса присутствия и услуг мгновенных сообщений. К сожалению, рабочей группе IMPP не удалось достичь консенсуса по единому протоколу определения статуса присутствия. Вместо этого она выпустила общий профиль для определения статуса присутствия и обмена мгновенными сообщениями (CPP), который определил семантику для общих служб определения статуса присутствия, чтобы облегчить создание шлюзов между этими службами. Таким образом, любые два протокола определения статуса присутствия, совместимые с CPP, автоматически взаимосовместимы. В 2001 году в рамках IETF была создана рабочая группа SIMPLE для разработки набора стандартов, соответствующих CPP, для приложений определения статуса присутствия и мгновенных сообщений на основе протокола инициирования сеанса (SIP). Деятельность SIMPLE определяет расширения протокола SIP, которые обеспечивают механизм публикации и подписки для информации о статусе присутствия и отправки мгновенных сообщений. Эти расширения включают форматы документов расширенного статуса присутствия, контроль конфиденциальности, "частичные публикации" и уведомления, информацию о статусе присутствия в прошлом и будущем, информацию о наблюдателях и многое другое. Несмотря на свое название, SIMPLE далеко не прост. Он описан примерно в 30 документах объемом более 1000 страниц. Это помимо сложности стека протоколов SIP, на котором основан SIMPLE. В конце 2001 года компании Nokia, Motorola и Ericsson сформировали инициативу Wireless Village (WV) для определения набора универсальных спецификаций для мобильных служб мгновенных сообщений и определения статуса присутствия (IMPS) и служб определения статуса присутствия для беспроводных сетей. В октябре 2002 года Wireless Village была объединена в Open Mobile Alliance (OMA), и через месяц была выпущена первая версия XML-сервиса OMA Instant Messaging and Presence Service (IMPS). IMPS определяет архитектуру системы, синтаксис и семантику для представления информации о статусе присутствия, а также набор протоколов для четырех основных функций: определение статуса присутствия, ИМ, группы и общий контент. Определение статуса присутствия является ключевой технологией, обеспечивающей работу IMPS. XMPP на основе XML, или протокол расширяемой передачи сообщений и определения статуса присутствия, был разработан и в настоящее время поддерживается XMPP Standards Foundation. Этот протокол IM, который является надежным и широко распространенным, также используется в коммерческих реализациях Google Talk и Facebook Chat. В октябре 2004 года рабочая группа XMPP в IETF опубликовала документы RFC 3920, RFC 3921, RFC 3922 и RFC 3923 для стандартизации основного протокола XMPP.