Желілік трафик полициясы: трафик шартына сәйкестікті бақылау, артық трафикті басқару. Трафик қалыптастыру, пакет жоғалтуын азайту, желінің тұрақты жұмысын қамтамасыз ету.
Ағылшыншамен салыстырыңыз: абзацты басыңыз — түпнұсқа терезеде ашылады. Абзац астындағы EN түймесі оны мәтін ішінде көрсетеді.
Мазмұны
Кіріспе
Байланыс саласында трафик полициясы – бұл желілік трафикті трафик шартына сәйкестігі үшін бақылау және осы шартты сақтау үшін қадамдар жасау процесі. Трафик шартынан хабардар трафик көздері, өз шығысы шарт шегінде болуын қамтамасыз ету үшін трафик пішінділеуді қолдануы мүмкін, осылайша олар жойылмайды. Трафик шартын асып кеткен трафик әкімшілік саясатқа және артық трафиктің сипаттамаларына байланысты дереу жойылуы, сәйкес еместік деп белгіленуі немесе өзгеріссіз қалдырылуы мүмкін.
In communications, traffic policing is the process of monitoring network traffic for compliance with a traffic contract and taking steps to enforce that contract. Traffic sources which are aware of a traffic contract may apply traffic shaping to ensure their output stays within the contract and is thus not discarded. Traffic exceeding a traffic contract may be discarded immediately, marked as non compliant, or left as is, depending on administrative policy and the characteristics of the excess traffic.
Әсерлер
Полицияланған трафикті қабылдаушы, кіріс трафигі келісімшартты басып өткен кездерде пакеттердің жоғалуын байқайды. Егер дереккөз жіберу жылдамдығын шектемесе (мысалы, кері байланыс механизмі арқылы), мұндай жағдай жалғаса береді және қабылдаушыға байланыс қателері немесе басқа да үзілістер кездейсоқ пакеттердің жоғалуына себеп болып жатқандай көрінеді. Полициялаудан өткен, алынған трафик әдетте келісімшартқа сәйкес келеді, бірақ полициялаудан кейінгі желі элементтері джиттерді тудыруы мүмкін. TCP сияқты сенімді протоколдарда (UDP-ге қарағанда), түсірілген пакеттер қабылдаушы тарапынан расталмайды, сондықтан олар жіберуші тарапынан қайта жіберіледі, осылайша трафик көбейеді.
The recipient of traffic that has been policed will observe packet loss distributed throughout periods when incoming traffic exceeded the contract. If the source does not limit its sending rate (for example, through a feedback mechanism), this will continue, and may appear to the recipient as if link errors or some other disruption is causing random packet loss. The received traffic, which has experienced policing en route, will typically comply with the contract, although jitter may be introduced by elements in the network downstream of the policer. With reliable protocols, such as TCP as opposed to UDP, the dropped packets will not be acknowledged by the receiver, and therefore will be resent by the emitter, thus generating more traffic.
Тоқтамаларды бақылауға арналған көздерге әсері
Кері байланыс негізінде жұмыс істейтін тығын бақылау механизмдері бар көздер (мысалы, TCP) әдетте статикалық шектеуге жылдам бейімделіп, шектеудің тұрақты жылдамдығынан сәл төменгі деңгейге жинақталады. Пакеттік жою сияқты өзара әрекеттесетін шектеу механизмдері, тез жинақталуға, жоғары тұрақтылыққа және ресурстарды тиімді бөлісуге көмектеседі. Осының салдарынан, түйіндік құрылғылар үшін тек шектелген TCP трафигін, формаланған TCP трафигінен ажырату қиын болуы мүмкін.
Sources with feedback based congestion control mechanisms (for example TCP) typically adapt rapidly to static policing, converging on a rate just below the policed sustained rate. Co operative policing mechanisms, such as packet based discard facilitate more rapid convergence, higher stability and more efficient resource sharing. As a result, it may be hard for endpoints to distinguish TCP traffic that has been merely policed from TCP traffic that has been shaped.
АТМ жағдайындағы әсері
Ұялы деңгейде трафик төмендетілген жағдайда (пакеттік бақылау арқылы емес, керісінше), әсері ең ұзын пакеттерге ерекше күшті тиеді. Ұяшықтардың ұзындығы әдетте максималды пакет көлемінен әлдеқайда қысқа болғандықтан, стандартты бақылау құрылғылары пакет шекараларын сақтамайтын ұяшықтарды жояды, демек, жойылған трафик көлемі бірнеше пакетке таралады. Көптеген пакеттерді қайта құрастыру механизмдері жоғалған ұяшыққа пакетті толығымен жою арқылы жауап береді, сондықтан бақылау шартының шамадан тыс асырылуы салдарынан көптеген пакеттер жоғалуы мүмкін.
Where cell level dropping is enforced (as opposed to that achieved through packet based policing) the impact is particularly severe on longer packets. Since cells are typically much shorter than the maximum packet size, conventional policers discard cells which do not respect packet boundaries, and hence the total amount of traffic dropped will typically be distributed throughout a number of packets. Almost all known packet reassembly mechanisms will respond to a missing cell by dropping the packet entirely, and consequently a very large number of packet losses can result from moderately exceeding the policed contract.
Процесс
RFC 2475 трафик бақылау элементтерін, мысалы, өлшегішті және тамшылағышты сипаттайды. Олар, сонымен қатар, белгілегішті де қамтуы мүмкін. Өлшегіш трафикті өлшейді және оның келісімшарттан асып кеткенін анықтайды (мысалы, GCRA арқылы). Келісімшарттан асып кеткен жағдайда, белгілі бір саясат кез келген PDU-ны тастау қажеттігін немесе таңбалауды жүзеге асыру қажеттігін, егер таңбалау жүзеге асырылатын болса, оның қалай жасалатынын анықтайды. Таңбалауға тығырық белгісін орнату (мысалы, TCP-ның ECN белгісі немесе ATM-ның CLP биті) немесе трафик жиынтық көрсетуін орнату (мысалы, IP-ның дифференциацияланған қызмет коды нүктесі) кіруі мүмкін. Жай ғана іске асыруда трафик екі санатқа немесе «түстерге» бөлінеді: келісімді (жасыл) және артық (қызыл). RFC 2697 үш «түсті» көбірек дәл жіктеуді ұсынады. Осы құжатта келісімшарт үш параметр арқылы сипатталады: міндетті ақпарат мөлшері (CIR), міндетті жарылу көлемі (CBS) және артық жарылу көлемі (EBS). Пакет «жасыл» болса, ол CBS-тен аспайды, «сары» болса, CBS-тен асып, бірақ EBS-тен аспайды, ал «қызыл» басқа жағдайда. RFC 2697 сипаттаған «бір жылдамдық үш түсті белгілегіш» уақытша жарылыстарға мүмкіндік береді. Жарылыстар бұрын желі аз қолданылған кезде рұқсат етіледі. RFC 2698-де көбірек болжауға болатын алгоритм сипатталған, ол «екі жылдамдық үш түсті белгілегішті» ұсынады. RFC 2698 жаңа параметрді, ең жоғары ақпарат жылдамдығын (PIR) анықтайды. RFC 2859 «Уақыттық жылжымалы терезе үш түсті белгілегішті» сипаттайды, ол трафик ағынын өлшейді және екі белгілі жылдамдыққа қатысты өлшенген өткізуге негізделген пакеттерді белгілейді: міндеттелген мақсатты жылдамдық (CTR) және ең жоғары мақсатты жылдамдық (PTR).
RFC 2475 describes traffic policing elements like a meter and a dropper. They may also optionally include a marker. The meter measures the traffic and determines whether or not it exceeds the contract (for example by GCRA). Where it exceeds the contract, some policy determines if any given PDU is dropped, or if marking is implemented, if and how it is to be marked. Marking can comprise setting a congestion flag (such as ECN flag of TCP or CLP bit of ATM) or setting a traffic aggregate indication (such as Differentiated Services Code Point of IP). In simple implementations, traffic is classified into two categories, or "colors" : compliant (green) and in excess (red). RFC 2697 proposes a more precise classification, with three "colors". In this document, the contract is described through three parameters: Committed Information Rate (CIR), Committed Burst Size (CBS), and Excess Burst Size (EBS). A packet is "green" if it doesn't exceed the CBS, "yellow" if it does exceed the CBS, but not the EBS, and "red" otherwise. The "single rate three color marker" described by RFC 2697 allows for temporary bursts. The bursts are allowed when the line was under used before they appeared. A more predictable algorithm is described in RFC 2698, which proposes a "double rate three color marker". RFC 2698 defines a new parameter, the Peak Information Rate (PIR). RFC 2859 describes the "Time Sliding Window Three Colour Marker" which meters a traffic stream and marks packets based on measured throughput relative to two specified rates: Committed Target Rate (CTR) and Peak Target Rate (PTR).
Қолданылу
Cisco жабдықтарында трафик бақылау және пішіндеу екі түрі де токендік шелек алгоритмі арқылы іске асырылады. ATM желілерінде трафик бақылау пайдалану/желі параметрлерін бақылау деп аталады. Желіде сәйкессіз трафикті де жою мүмкіндігі бар (Басымдық бақылауын қолдану арқылы). ATM-де трафик бақылау және трафик пішіндеу үшін анықтама (ATM Форумы және ITU-T ұсынған) – Generic Cell Rate Algorithm (GCRA) болып табылады, ол ағып тұратын шелек алгоритмінің түрі ретінде сипатталады. Дегенмен, ағып тұратын шелек және токендік шелек алгоритмдерін салыстыру олардың бір-бірінің кері бейнесі екенін көрсетеді, бірі шелек мазмұнын қосады, екіншісі алып тастайды, ал екіншісі қосады, бірі алып тастайды. Сондықтан, эквивалентті параметрлер берілген жағдайда, екі алгоритмнің де іске асырылуы сәйкес және сәйкессіз трафикті бірдей деп анықтайды. Трафик бақылау бақыланатын әрбір трафик ағыны үшін сандық статистиканы және өлшемдерді сақтауды талап етеді, бірақ ол маңызды көлемде пакеттік буферді іске асыруды немесе басқаруды қажет етпейді. Осы себепті, оны іске асыру трафикті пішіндеуге қарағанда әлдеқайда қарапайым.
On Cisco equipment, both traffic policing and shaping are implemented through the token bucket algorithm. Traffic policing in ATM networks is known as Usage/Network Parameter Control. The network can also discard non conformant traffic in the network (using Priority Control). The reference for both traffic policing and traffic shaping in ATM (given by the ATM Forum and the ITU T) is the Generic Cell Rate Algorithm (GCRA), which is described as a version of the leaky bucket algorithm. However, comparison of the leaky bucket and token bucket algorithms shows that they are simply mirror images of one another, one adding bucket content where the other takes it away and taking away bucket content where the other adds it. Hence, given equivalent parameters, implementations of both algorithms will see exactly the same traffic as conforming and non conforming. Traffic policing requires maintenance of numerical statistics and measures for each policed traffic flow, but it does not require implementation or management of significant volumes of packet buffer. Consequently, it is significantly less complex to implement than traffic shaping.
Қосылымды басқарудың баламасы
Қосылымға бағытталған желілер (мысалы, ATM жүйелері) трафик келісімшарттары негізінде қосылымға қабылдауды бақылау (CAC) жүргізе алады. Voice over IP (VoIP) контекстінде бұл Call Admission Control (CAC) деп те аталады. Қосылымға бағытталған желі арқылы трафик жібергісі келетін қосымша, ең алдымен қосылымды сұрауы керек (мысалы, Q.2931 сигнализациясы арқылы), бұл желіге трафик сипаттамалары мен қажетті қызмет сапасы (QoS) туралы хабарлауды қамтиды. Бұл ақпарат трафик келісімшартымен салыстырылады. Егер қосылым сұранысы қабылданса, қосымшаға трафик жіберу үшін желіні пайдалануға рұқсат беріледі. Бұл функция желі ресурстарын қасақана жасалған қосылымдардан қорғайды және әрбір қосылымның келісілген трафик келісімшартына сәйкес келуін қамтамасыз етеді. CAC пен трафик бақылаудың арасындағы айырмашылық – CAC өткізу алдындағы алдын ала тексеру, ал трафик бақылау – өткізу барысындағы кейіннен тексеру болып табылады.
Connection oriented networks (for example ATM systems) can perform Connection Admission Control (CAC) based on traffic contracts. In the context of Voice over IP (VoIP), this is also known as Call Admission Control (CAC). An application that wishes to use a connection oriented network to transport traffic must first request a connection (through signalling, for example Q.2931), which involves informing the network about the characteristics of the traffic and the quality of service (QoS) required by the application. This information is matched against a traffic contract. If the connection request is accepted, the application is permitted to use the network to transport traffic. This function protects the network resources from malicious connections and enforces the compliance of every connection to its negotiated traffic contract. Difference between CAC and traffic policing is that CAC is an a priori verification (before the transfer occurs), while traffic policing is an a posteriori verification (during the transfer).