Кіріспе

IPv4 пакеті тақырыбындағы өріс. Қызмет түрі (ToS) өрісі – IPv4 тақырыбының екінші байты. Ол жылдар бойы әртүрлі мақсаттарға қолданылып, бес RFC құжатында әртүрлі жолдармен анықталды. Жаңадан анықталуына дейін, ToS өрісі деректердің басымдығын көрсетуге және төменгі задерлі, жоғары өткізу қабілетті немесе жоғары сенімді қызмет үшін маршрутты сұрауға мүмкіндік берді. Осы ToS мәндеріне сүйене отырып, пакет басымдылық бойынша шығыс кезекке қойылатын немесе тиісті задерлі, өткізу қабілетті немесе сенімділікке ие маршрутты таңдайтын. Іс жүзінде, ToS өрісі АҚШ Қорғаныс министрлігінің желілерінен тыс кеңінен қолданылмады. Дегенмен, осы сегіз битті қалай пайдалануға болатынына қатысты көптеген тәжірибелік, зерттеу және енгізу жұмыстары жүргізілді, нәтижесінде қазіргі DS өрісінің анықтамасы пайда болды. IPv6 пакеттеріндегі трафик класы өрісі үшін де қолданылатын ToS өрісінің қазіргі заманғы жаңа анықтамасы – 6 битті Дифференциацияланған қызмет көрсету коды (DSCP) өрісі және 2 битті Ашық қанағаттанбау туралы хабарлама (ECN) өрісінен тұратын 8 битті Дифференциацияланған қызметтер өрісі (DS өрісі). Дифференциацияланған қызметтер шартты түрде ToS-пен кері үйлесімді болғанымен, ECN кері үйлесімді емес.

Тарих

IP-басындағы қызмет түрі өрісі бастапқыда RFC 791-де анықталды және содан бері IP-нің басымдығы мен қызмет көрсету шарттары үшін интерпретацияланды. Анықтама негізінен хабарлама басымдығын анықтайтын JANAP 128 АҚШ Қорғаныс министрлігінің ерекшелігінен алынған. Ол әрбір IP-пакетке басымдық тағайындау механизмін, сондай-ақ жоғары өткізу қабілеті, жоғары сенімділік немесе төмен задержка сияқты арнайы өңдеуді сұрау механизмін анықтады. RFC 1349 жаңартуында Ақшалай құн биті енгізілді (бұл бит бұрын "Болашақта пайдалану үшін резервтелген" деп белгіленген). RFC 1583 (OSPFv2) 2.4-бөлімі ToS-қа сезімтал маршруттау әдісін ұсынады. Іс жүзінде, өрістің тек IP басымдылығы бөлігі АҚШ Қорғаныс министрлігінің желілерінен тыс қолданылған: IP басымдылығы өрісінің мәні неғұрлым жоғары болса, IP пакетінің басымдығы соғұрлым жоғары болады. Кейбір АҚШ Қорғаныс министрлігінің желілері мұхиттық кабельдік жолдар мен спутниктік байланыс (SATCOM) жолдары арасында маршрутты таңдау үшін кешігу битін қолданды, егер екі жол да бар болса. IPv6 ешқашан IPv4-тегі "дәстүрлі" ToS өрісіне ие болған емес, өйткені авторлар оны жобалау кезінде DiffServ күш-жігерін білген (RFC 2460 7-бөлімі). RFC 2474 осы өрістің толық анықтамасын өзгертті. Ол енді "DS" (Differentiated Services, "DiffServ") өрісі деп аталады және жоғарғы 6 биті "DSCP" (Differentiated Services Code Point) деп аталатын мәнді қамтиды. DS өрісінің жоғарғы 3 биті IP басымдылығымен үйлесімділікті сақтайды. RFC 3168-ден бастап қалған екі бит (ең кіші маңызды екі бит) Explicit Congestion Notification үшін қолданылады. RFC 8622 басқа трафикпен ығыстырылуы мүмкін трафик үшін төменгі күш (LE) DS қосты (жақсы күш трафигі). Ол төмен басымдылыққа ие фондық трафик үшін арналған, мысалы, уақыт бойынша төмен басымдылықты жапсырмалы деректерді тасымалдау үшін.