Введение

Поле в заголовке пакета IPv4. Поле типа обслуживания (ToS) является вторым байтом заголовка IPv4. На протяжении многих лет оно имело различные назначения и было определено разными способами в пяти RFC. До переопределения поле ToS могло указывать приоритет датаграммы и запрашивать маршрут с низкой задержкой, высокой пропускной способностью или высокой надежностью обслуживания. На основе этих значений ToS пакет помещался бы в приоритетную исходящую очередь или направлялся по маршруту с соответствующей задержкой, пропускной способностью или надежностью. На практике поле ToS никогда не получило широкого распространения за пределами сетей Министерства обороны США. Однако значительная часть экспериментальных, исследовательских и внедренческих работ была посвящена тому, как использовать эти восемь бит, что привело к текущему определению поля DS. Современное переопределение поля ToS, также используемое для поля класса трафика в пакетах IPv6, представляет собой 8-битное поле дифференцированных услуг (поле DS), состоящее из 6-битного поля кода дифференцированных услуг (DSCP) и 2-битного поля явного уведомления о перегрузке (ECN). В то время как дифференцированные услуги частично обратно совместимы с ToS, ECN – нет.

История

Поле "Тип службы" в заголовке IP было первоначально определено в RFC 791 и с тех пор интерпретировалось для IP-прецедентности и ToS. Определение во многом основано на спецификации Министерства обороны США JANAP 128, определяющей приоритет сообщений. В ней был определен механизм присвоения приоритета каждому IP-пакету, а также механизм запроса определенной обработки, такой как высокая пропускная способность, высокая надежность или низкая задержка и т. д. В обновлении RFC 1349 введен бит "Стоимость" (ранее этот бит был помечен как "Зарезервировано для будущего использования"). Раздел 2.4 RFC 1583 (OSPFv2) представляет метод маршрутизации с учетом ToS. На практике за пределами сетей Министерства обороны США использовалась только часть поля IP Precedence: чем выше значение поля IP Precedence, тем выше приоритет IP-пакета. Некоторые сети Министерства обороны США использовали бит задержки для выбора маршрута между океанскими кабельными линиями и каналами спутниковой связи (SATCOM), когда оба канала были доступны. IPv6 никогда не имел "традиционного" поля ToS, как в IPv4, отчасти потому, что авторы знали об усилиях DiffServ на этапе его разработки (RFC 2460, раздел 7). В RFC 2474 определение всего этого поля было изменено. Теперь оно называется полем "DS" (Differentiated Services, "DiffServ"), а верхние 6 бит содержат значение, называемое "DSCP" (Differentiated Services Code Point). Верхние 3 бита DS обеспечивают совместимость с IP-прецедентностью. Начиная с RFC 3168, оставшиеся два бита (два младших бита) используются для явного уведомления о перегрузке. RFC 8622 добавил DS с низкими затратами усилий (LE) для трафика, который может быть вытеснен другим трафиком (трафик с наилучшими усилиями). Он предназначен для фонового трафика с низким приоритетом, например, для массовой передачи данных с низкой временной приоритетностью.