Кіріспе

Орналасу туралы ақпарат сервері немесе LIS – Ұлттық авариялық нөмірлер қауымдастығының i2 желілік архитектурасында бастапқыда анықталған желілік түйін. Ол VoIP телефониясы қолданушыларына e911 қызметін көрсетудің аралық шешімін қамтамасыз етеді. LIS – VoIP терминалының орналасқан жерін анықтайтын түйін. NENA архитектурасымен және VoIP-тен асып түсе отырып, LIS өзіне қарасты қолжетімді желі ішіндегі кез келген IP құрылғысына орналасу туралы ақпарат бере алады.

LIS-тің рөлі

Адамдар мен жабдықтарды анықтауға арналған таратылған жүйелер ертеңгі күннің белсенді кеңселерiнiң негiзiн құрайды. Компьютерлiк және коммуникациялық жүйелер кеңселерде және үйлерде көбейiп келедi. Жүйелер әртүрлi және күрделi, сымсыз желілер мен мобильді компьютерлерді қамтиды. Дегенмен, жүйелер тиiстi деңгейде пайдаланылмайды, себебi басқару механизмдерi мен қолданба интерфейстерiнiң таңдаулары тым әртүрлi. Сондықтан, пайдаланушыларға жүйелердi қарапайым және кең таралған тәсiлдермен басқаруға мүмкiндiк беретiн механизмдердi және компьютерлердi қоршаған ортадағы мүмкiндiктердi қалай жақсырақ сезiнуге үйретуге болатынын қарастыру қажет. Ұйым iшiндегi адамдар мен жабдықтардың орналасқан жерiн бiлу – осындай мүмкiндiктердiң бiрi. Ресурс дерекқорына орналасу туралы ақпаратты қосу арқылы, басқару және өзара әрекеттесу үшiн орналасуға негiзделген ережелер құруға болады. Бұл тәсiл әсiресе тартымды, себебi физикалық тұрғыдан бiрқатар ыңғайсыздықтарды тудырмайтын және пайдаланушының нақты әрекеттерiне тәуелдi емес орналасу әдiстерiн жасауға болады. Мақалада адамдар мен жабдықтарды анықтау жүйесiнiң технологиясы және осы ақпаратқа қол жеткiзудi қолдайтын таратылған жүйелiк қызметтiң дизайны сипатталған. Осы мүмкiндiк арқылы қамтамасыз етiлетiн немесе осы мүмкiндiктен пайдаланатын қолданба интерфейстерi ұсынылады.

Орналасуды анықтау

Қосымша желідегі құрылғының орналасуын анықтау әдісі әртүрлі желілерде әртүрлі болады. Ethernet немесе DSL сияқты сымдық желілер үшін сым картасы әдісі жиі қолданылады. Сым картасы арқылы орналасуды анықтауда құрылғының орналасуы, оған пакеттерді жіберу үшін қолданылатын кабельдерді анықтау арқылы белгіленеді. Бұл желідегі агрегациялық нүктелер (мысалы, Ethernet коммутаторлары немесе DSL кіру тораптары) арқылы деректерді іздеуді және сол құрылғыға арналған пакеттер жіберілетін портты табуды қамтиды. Бұл ақпарат LIS-ке қолжетімді деректермен (әдетте деректер базасынан алынған) біріктіріліп, соңғы орналасу анықталады. Мұндай іздеу қалай жүргізіледі, ол желі түріне байланысты. Сымсыз желілерде орналасуды анықтау үшін түрлі технологиялар қолданылуы мүмкін, олардың ең қарапайымы радио таратушының орналасуын шамамен анықтауға негізделген. Қолданылатын нақты әдіс сым картасы әдісіне ұқсас: егер радио таратушы анықталса, құрылғының орналасуы белгісіздік аймағымен көрсетілген таратушының орналасуы ретінде беріледі.

Архитектура және протоколдар

IETF LIS-тен орналасу туралы ақпаратты алуға арналған архитектура мен протоколдарды анықтады. Жедел қолжетімді желідегі LIS автоматты түрде табылады және орналасу туралы ақпарат HELD протоколы арқылы алынады. Орналасу туралы ақпаратты тікелей – мәні бойынша (by value) алуға болады, немесе LIS уақытша URI-ді жасайды, оны орналасу URI ретінде жанама түрде беруге болады. LIS ұсынатын орналасу туралы ақпарат негізінен GEOPRIV форматын (RFC 4119) пайдаланады, бұл RFC 3863-те анықталған нақтылау форматына негізделген XML ұсынымы. RFC 4119 геодезиялық координаттар мен азаматтық мекенжай туралы ақпаратты қамтиды (қазір RFC 5139-мен жаңартылды) және сонымен қатар пайдаланушының жеке өмірге қатысты пікірлерін білдіретін элементтерді анықтайды.