Кіріспе
Дүниежүзілік желідегі анықталатын нысан Веб-ресурс – Дүниежүзілік желіде немесе оған қосылған кез келген анықталатын ресурс (цифрлық, физикалық немесе абстрактілік). Ресурстар Бірыңғай ресурс идентификаторлары (URI) арқылы анықталады. Семантикалық желіде веб-ресурстар мен олардың семантикалық қасиеттері Ресурстарды сипаттау тілі (RDF) арқылы сипатталады. Веб-ресурс туралы түсінік, Веб тарихы барысында статикалық адрестелетін құжаттар немесе файлдар туралы бастапқы түсініктерден бастап, қазіргі кезде кез келген "нәрсені" немесе нысанды қамтитын, оны анықтауға, атауға, адрестеуге немесе кез келген тәсілмен өңдеуге болатын, жалпы Веб немесе кез келген желілік ақпараттық жүйедегі кез келген нысанға дейін дамыды. Ресурстың мәлімдемелік аспектілері (анықтау және атау) мен функционалдық аспектілері (адрестеу және техникалық өңдеу) Вебтің алғашқы сипаттамаларында нақтырақ ажыратылмаған, ал осы ұғымның анықтамасы күрделі және көбінесе түсініксіз техникалық, әлеуметтік, тілдік және философиялық мәселелерді қамтитын, ұзаққа созылған және әлі де аяқталмаған пікірталас тақырыбы болып табылады.
A web resource is any identifiable resource (digital, physical, or abstract) present on or connected to the World Wide Web. Resources are identified using Uniform Resource Identifiers (URIs). In the Semantic Web, web resources and their semantic properties are described using the Resource Description Framework (RDF). The concept of a web resource has evolved during the Web's history, from the early notion of static addressable documents or files, to a more generic and abstract definition, now encompassing every "thing" or entity that can be identified, named, addressed or handled, in any way whatsoever, in the web at large, or in any networked information system. The declarative aspects of a resource (identification and naming) and its functional aspects (addressing and technical handling) weren't clearly distinct in the early specifications of the web, and the very definition of the concept has been the subject of long and still open debate involving difficult, and often arcane, technical, social, linguistic and philosophical issues.
Құжаттар мен файлдардан веб-ресурстарға дейін
Вебтің алғашқы сипаттамаларында (1990–1994) ресурс термині іс жүзінде қолданылмайды. Веб – бірыңғай ресурс локаторлары (URL) арқылы байланыстырылған, негізінен файлдар мен құжаттардан тұратын, көбінесе статикалық адрестелетін нысандар желісі ретінде құрылған. Веб-ресурсы анықталуға болатын нәрсе ретінде түсіндіріледі. Анықтама екі ерекше мақсатқа қызмет етеді: атау беру және адрестеу; соңғысы тек протоколға тәуелді. RFC 1630 ресурс ұғымын анықтауға тырыспайтыны байқалады; шындығында, ол бұл терминді бірыңғай ресурс идентификаторы (URI), бірыңғай ресурс локаторы (URL) және бірыңғай ресурс атауы (URN) терминдерінде кездеуінен басқа қолданбайды және әлі де «Желі нысандары» туралы сөйлейді. RFC 1738 (1994 жылғы желтоқсан) URL-ді одан әрі нақтылайды, «Universal» термині «Uniform» деп өзгертіледі. Құжат интернет арқылы «қол жетімді» немесе «табылып, қол жеткізілетін» нысандарға сілтеме жасау үшін ресурсты жүйелі түрде пайдаланады. Бірақ бұл жерде де ресурс термині нақты анықталмайды.
RDF және Семантикалық Веб ресурстары
1999 жылы алғаш рет жарияланған RDF бастапқыда ресурстарды сипаттау, яғни ресурстардың метадеректерін стандартты тәсілмен жариялау мақсатында жасалған. Ресурстың RDF сипаттамасы – бұл үштіктер жиынтығы (субъект, предикат, объект), мұнда субъект сипатталатын ресурсты білдіреді, предикат осы ресурсқа қатысты қасиеттің түрін, ал объект деректерді немесе басқа ресурсты көрсетеді. Предикат өзі ресурс ретінде қарастырылады және URI арқылы сәйкестендіріледі. Сондықтан "title", "author" сияқты қасиеттер RDF-те ресурстар ретінде бейнеленеді, оларды рекурсивті түрде басқа үштіктердің субъектісі ретінде қолдануға болады. Осы рекурсивті принципке негізделіп, RDF сөздіктері, мысалы RDF схемасы (RDFS), Веб-онтология тілі (OWL) және қарапайым білімді ұйымдастыру жүйесі сыныптар, қасиеттер, түсініктер сияқты абстракті ресурстардың анықтамаларын жинақтайды, барлығы URI арқылы сәйкестендіріледі. RDF сонымен қатар URI арқылы толық анықталмайтын анонимді ресурстар немесе бос түйіндердің анықтамасын да белгілейді.
Абстрактілік ресурстарды анықтау үшін HTTP URI пайдалану
URL-тер, әсіресе HTTP URI-лер, сабақтар, қасиеттер немесе басқа да ұғымдар сияқты абстракті ресурстарды анықтау үшін жиі қолданылады. Мысалдарды RDFS немесе OWL онтологияларынан табуға болады. Мұндай URI-лер HTTP протоколымен байланысты болғандықтан, бұл протокол арқылы, әдетте веб-браузерді пайдалана отырып, осындай ресурстарды қандай түрдегі бейнелеу керек деген сұрақ туындады және URI-дің синтаксисі "абстрактілік" ресурстарды "ақпараттық" ресурстардан ажыратуға көмектесе ала ма. RFC 3986 сияқты URI спецификациялары ресурстарда орындалатын әрекеттерді анықтау міндетін протокол спецификациясына қалдырды және олар осы сұраққа ешқандай жауап бермейді. Бұрын HTTP URI ресурсты бастапқы мағынада, мысалы файл, құжат немесе кез келген ақпарат ресурсын анықтайтын "slash" URI болуы керек деп айтылған болатын. Басқаша айтқанда, фрагмент идентификаторын қамтымауы керек, ал ұғымды немесе абстрактілік ресурсты анықтау үшін қолданылатын URI фрагмент идентификаторын пайдаланатын "hash" URI болуы керек. Мысалы: http://www.example.org/catalogue/widgets.html веб-бетті анықтап, оны табады (бәлкім, Silly Widgets, Inc. сататын виджеттердің адам оқитын сипаттамасын береді), ал http://www.example.org/ontology#Widget компанияның онтологиясындағы абстрактілік ұғымды немесе "Widget" класын анықтайды және міндетті түрде HTTP протоколы арқылы кез келген физикалық ресурсты қайтарып алмайды. Бірақ мұндай айырмашылықты іс жүзінде жүзеге асыру мүмкін емес деп жауап берілді және танымал стандартты сөздіктер кеңінен қолданылатын қарсы мысалдарды ұсынады. Мысалы, "title", "publisher", "creator" сияқты Дублин ядросы ұғымдары http://purl.org/dc/elements/1.1/title сияқты "slash" URI арқылы анықталады. HTTP URI қай түрдегі ресурстарды анықтауы керек немесе анықтамауы керек деген жалпы мәселе бұрын W3C-де httpRange 14 мәселесі ретінде белгілі болды, оның атауы (TAG) анықтаған тізімде. TAG 2005 жылы осы мәселеге соңғы жауап берді, "ақпараттық ресурс" пен "ақпараттық емес" ресурстың арасындағы айырмашылық сервердің "GET" сұранысына берген жауабының түріне байланысты: 2xx Сәттілік ресурс ақпараттық ресурс екенін көрсетеді. 303 Басқаны қараңыз ресурстың ақпараттық немесе абстрактілік болуы мүмкін екенін көрсетеді; қайта бағыттау нысанасы сізге айта алады. 4xx Клиенттің қатесі ешқандай ақпарат бермейді. Бұл сөздіктерге (мысалы, Дублин ядросы, FOAF және Wordnet) прагматикалық себептермен хэш орнына слэшты пайдалануды жалғастыруға мүмкіндік береді. Бұл келісім Семантикалық Веб қоғамдастығында консенсусқа тап болған сияқты, оның кейбір танымал мүшелері, мысалы, Пэт Хейс, оның техникалық мүмкіндігін және тұжырымдамалық негізін уайымдағанын білдірді. Патрик Хейздің пікірінше, "ақпараттық ресурс" пен "басқа ресурс" арасындағы ерекшелікті табу мүмкін емес және оны мүлдем нақтыламаған дұрыс, ал сілтеме ресурсының түсініктілігі кез-келген атау механизмі сияқты URI-ге тән.
2xx Success indicates resource is an information resource. 303 See Other indicates the resource could be informational or abstract; the redirection target could tell you. 4xx Client Error provides no information at all. This allows vocabularies (like Dublin Core, FOAF, and Wordnet) to continue to use slash instead of hash for pragmatic reasons. While this compromise seems to have met a consensus in the Semantic Web community, some of its prominent members such as Pat Hayes have expressed concerns both on its technical feasibility and conceptual foundation. According to Patrick Hayes' viewpoint, the very distinction between "information resource" and "other resource" is impossible to find and should better not be specified at all, and ambiguity of the referent resource is inherent to URIs like to any naming mechanism.
Ресурстарға меншік, зияткерлік меншік және сенімгерлік
RDF-де "әркім кез келген нәрсе туралы кез келген мәлімдеме жасай алады". Ресурстар формалды сипаттамалар арқылы анықталады, оларды кез келген адам жариялай, көшіре, өзгерте және веб арқылы тарата алады. Егер веб-ресурсының мазмұны классикалық түсінік бойынша (веб-бет немесе онлайн файл) оның жариялаған тұлғасына тиесілі болса, ол оған авторлық құқық тағайындауға болады, ал абстракт ресурстың сипаттамасы RDF сипаттамаларының жиынтығы арқылы жасалуы мүмкін, бұл жиынтық міндетті түрде бірегей жариялаған тұлғаның бақылауында болмайды және бір-бірімен үйлесімді болуы да міндетті емес. Ресурстың анық және сенімді иеленушісі бар ресми анықтамасы болуы керек пе, және егер солай болса, осы сипаттаманы басқа сипаттамалардан техникалық тұрғыдан қалай ажырату қажеттігі – ашық мәселе. Бұған қоса, мұндай сипаттамаларға авторлық құқық қалай қолданылатындығы да қарастырылуда.