Кіріспе
Барлық нарық қатысушылары оңай қол жеткізе алатын және пайдалана алатын стандарт. Ашық стандарт – кез келген адамға ашық түрде қол жетімді және пайдалануға болатын стандарт. Ашық стандарттардың кеңейтілуге мүмкіндік беретін ашық лицензияны қолдануы да жиі кездесетін талап. Олардың ашық табиғатынан туындайтын себепті, кез келген адам олардың әзірленуіне қатыса алады. Бірыңғай анықтамасы жоқ, түсіндірмелері қолданылуына қарай өзгереді. Ашық стандарттардың мысалдарына GSM, 4G және 5G стандарттары жатады, олар көптеген заманауи ұялы телефондардың бүкіл әлемде жұмыс істеуіне мүмкіндік береді.
An open standard is a standard that is openly accessible and usable by anyone. It is also a common prerequisite that open standards use an open license that provides for extensibility. Typically, anybody can participate in their development due to their inherently open nature. There is no single definition, and interpretations vary with usage. Examples of open standards include the GSM, 4G, and 5G standards that allow most modern mobile phones to work world wide.
Анықтамалар
Ашық және стандартты терминдердің қолданылуымен байланысты мағыналарының кең ауқымы бар. Ашық стандарттардың әртүрлі аспектілерін атап өтетін көптеген анықтамалар бар, оның ішінде дамыған спецификацияның ашықтығы, жобалау процесінің ашықтығы және стандарттағы құқықтардың меншігі. "Стандарт" термині кейде барлық мүдделі тараптардың қатысуына ашық және консенсус негізінде жұмыс істейтін ресми комитеттер бекіткен технологияларға ғана қолданылады. Академиктер, Еуропалық Одақ және Дания, Франция және Испания сияқты кейбір мүше мемлекеттердің үкіметтері немесе парламенттері қолданатын ашық стандарт терминінің анықтамалары, Жаңа Зеландия, Оңтүстік Африка және Венесуэла үкіметтері сияқты, пайдалану үшін төлем талап ететін ашық стандарттарды қабылдамайды. Стандарттау ұйымы ретінде, World Wide Web Consortium (W3C) өзінің спецификацияларын роялтисіз негізде жүзеге асыруды қамтамасыз етеді. Стандарт терминінің көптеген анықтамалары патент иелеріне стандартты жүзеге асырушыларға немесе пайдаланушыларға "әділ және кемсітпейтін лицензиялық" жарналар мен басқа да лицензиялық шарттарды жүктеуге мүмкіндік береді. Мысалы, Интернет-инженерлік тобы (IETF), Халықаралық стандарттау ұйымы (ISO), Халықаралық электротехникалық комиссия (IEC) және ITU сияқты халықаралық деңгейде танылған стандарттау органдарының стандарттары бойынша ережелер олардың стандарттарында патенттік лицензиялық төлемдерді талап ететін ерекшеліктерді қамтуға мүмкіндік береді. Бұл ұйымдардың ішінде тек IETF және ITU T өз стандарттарын "ашық стандарттар" деп атайды, ал қалғандары тек "стандарттар" жасауды айтады. IETF және ITU T "ашық стандарттың" анықтамасын қолданады, ол патенттік лицензиялық төлемдерге "әділ және кемсітушіліксіз" талаптарды қоюға рұқсат береді. Ашық кодты бағдарламалық қамтамасыз ету қауымдастығында "ашық стандарт" тек оны еркін қабылдап, жүзеге асырып және кеңейте алатын болса ғана ашық деп санайтындар бар. Ашық стандарттар немесе архитектуралар меншік құқығы жоқ деп есептелсе де, стандарттың меншігі жоқ немесе оны ұжымдық орган иеленеді, оны көпшілікпен бөлісуге және қатаң қорғауға болмайды. Стандартқа айналған "ашық бастапқы кодтың" классикалық мысалы - IBM-нің жеке компьютері, қазір Wintel деп аталады, ол Microsoft операциялық жүйесі мен Intel микропроцессорының комбинациясы. Ең көп қабылданған үш мысал бар: GSM телефондары (үкімет стандарты ретінде қабылданған), UNIX-ті насихаттайтын Open Group және SMTP және TCP/IP-тің алғашқы стандарттарын жасаған Интернет-инженерлік тобы (IETF). Сатып алушылар ашық стандарттарды артық көреді, өйткені олар желілік эффектілер мен сатушылар арасындағы бәсекелестіктің күшеюіне байланысты арзан өнімдер мен таңдау мүмкіндігін ұсынады деп санайды. Форматтарды анықтайтын ашық стандарттар кейде ашық форматтар деп аталады. Көптеген спецификациялар, кейде стандарттар деп аталатын, меншік құқығында болып табылады және оларды (егер оларды алуға болатын болса) спецификация бойынша авторлық құқықты иеленетін ұйыммен жасалған шектеулі шарттар бойынша ғана алуға болады. Осылайша, бұл спецификациялар толыққанды ашық деп есептелмейді. Джоэл Уэст "ашық" стандарттар қара және ақ емес, "ашықтықтың" әртүрлі деңгейлері бар екенін айтады. Ашық стандарт технология туралы білім жеткілікті деңгейде тарағанда пайда болады, бұл бәсекелестікті күшейтеді және басқалар технологияны жүзеге асырған кезде оны көшіре бастайды. Бұл Wintel архитектурасымен болды, өйткені басқалар бағдарламалық жасақтаманы еліктей бастады.
IETF анықтамасы
RFC 2026-ның 7-бөлімінде IETF өзіне ұқсас әдіспен әзірленген сипаттамаларды «ашық стандарттар» деп жіктейді және мысал ретінде ANSI, ISO, IEEE және ITU T ұсынған стандарттарды тізімдейді. IETF стандарттау процестері мен ИСҚ саясаты ITU T жоғарыда аталған сипаттамаларға ие болғандықтан, IETF стандарттары ITU T «ашық стандарттар» анықтамасына сай келеді. Дегенмен, IETF «ашық стандарттың» нақты анықтамасын қабылдаған жоқ; RFC 2026 және IETF-тің миссиялық мәлімдемесі (RFC 3935) «ашық процесс» туралы айтады, бірақ RFC 2026 IETF стандарттары қандай құжаттармен байланыса алатынын анықтау мақсатында ғана «ашық стандартты» анықтамайды. RFC 2026 RFC жиынтығына жатады, олар бірлесіп BCP 9 (Ең жақсы ортақ тәжірибе, IETF саясаты) деп аталады. RFC 2026 кейіннен BCP 78 және 79 (басқаларымен бірге) жаңартылды. 2011 жылдан бастап BCP 78 RFC 5378 (Құқық иелері IETF Трастына ұсынады), ал BCP 79 RFC 3979 (IETF технологиясындағы зияткерлік меншік құқықтары) және RFC 4879-дағы толықтырулардан тұрады. Бұл өзгерістер RFC 5377 негізіндегі IETF Trust Legal Provisions және Copyright FAQ-да көрсетілгендей «Simplified BSD License» – «Жеңілдетілген BSD лицензиясымен» үйлесімді болуға бағытталған. 2012 жылдың тамызында IETF W3C және IEEE-мен бірігіп OpenStand жобасын іске қосып, «Стандарттардың қазіргі заманғы парадигмасын» жариялады. Бұл «Интернет пен Вебті инновация мен шекарасыз сауда үшін жетекші платформаға айналдырған тиімді және нәтижелі стандарттау процестерін» қамтиды. Аталған мәлімдеме 2013 жылдың қаңтарында RFC 6852 нысанында жарияланды.
Француз заңдарының анықтамасы
Француз парламенті "Цифрлық экономикаға сенім туралы заңда" "ашық стандарт" анықтамасын бекітті. Анықтамасы (4-бап): Ашық стандарт – дегеніміз, кез келген коммуникация, өзара байланыс немесе ақпарат алмасу протоколы, сондай-ақ спецификациялары жариялы және оларға қол жеткізуге немесе іске асыруға ешқандай шектеулер жоқ, өзара үйлесімді деректер форматы.
By open standard is understood any communication, interconnection or interchange protocol, and any interoperable data format whose specifications are public and without any restriction in their access or implementation.
Италия заңдарының анықтамасы
Италияда ашық стандарттармен айналысатын мемлекеттік сектордың барлығына арналған жалпы ереже бар, бірақ ол дерек форматтарына баса назар аударады, бұл ереже Цифрлық әкімшілік кодексінің 68-бабында көрсетілген.
[Қолданбалар] деректерді әртүрлі форматтарда көрсетуге мүмкіндік беруі керек, олардың кем дегенде бірі ашық дерек форматы болуы тиіс. [ ]
Ашық дерек форматы – бұл деректерді жариялайтын, толыққанды құжатталған және бірдей деректерді қарау үшін қажетті технологиялық құралдарға қатысты бейтарап дерек форматы ретінде анықталады.
Ұлыбритания үкіметінің анықтамасы
Ұлыбритания үкіметінің ашық стандарттар туралы анықтамасы бағдарламалық қамтамасыздыманың өзара үйлесімділігіне, деректерге және құжат форматтарына қолданылады. Ашық стандарттарға қойылатын талаптар «Ашық стандарттар қағидаттары» саясаты құжатында жарияланған және былай бөлінеді. Ынтымақтастық – стандарт консенсус негізінде және кез келген жеке жеткізушіден тәуелсіз, бірлескен шешім қабылдау процесі арқылы қолдауға алынады. Стандартты әзірлеуге және күтуге қатысу барлық мүдделі тараптарға ашық. Ашықтық – шешім қабылдау процесі ашық жүреді, ал пәндік сарапшылар жүргізетін, жалпыға қолжетімді тексеру процестің бір бөлігі болып табылады. Тиісті процедура – стандартты стандарттау ұйымы немесе форум, консорциум қабылдайды, олар сапаны қамтамасыз ету үшін кері байланыс және бекіту процесін қамтиды. Әділ қолжетімділік – стандарт жақсы құжатталған, жұртшылыққа қолжетімді және пайдалануға тегін. Жасалған – инновациялық шешімдер құру контекстінде болмаса, толық дамыған. Платформаға, қолданбаға және сатушыға тәуелсіз – нарықта бірнеше іске асырылған. Құқықтар – стандартты іске асыруға және сол стандартты қолданған басқа іске асырылымдармен байланысуға қажетті құқықтар, ашық бастапқы кодты және меншікті лицензиялық шешімдермен үйлесімді, лицензиялық төлемсіз беріледі. Бұл құқықтар лицензиялық шарттар бұзылған жағдайда ғана жойылуы мүмкін. Ұлыбританиядағы Кабинет кеңсесі мемлекеттік органдарға өзара үйлесімділікті және қайта пайдалануды ынталандыру және технологиялық тұйықталудан сақтану үшін сатып алу кезінде ашық стандарттарды қолдану арқылы талаптарды нақтылауды ұсынады.
FFII-дің анықтамасы
Азат ақпараттық инфрақұрылымның анықтамасы 2004 жылы жарияланған Еуропалық өзара үйлесімділік аясының анықтамасымен сәйкес келеді делінеді. Бұл стандарт ашық, кіріктірілген және ашық стандарттау процесінде әзірленген және күтіліп келеді, оны кез келген адам ешқандай шектеусіз, төлемсіз және авторлық құқықтарды лицензиялаусыз (барлығына тегін және ешқандай талапсыз беріледі) іске асыра алады. Бұл W3C сияқты стандарттау органдарының талап ететін ең төменгі лицензиялық талаптар. Әрине, басқа да органдар ашық стандарттарды қабылдайды. Бірақ, спецификацияның өзі қымбатқа түсуі мүмкін (мысалы, ISO-дағыдай бір данасы 100-400 евроға дейін, себебі авторлық құқық және құжатты жариялау).
Анықтамаларды салыстыру
Баспасөз Жариялану уақыты Қолжетімділік (Техникалық ерекшеліктерді қайта тарату) Пайдалану құқықтары (Маңызды патенттерді лицензиялау) Процесс (Одан әрі дамыту процесі) Толықтығы Ақысыз FRAND шарттары, роялтисіз, қайтарылмайтын FRAND шарттары Ашық қатысу Ашық қарау Кемелденуі үшін бірнеше сатушылардың іске асыруы немесе ашық анықтама қажет Бірлескен IEEE, ISOC, W3C, IETF, IAB 2012 08 12 ITU T 2005 03 ✔ ✔ Pan European eGovernment 2004 0 немесе номиналды ✔ ✔ Дания үкіметі 2004 ✔ Француз заңы 2004 Үнді үкіметі 2014 0 немесе номиналды ✔ ✔ Италия заңы 2005 03 07 Жаңа Зеландия e GIF 2007 06 22 ✔ Португалия заңы 2011 06 21 ✔ ✔ ✔ Оңтүстік Африка үкіметі 2007 ✔ ✔ ✔ ✔ Испан заңы 2007 06 22 0 немесе төмен Ұлыбритания үкіметі 2012 0 немесе төмен ✔ ✔ ✔ Венесуэла заңы 2004 12 23 Брюс Персен 2002 жылға дейін Артықшылықты ✔ Microsoft c. 2006 ✔ ✔ Open Source Initiative 2006 09 ✔ ✔ Кен Крехмер 2005 01 ✔ ✔ ✔ W3C 2005 09 ✔ ✔ ✔ DIGISTAN c. 2008 ✔ ✔ ✔ FSFE 2001 ✔ ✔ ✔ FFII 2004 жылға дейін ✔
Ашық стандарттардың мысалдары
Ескеріңіз, "ашық стандарт" терминінің әртүрлі анықтамалары талаптарымен өзгеше келетіндіктен, төменде тізілген стандарттар барлық анықтамалар бойынша ашық болып келе бермейді.