Введение

Стандарт, к которому легко могут получить доступ и который могут использовать все участники рынка. Открытый стандарт – это стандарт, который находится в открытом доступе и может быть использован любым желающим. Обычно открытые стандарты используют открытую лицензию, обеспечивающую возможность расширения и доработки. Благодаря своей природе, любой может участвовать в их разработке. Единого определения не существует, и интерпретации могут различаться в зависимости от контекста использования. Примерами открытых стандартов являются стандарты GSM, 4G и 5G, обеспечивающие работу большинства современных мобильных телефонов по всему миру.

Определения

Термины "открытый" и "стандартный" имеют широкий спектр значений в зависимости от контекста их использования. Существует множество определений открытых стандартов, подчеркивающих различные аспекты открытости, включая открытость самой спецификации, открытость процесса разработки и права на стандарт. Термин "стандарт" иногда ограничивается технологиями, утвержденными формализованными комитетами, открытыми для участия всех заинтересованных сторон и работающими на основе консенсуса. Определения термина "открытый стандарт", используемые научными кругами, Европейским союзом и некоторыми государствами-членами или парламентами, такими как Дания, Франция и Испания, исключают открытые стандарты, требующие платы за использование, как и правительства Новой Зеландии, Южной Африки и Венесуэлы. Что касается организаций по стандартизации, Консорциум Всемирной паутины (W3C) гарантирует, что его спецификации могут быть реализованы без уплаты роялти. Многие определения термина "стандарт" разрешают владельцам патентов взимать "разумные и недискриминационные" лицензионные сборы и устанавливать другие условия лицензирования для тех, кто внедряет или использует стандарт. Например, правила стандартов, публикуемые крупными международными организациями по стандартизации, такими как Internet Engineering Task Force (IETF), Международная организация по стандартизации (ISO), Международная электротехническая комиссия (IEC) и ITU T, допускают включение в их стандарты спецификаций, реализация которых потребует выплаты лицензионных сборов за патенты. Среди этих организаций только IETF и ITU T явно называют свои стандарты "открытыми стандартами", в то время как остальные говорят лишь о производстве "стандартов". IETF и ITU T используют определения "открытого стандарта", которые допускают требования к "разумным и недискриминационным" лицензионным сборам за патенты. В сообществе разработчиков программного обеспечения с открытым исходным кодом существуют сторонники точки зрения, что "открытый стандарт" является по-настоящему открытым только в том случае, если его можно свободно использовать, внедрять и расширять. Хотя открытые стандарты или архитектуры считаются не проприетарными в том смысле, что стандарт либо не имеет владельца, либо принадлежит коллективному органу, он все равно может быть общедоступным и не подвергаться жесткому контролю. Типичным примером "открытого исходного кода", ставшего стандартом, является персональный компьютер, разработанный IBM и теперь известный как Wintel – комбинация операционной системы Microsoft и микропроцессора Intel. Существуют еще три широко признанных "открытых" стандарта: телефоны GSM (принятые в качестве государственного стандарта), Open Group, продвигающая UNIX, и Internet Engineering Task Force (IETF), создавшая первые стандарты SMTP и TCP/IP. Покупатели, как правило, предпочитают открытые стандарты, поскольку считают, что они предлагают более дешевые продукты и больший выбор благодаря сетевому эффекту и усилению конкуренции между поставщиками. Открытые стандарты, определяющие форматы, иногда называют открытыми форматами. Многие спецификации, которые иногда называют стандартами, являются проприетарными и доступны только (если вообще доступны) на условиях ограничительных договоров с организацией, владеющей авторскими правами на спецификацию. Следовательно, эти спецификации не считаются полностью открытыми. Джоэл Уэст утверждает, что "открытые" стандарты не бывают однозначными, а имеют множество уровней "открытости". Стандарт становится более открытым, когда знания о технологии достаточно распространяются, что приводит к усилению конкуренции и возможности для других копировать технологию при ее внедрении. Это произошло с архитектурой Wintel, поскольку другие смогли начать имитировать программное обеспечение.

Определение IETF

В разделе 7 RFC 2026 IETF классифицирует спецификации, разработанные аналогичным IETF образом, как «открытые стандарты» и приводит в качестве примеров стандарты, разработанные ANSI, ISO, IEEE и ITU T. Поскольку процессы стандартизации IETF и политики в отношении прав интеллектуальной собственности (ИС) обладают характеристиками, перечисленными ITU T, стандарты IETF соответствуют определению «открытых стандартов» ITU T. Однако IETF не приняло конкретного определения «открытого стандарта»; как RFC 2026, так и заявление о миссии IETF (RFC 3935) говорят об «открытом процессе», но RFC 2026 не определяет «открытый стандарт», за исключением цели определения документов, на которые могут ссылаться стандарты IETF. RFC 2026 входит в набор RFC, известных как BCP 9 (Best Common Practice – политика IETF). RFC 2026 впоследствии был обновлен BCP 78 и 79 (и другими). По состоянию на 2011 год BCP 78 – это RFC 5378 («Права, предоставляемые участниками IETF Trust»), а BCP 79 состоит из RFC 3979 («Права интеллектуальной собственности в технологиях IETF») и разъяснений в RFC 4879. Эти изменения призваны быть совместимыми с «Упрощенной BSD-лицензией», как указано в Legal Provisions IETF Trust и FAQ по авторскому праву на основе RFC 5377. В августе 2012 года IETF объединился с W3C и IEEE для запуска OpenStand и публикации The Modern Paradigm for Standards. Это отражает «эффективные процессы стандартизации, которые сделали Интернет и Web ведущими платформами для инноваций и безграничной торговли». Затем декларация была опубликована в форме RFC 6852 в январе 2013 года.

Определение французского права

Французский парламент утвердил определение "открытого стандарта" в своем "Законе о доверии к цифровой экономике". Определение (статья 4): Открытым стандартом понимается любой протокол связи, взаимодействия или обмена данными, а также любой совместимый формат данных, спецификации которого находятся в открытом доступе и не имеют ограничений на доступ или реализацию.

Определение итальянского права

В Италии действует общее правило для всего государственного сектора в отношении открытых стандартов, хотя оно сосредоточено преимущественно на форматах данных, и закреплено в ст. 68 Кодекса о цифровом администрировании (Codice dell'Amministrazione Digitale).

[Приложения должны] обеспечивать представление данных в различных форматах, как минимум один из которых должен быть открытым форматом данных.

[Определяется] открытый формат данных как формат данных, который является общедоступным, тщательно документированным и нейтральным по отношению к технологическим средствам, необходимым для его обработки.

Определение правительства Великобритании

Определение открытых стандартов, данное правительством Великобритании, распространяется на совместимость программного обеспечения, данные и форматы документов. Критерии открытых стандартов опубликованы в документе "Принципы открытых стандартов" и следующие:

Сотрудничество – стандарт поддерживается посредством совместного процесса принятия решений, основанного на консенсусе и независимого от какого-либо отдельного поставщика. Участие в разработке и поддержании стандарта доступно всем заинтересованным сторонам.

Прозрачность – процесс принятия решений прозрачен, и общедоступный анализ экспертами в соответствующей области является его частью.

Процедура – стандарт принимается организацией по разработке спецификаций или стандартизации, либо форумом или консорциумом с механизмом обратной связи и ратификации для обеспечения качества.

Свободный доступ – стандарт хорошо документирован, находится в открытом доступе и свободен от платежей за использование.

Зрелость – полностью разработан, за исключением случаев, когда он используется для создания инновационных решений.

Независимость от платформы, приложения и поставщика – поддерживается рынком и имеет несколько реализаций.

Права – права, необходимые для реализации стандарта и взаимодействия с другими реализациями, использующими тот же стандарт, лицензируются на безвозмездной основе, совместимой как с решениями с открытым исходным кодом, так и с проприетарными решениями. Эти права должны быть безотзывными, за исключением случаев нарушения условий лицензии.

Кабинет министров Великобритании рекомендует государственным органам указывать требования к использованию открытых стандартов при проведении закупок для обеспечения совместимости, повторного использования и предотвращения технологической привязки.

Определение FFII

Считается, что определение Фонда свободной информационной инфраструктуры совпадает с определением, представленным в Европейской структуре обеспечения совместимости, опубликованной в 2004 году. Эта спецификация является публичной, стандарт – всеобъемлющим, и он разработан и поддерживается в рамках открытого процесса стандартизации. Любой может реализовать его без каких-либо ограничений, включая оплату или лицензирование прав интеллектуальной собственности (предоставляемых всем бесплатно и без каких-либо условий). Это минимальные условия лицензирования, требуемые организациями по стандартизации, такими как W3C. Разумеется, все остальные организации принимают открытые стандарты. Однако сама спецификация может стоить значительных средств (например, 100 400 евро за экземпляр, как в ISO, из-за авторских прав и публикации документа).

Сравнение определений

Издатель Время публикации Доступность (Распространение спецификации) Права использования (Лицензирование основных патентов) Процесс (Процесс дальнейшей разработки) Полнота Бесплатно Условия FRAND Без роялти, безвозвратно Условия FRAND Открытое участие Открытый просмотр Требует реализации от нескольких поставщиков или открытой справки для зрелости Совместный IEEE, ISOC, W3C, IETF, IAB 2012 08 12 ITU T 2005 03 ✔ ✔ Pan European eGovernment 2004 0 или номинальная ✔ ✔ Правительство Дании 2004 ✔ Французское законодательство 2004 Правительство Индии 2014 0 или номинальная ✔ Итальянское законодательство 2005 03 07 Новая Зеландия e GIF 2007 06 22 ✔ Португальское законодательство 2011 06 21 ✔ ✔ ✔ Правительство Южной Африки 2007 ✔ ✔ ✔ ✔ Испанское законодательство 2007 06 22 0 или низкая Правительство Великобритании 2012 0 или низкая ✔ ✔ ✔ Венесуэльское законодательство 2004 12 23 Брюс Перенс до 2002 Предпочтительно ✔ Microsoft ок. 2006 ✔ ✔ Open Source Initiative 2006 09 ✔ ✔ Кен Крехмер 2005 01 ✔ ✔ ✔ W3C 2005 09 ✔ ✔ ✔ DIGISTAN ок. 2008 ✔ ✔ ✔ FSFE 2001 ✔ ✔ ✔ FFII до 2004 ✔

Примеры открытых стандартов

Обратите внимание, что поскольку различные определения "открытого стандарта" различаются по своим требованиям, перечисленные ниже стандарты могут не соответствовать критериям открытости согласно всем определениям.