Кіріспе
Күнтізбе туралы ақпаратты сақтау үшін компьютерлік файл форматы
Apple-дің күнтізбе қосымшасы, бұрын iCal деп аталатын
Apple's calendar application, previously named iCal
The Internet Calendaring and Scheduling Core Object Specification (iCalendar) is a media type which allows users to store and exchange calendaring and scheduling information such as events, to dos, journal entries, and free/busy information, and together with its associated standards has been a cornerstone of the standardization and interoperability of digital calendars across different vendors. Files formatted according to the specification usually have an extension of With supporting software, such as an email reader or calendar application, recipients of an iCalendar data file can respond to the sender easily or counter propose another meeting date/time. The file format is specified in a proposed Internet standard (RFC 5545) for calendar data exchange. The standard and file type are sometimes referred to as "iCal", which was the name of the Apple Inc. calendar program until 2012 (see iCal), which provides one of the implementations of the standard. iCalendar is used and supported by many products, including:
general consumer: Apple Calendar (formerly iCal), eM Client, Google Calendar, Yahoo! Calendar
corporate: HCL Domino (formerly IBM Notes and Lotus Notes)
free software: GNOME Evolution, GNU Emacs, Mozilla Thunderbird, and SeaMonkey
It is also worth noting that it is partially supported by Microsoft Outlook and Novell GroupWise. iCalendar is designed to be independent of the transport protocol. For example, certain events can be sent by traditional email or whole calendar files can be shared and edited by using a WebDav server, or SyncML. Simple web servers (using just the HTTP protocol) are often used to distribute iCalendar data about an event and to publish busy times of an individual. Publishers can embed iCalendar data in web pages using hCalendar, a 1:1 microformat representation of iCalendar in semantic (X)HTML.
Интернеттік күнтізбе және жоспарлау негізгі объектілік спецификациясы (iCalendar) – бұл пайдаланушыларға оқиғалар, міндеттер, журнал жазбалары және бос/бос уақыт туралы ақпарат сияқты күнтізбелік және жоспарлау ақпаратын сақтауға және алмасуға мүмкіндік беретін медиа түрі. Спецификацияға сәйкес форматталған файлдар әдетте кеңейтімге ие. Электрондық пошта бағдарламасы немесе күнтізбе қосымшасы сияқты қолдаушы бағдарламалық жасақтамасы бар пайдаланушылар iCalendar дерек файлының алғандарын жіберушіге оңай жауап беруге немесе басқа уақыт/күн ұсынуға мүмкіндік алады. Файл форматы күнтізбе деректерін алмасу бойынша ұсынылған Интернет стандартында (RFC 5545) көрсетілген. Стандартты және файл түрін кейде "iCal" деп атайды, бұл 2012 жылға дейін Apple Inc. күнтізбе бағдарламасының аты болды (iCal-ға қараңыз), ол стандартты іске асырудың бірін қамтамасыз етеді. iCalendar көптеген өнімдерде қолданылады және қолдау көрсетіледі, оның ішінде:
Apple's calendar application, previously named iCal
The Internet Calendaring and Scheduling Core Object Specification (iCalendar) is a media type which allows users to store and exchange calendaring and scheduling information such as events, to dos, journal entries, and free/busy information, and together with its associated standards has been a cornerstone of the standardization and interoperability of digital calendars across different vendors. Files formatted according to the specification usually have an extension of With supporting software, such as an email reader or calendar application, recipients of an iCalendar data file can respond to the sender easily or counter propose another meeting date/time. The file format is specified in a proposed Internet standard (RFC 5545) for calendar data exchange. The standard and file type are sometimes referred to as "iCal", which was the name of the Apple Inc. calendar program until 2012 (see iCal), which provides one of the implementations of the standard. iCalendar is used and supported by many products, including:
general consumer: Apple Calendar (formerly iCal), eM Client, Google Calendar, Yahoo! Calendar
corporate: HCL Domino (formerly IBM Notes and Lotus Notes)
free software: GNOME Evolution, GNU Emacs, Mozilla Thunderbird, and SeaMonkey
It is also worth noting that it is partially supported by Microsoft Outlook and Novell GroupWise. iCalendar is designed to be independent of the transport protocol. For example, certain events can be sent by traditional email or whole calendar files can be shared and edited by using a WebDav server, or SyncML. Simple web servers (using just the HTTP protocol) are often used to distribute iCalendar data about an event and to publish busy times of an individual. Publishers can embed iCalendar data in web pages using hCalendar, a 1:1 microformat representation of iCalendar in semantic (X)HTML.
жалпы тұтынушылар үшін: Apple Calendar (бұрынғы iCal), eM Client, Google Calendar, Yahoo! Calendar
корпоративтік: HCL Domino (бұрынғы IBM Notes және Lotus Notes)
ақысыз бағдарламалық қамтамасыз ету: GNOME Evolution, GNU Emacs, Mozilla Thunderbird және SeaMonkey
Apple's calendar application, previously named iCal
The Internet Calendaring and Scheduling Core Object Specification (iCalendar) is a media type which allows users to store and exchange calendaring and scheduling information such as events, to dos, journal entries, and free/busy information, and together with its associated standards has been a cornerstone of the standardization and interoperability of digital calendars across different vendors. Files formatted according to the specification usually have an extension of With supporting software, such as an email reader or calendar application, recipients of an iCalendar data file can respond to the sender easily or counter propose another meeting date/time. The file format is specified in a proposed Internet standard (RFC 5545) for calendar data exchange. The standard and file type are sometimes referred to as "iCal", which was the name of the Apple Inc. calendar program until 2012 (see iCal), which provides one of the implementations of the standard. iCalendar is used and supported by many products, including:
general consumer: Apple Calendar (formerly iCal), eM Client, Google Calendar, Yahoo! Calendar
corporate: HCL Domino (formerly IBM Notes and Lotus Notes)
free software: GNOME Evolution, GNU Emacs, Mozilla Thunderbird, and SeaMonkey
It is also worth noting that it is partially supported by Microsoft Outlook and Novell GroupWise. iCalendar is designed to be independent of the transport protocol. For example, certain events can be sent by traditional email or whole calendar files can be shared and edited by using a WebDav server, or SyncML. Simple web servers (using just the HTTP protocol) are often used to distribute iCalendar data about an event and to publish busy times of an individual. Publishers can embed iCalendar data in web pages using hCalendar, a 1:1 microformat representation of iCalendar in semantic (X)HTML.
Microsoft Outlook және Novell GroupWise ішінара қолдайтынын атап өткен жөн. iCalendar тасымалдау протоколынан тәуелсіз болу үшін жасалған. Мысалы, кейбір оқиғаларды дәстүрлі электрондық пошта арқылы жіберуге болады немесе WebDav серверін немесе SyncML пайдалану арқылы күнтізбе файлдарын бөлісуге және өңдеуге болады. Жақсырақ веб-серверлер (тек HTTP протоколын пайдалану) iCalendar деректерін оқиға туралы және жеке тұлғаның бос уақытын жариялау үшін жиі қолданылады. Жариялаушылар iCalendar деректерін hCalendar арқылы веб-беттерге ендіре алады, бұл iCalendar-дің семантикалық (X)HTML-дегі 1:1 микроформатты бейнелеуі.
Apple's calendar application, previously named iCal
The Internet Calendaring and Scheduling Core Object Specification (iCalendar) is a media type which allows users to store and exchange calendaring and scheduling information such as events, to dos, journal entries, and free/busy information, and together with its associated standards has been a cornerstone of the standardization and interoperability of digital calendars across different vendors. Files formatted according to the specification usually have an extension of With supporting software, such as an email reader or calendar application, recipients of an iCalendar data file can respond to the sender easily or counter propose another meeting date/time. The file format is specified in a proposed Internet standard (RFC 5545) for calendar data exchange. The standard and file type are sometimes referred to as "iCal", which was the name of the Apple Inc. calendar program until 2012 (see iCal), which provides one of the implementations of the standard. iCalendar is used and supported by many products, including:
general consumer: Apple Calendar (formerly iCal), eM Client, Google Calendar, Yahoo! Calendar
corporate: HCL Domino (formerly IBM Notes and Lotus Notes)
free software: GNOME Evolution, GNU Emacs, Mozilla Thunderbird, and SeaMonkey
It is also worth noting that it is partially supported by Microsoft Outlook and Novell GroupWise. iCalendar is designed to be independent of the transport protocol. For example, certain events can be sent by traditional email or whole calendar files can be shared and edited by using a WebDav server, or SyncML. Simple web servers (using just the HTTP protocol) are often used to distribute iCalendar data about an event and to publish busy times of an individual. Publishers can embed iCalendar data in web pages using hCalendar, a 1:1 microformat representation of iCalendar in semantic (X)HTML.
Тарих
iCalendar алғаш рет 1998 жылы Open Text Corporation компаниясының Аник Гангули төрағалық еткен Интернет-инженерлік жұмыс тобының күнтізбе және жоспарлау жұмыс тобымен құрылды. Оның авторлары – Lotus Development Corporation компаниясының Фрэнк Доусон және Microsoft Corporation компаниясының Дерик Стенерсон. iCalendar деректер файлдары – .ics немесе .vcs (тек қолжетімділік туралы ақпаратты қамтитын файлдар үшін) кеңейтімі бар қарапайым мәтіндік файлдар. RFC 5545 2009 жылдың қыркүйегінде RFC 2445-ті алмастырып, қазіргі стандартты анықтайды. iCalendar Интернет пошта консорциумының (IMC) бұрынғы vCalendar стандартына негізделген. Интернет пошта консорциумы iCalendar шығарылғаннан кейін, "барлық vCalendar әзірлеушілері осы жаңа ашық стандарттарды пайдаланып, өз бағдарламаларын vCalendar 1.0 және iCalendar форматымен үйлесімді етеді деп үміттенеді" деп мәлімдеді. "Calendar Access Protocol" (RFC 4324) меморандумы – нақты уақыт күнтізбесін құруға арналған әмбебап жүйеге жасалған алғашқы әрекет, бірақ ол ақырында тасталды. Оның орнына, iCalendar мұндай мақсаттар үшін GroupDAV және CalDAV сияқты арнайы кеңейтулермен қабылдауға ие болды, олар бейресми стандарттар ретінде пайда болып, клиенттік және серверлік бағдарламалық жасақтамаларда қолданыс тапты. IETF "Күнтізбе және жоспарлау жұмыс тобының" (ietf calsify WG) iCalendar стандарттарын жеңілдетуге жасаған алғашқы әрекеті 2011 жылдың қаңтарында қабылданбады. Бұл жұмысты кейін "Күнтізбе кеңейту жұмыс тобы" (ietf calext WG) жалғастырды.
Құралымдардың, қасиеттердің және параметрлердің тізімі
+ Атауы Түрі RFC бөлімі (RFC 5545 бөлімдері) VCALENDAR Компонент 3.4. iCalendar Объектісі 1.1 VEVENT Компонент 3.6.1. iCalendar Объектісі 1.1 VEVENT Компонент 3.6.1. iCalendar Объектісі 1.1 VEVENT Компонент 3.6.1. iCalendar Оқиға Компоненті 1.1.20 VTODO Компоненті 3.6.2. Жоспар Компоненті VJOURNAL Компонент 3.6.3. Журнал Компоненті VFREEBUSY Компонент 3.6.4. Бос/Жұмыс Көп Компоненті VTIMEZONE Компонент 3.6.5. Уақыт Белдеуі Компоненті STANDARD Компонент 3.6.5. Уақыт Белдеуі Компоненті 1.1.19.2 Күндізгі Жарық Компоненті 3.6.5. Уақыт Белдеуі Компоненті 1.1.19.3 VALARM Компонент 3.6.6. Ескерту Компоненті VAVAILABILITY Компонент RFC 7953 3.1. бөлім. Жұмысқа Жарамдылық Компоненті AVAILABLE Компонент RFC 7953 3.1. бөлім. VAVAILABILITY Компоненті PARTICIPANT Компонент RFC 9073 7.1. бөлім. Қатысушы VLOCATION Компонент RFC 9073 7.2. бөлім. Орналасқан Жері VRESOURCE Компонент RFC 9073 7.3. бөлім. Ресурс CALSCALE Қасиет 3.7.1. Күнтізбелік Масштаб METHOD Қасиет 3.7.2. Әдіс 1.1.1 PRODID Қасиет 3.7.3. Өнімнің Идентификаторы 1.1.2 VERSION Қасиет 3.7.4. Нұсқасы 1.1.3 X CALEND Қасиет 1.1.4 X CALSTART Қасиет 1.1.5 X CLIPEND Қасиет 1.1.6 X CLIPSTART Қасиет 1.1.7 X MICROSOFT CALSCALE Қасиет 1.1.8 X MS OLK FORCEINSPECTOROPEN Қасиет 1.1.9 X MS WKHRDAYS Қасиет 1.1.10 X MS WKHREND Қасиет 1.1.11 X MS WKHRSTART Қасиет 1.1.12 X OWNER Қасиет 1.1.13 X PRIMARY CALENDAR Қасиет 1.1.14 X PUBLISHED TTL Қасиет 1.1.15 X WR CALDESC Қасиет 1.1.16 X WR CALNAME Қасиет 1.1.17 X WR RELCALID Қасиет 1.1.18 ATTACH Қасиет 3.8.1.1. Қосымша 1.1.20.1 CATEGORIES Қасиет 3.8.1.2. Санаттар, RFC 7986 5.6-бөлімі. CATEGORIES Қасиет 1.1.20.3 CLASS Қасиет 3.8.1.3. Классификация 1.1.20.4 COMMENT Қасиет 3.8.1.4. Ескерту 1.1.20.5 DESCRIPTION Қасиет 3.8.1.5. Сипаттама, RFC 7986 5.2-бөлімі. DESCRIPTION Қасиет 1.1.20.11, 1.1.20.6 2.3 GEO Қасиет 3.8.1.6. Географиялық Орналасу LOCATION Қасиет 3.8.1.7. Орналасқан Жер 1.1.20.15 PERCENT COMPLETE Қасиет 3.8.1.8. Толықтыру Пайызы PRIORITY Қасиет 3.8.1.9. Басымдық 1.1.20.17 RESOURCES Қасиет 3.8.1.10. Ресурстар 1.1.20.21 STATUS Қасиет 3.8.1.11. Күйі 1.1.20.23 SUMMARY Қасиет 3.8.1.12. Қорытынды 1.1.20.24 COMPLETED Қасиет 3.8.2.1. Аяқталған Күн Уақыты DTEND Қасиет 3.8.2.2. Аяқталу Күн Уақыты 1.1.20.8 DUE Қасиет 3.8.2.3. Мерзім Күн Уақыты DTSTART Қасиет 3.8.2.4. Басталу Күн Уақыты 1.1.19.2.1, 1.1.19.3.1, 1.1.20.10 DURATION Қасиет 3.8.2.5. Ұзақтығы 1.1.20.12 FREEBUSY Қасиет 3.8.2.6. Бос/Жұмыс Көп Уақыт TRANSP Қасиет 3.8.2.7. Уақыт Ашықтығы 1.1.20.25 TZID Қасиет 3.8.3.1. Уақыт Белдеуінің Идентификаторы 1.1.19.1 TZNAME Қасиет 3.8.3.2. Уақыт Белдеуінің Атауы 1.1.19.2.3, 1.1.19.3.3 TZOFFSETFROM Қасиет 3.8.3.3. Уақыт Белдеуінің Бастапқы Ауытқуы 1.1.19.2.4, 1.1.19.3.4 TZOFFSETTO Қасиет 3.8.3.4. Уақыт Белдеуінің Соңғы Ауытқуы 1.1.19.2.5, 1.1.19.3.5 TZURL Қасиет 3.8.3.5. Уақыт Белдеуінің URL ATTENDEE Қасиет 3.8.4.1. Қатысушы 1.1.20.2 CONTACT Қасиет 3.8.4.2. Байланыс 1.1.20.6 ORGANIZER Қасиет 3.8.4.3. Ұйымдастырушы 1.1.20.16 RECURRENCE ID Қасиет 3.8.4.4. Қайталану ID 1.1.20.20 RELATED TO Қасиет 3.8.4.5. Қатысты, RFC 9253 9.1-бөлімі. RELATED TO URL Қасиет 3.8.4.6. Бірыңғай Ресурс Локаторы, RFC 7986 5.5-бөлімі. URL Қасиет UID Қасиет 3.8.4.7. Бірегей Идентификатор, RFC 7986 5.3-бөлімі. UID Қасиет 1.1.20.26 EXDATE Қасиет 3.8.5.1. Ерекшелік Күн Уақыттары 1.1.20.13 RDATE Қасиет 3.8.5.2. Қайталану Күн Уақыттары 1.1.20.18 RRULE Қасиет 3.8.5.3. Қайталану Ережесі 1.1.19.2.2, 1.1.19.3.2, 1.1.20.19 ACTION Қасиет 3.8.6.1. Әрекет 1.1.20.6 2.2 REPEAT Қасиет 3.8.6.2. Қайталау Саны TRIGGER Қасиет 3.8.6.3. Триггер 1.1.20.6 2.1 CREATED Қасиет 3.8.7.1. Жаратылған Күн Уақыты 1.1.20.7 DTSTAMP Қасиет 3.8.7.2. Күн Уақыт Белгісі 1.1.20.9 LAST MODIFIED Қасиет 3.8.7.3. Соңғы Рет Өзгертілген, RFC 7986 5.4-бөлімі. LAST MODIFIED Қасиет 1.1.20.14 SEQUENCE Қасиет 3.8.7.4. Реттік Нөмірі 1.1.20.22 REQUEST STATUS Қасиет 3.8.8.3. Сұраныс Күйі X ALT DESC Қасиет 1.1.20.27 X MICROSOFT CDO ALLDAYEVENT Қасиет 1.1.20.28 X MICROSOFT CDO APPT SEQUENCE Қасиет 1.1.20.29 X MICROSOFT CDO ATTENDEE CRITICAL CHANGE Қасиет 1.1.20.30 X MICROSOFT CDO BUSYSTATUS Қасиет 1.1.20.31 X MICROSOFT CDO IMPORTANCE Қасиет 1.1.20.32 X MICROSOFT CDO INSTTYPE Қасиет 1.1.20.33 X MICROSOFT CDO INTENDEDSTATUS Қасиет 1.1.20.34 X MICROSOFT CDO OWNERAPPTID Қасиет 1.1.20.35 X MICROSOFT CDO OWNER CRITICAL CHANGE Қасиет 1.1.20.36 X MICROSOFT CDO REPLYTIME Қасиет 1.1.20.37 X MICROSOFT DISALLOW COUNTER Қасиет 1.1.20.38 X MICROSOFT EXDATE Қасиет 1.1.20.39 X MICROSOFT ISDRAFT Қасиет 1.1.20.40 X MICROSOFT MSNCALENDAR ALLDAYEVENT Қасиет 1.1.20.41 X MICROSOFT MSNCALENDAR BUSYSTATUS Қасиет 1.1.20.42 X MICROSOFT MSNCALENDAR IMPORTANCE Қасиет 1.1.20.43 X MICROSOFT MSNCALENDAR INTENDEDSTATUS Қасиет 1.1.20.44 X MICROSOFT RRULE Қасиет 1.1.20.45 X MS OLK ALLOWEXTERNCHECK Қасиет 1.1.20.46 X MS OLK APPTLASTSEQUENCE Қасиет 1.1.20.47 X MS OLK APPTSEQTIME Қасиет 1.1.20.48 X MS OLK AUTOFILLLOCATION Қасиет 1.1.20.49 X MS OLK AUTOSTARTCHECK Қасиет 1.1.20.50 X MS OLK COLLABORATEDOC Қасиет 1.1.20.51 X MS OLK CONFCHECK Қасиет 1.1.20.52 X MS OLK CONFTYPE Қасиет 1.1.20.53 X MS OLK DIRECTORY Қасиет 1.1.20.54 X MS OLK MWSURL Қасиет 1.1.20.55 X MS OLK NETSHOWURL Қасиет 1.1.20.56 X MS OLK ONLINEPASSWORD Қасиет 1.1.20.57 X MS OLK ORGALIAS Қасиет 1.1.20.58 X MS OLK SENDER Қасиет 1.1.20.61 BUSYTYPE Қасиет RFC 7953 3.2. бөлім. Жұмыс Көп Уақыт Түрі NAME Қасиет RFC 7986 5.1-бөлімі. NAME Қасиет REFRESH INTERVAL Қасиет RFC 7986 5.7-бөлімі. REFRESH INTERVAL Қасиет SOURCE Қасиет RFC 7986 5.8-бөлімі. SOURCE Қасиет COLOR Қасиет RFC 7986 5.9-бөлімі. ТҮС Қасиет IMAGE Қасиет RFC 7986 5.10-бөлімі. IMAGE Қасиет CONFERENCE Қасиет RFC 7986 5.11-бөлімі. Конференция Қасиет CALENDAR ADDRESS Қасиет RFC 9073 6.4-бөлімі. Күнтізбе Мекеңжайы LOCATION TYPE Қасиет RFC 9073 6.1-бөлімі. Орналасқан Жер Түрі PARTICIPANT TYPE Қасиет RFC 9073 6.2-бөлімі. Қатысушы Түрі RESOURCE TYPE Қасиет RFC 9073 6.3-бөлімі. Ресурс Түрі STRUCTURED DATA Қасиет RFC 9073 6.6-бөлімі. Құрылымдық Деректер STYLED DESCRIPTION Қасиет RFC 9073 6.5-бөлімі. Стилирленген Сипаттама ACKNOWLEDGED Қасиет RFC 9074 6.1-бөлімі. Растау PROXIMITY Қасиет RFC 9074 8.1-бөлімі. Жақындық Қасиеттері CONCEPT Қасиет RFC 9253 8.1-бөлімі. Concept LINK Қасиет RFC 9253 8.2-бөлімі. Link REFID Қасиет RFC 9253 8.3-бөлімі. ALTREP Параметрі 3.2.1. Баламалы Мәтін Төңкерісі 1.1.20.15.1 CN Параметрі 3.2.2. Жалпы Атауы 1.1.13.1, 1.1.20.2.1, 1.1.20.16.1, 1.1.20.61.1 CUTYPE Параметрі 3.2.3. Күнтізбе Пайдаланушысының Түрі 1.1.20.2.2 DELEGATED FROM Параметрі 3.2.4. Өкілеттік Бергендер DELEGATED TO Параметрі 3.2.5. Өкілеттік Алғандар DIR Параметрі 3.2.6. Каталогқа Кіру Сілтемесі ENCODING Параметрі 3.2.7. Инлайндық Кодтау 1.1.20.1.1 FMTTYPE Параметрі 3.2.8. Форматтың Түрі 1.1.20.1.2, 1.1.20.27.1 FBTYPE Параметрі 3.2.9. Бос/Жұмыс Көп Уақыт Түрі LANGUAGE Параметрі 3.2.10. Тіл 1.1.20.11.1, 1.1.20.15.2, 1.1.20.24.1 MEMBER Параметрі 3.2.11. Топқа Немесе Тізімге Мүшелік PARTSTAT Параметрі 3.2.12. Қатысу Жағдайы 1.1.20.2.3 RANGE Параметрі 3.2.13. Қайталану Идентификаторының Ауқымы RELATED Параметрі 3.2.14. Ескертуді Іске Қосу Қатынасы RELTYPE Параметрі 3.2.15. Қатынас Түрі, RFC 9074 7.1-бөлімі. Қатынас Түрі Қасиет Параметрі, RFC 9253 4 және 5-бөлімдері ROLE Параметрі 3.2.16. Қатысу Рөлі 1.1.20.2.4 RSVP Параметрі 3.2.17. Жауап Күтуі 1.1.20.2.5 SENT BY Параметрі 3.2.18. Жіберген TZID Параметрі 3.2.19. Уақыт Белдеуінің Идентификаторы 1.1.4.1, 1.1.5.1, 1.1.6.1, 1.1.7.1, 1.1.11.1, 1.1.12.1, 1.1.20.8.1, 1.1.20.9.1, 1.1.20.10.1, 1.1.20.13.1, 1.1.20.18.1, 1.1.20.20.1, 1.1.20.48.1 VALUE Параметрі 3.2.20. Мәндік Дерек Түрлері 1.1.20.1.3, 1.1.20.8.2, 1.1.20.10.2, 1.1.20.13.2, 1.1.20.18.2, 1.1.20.20.2, 1.1.20.39.1, 1.1.20.45.1 X FILENAME Параметрі 1.1.20.1.4 X MS OLK RESPTIME Параметрі 1.1.20.2.6 X MICROSOFT ISLEAPMONTH Параметрі 1.1.20.45.2 DISPLAY Параметрі RFC 7986 6.1-бөлімі. DISPLAY Қасиет Параметрі EMAIL Параметрі RFC 7986 6.2-бөлімі. EMAIL Қасиет Параметрі FEATURE Параметрі RFC 7986 6.3-бөлімі. FEATURE Қасиет Параметрі LABEL Параметрі RFC 7986 6.4-бөлімі. LABEL Қасиеті
Басқа бейнелеулер
xCal – iCalendar деректерінің XML форматындағы бейнелеуі, jCal – iCalendar деректерінің JSON форматындағы бейнелеуі, hCalendar – микроформаттарды қолдана отырып, iCalendar деректерінің бір бөлігінің (x)HTML форматындағы бейнелеуі. hEvent – hCalendar форматындағы қолжетімділік мәселелерін шешетін микроформаттарды қолдана отырып, iCalendar деректерінің бір бөлігінің HTML форматындағы бейнелеуі.
jCal is a JSON representation of iCalendar data, as defined in
hCalendar is an (x)HTML representation of a subset of iCalendar data using microformats. hEvent is an HTML representation of a subset of iCalendar data using microformats addressing some accessibility concerns with the hCalendar format.