Введение

Уведомление о статусе электронного сообщения

В электронной почте обратный квитанция – это уведомление, которое почтовый клиент получателя отправляет отправителю в подтверждение получения электронного сообщения. Какое именно уведомление, если таковое отправляется, получает отправитель, зависит от почтового программного обеспечения получателя. Для электронной почты доступны два типа уведомлений: уведомления о статусе доставки (DSN) и уведомления о прочтении (MDN). Отправка подтверждения о получении зависит от настроек почтового программного обеспечения получателя.

Уведомления о состоянии поставки

DSN — это как услуга, которая может предоставляться агентами передачи сообщений (MTA), использующими протокол простого обмена почтой (SMTP), так и формат сообщения, используемый для уведомления отправителя о результатах доставки сообщения. В частности, служба DSN SMTP используется для запроса уведомлений об успешной доставке или о неудаче доставки (в формате DSN). Уведомление DSN при неудачной доставке выдается по умолчанию, в то время как выдача уведомления DSN при успешной доставке требует специального запроса от отправителя. Однако по различным причинам возможно, что сообщение будет доставлено, и отправителю будет возвращено уведомление DSN, указывающее на успешную доставку, но впоследствии сообщение может не быть прочитано получателем или даже не станет ему доступным. Расширение DSN SMTP, формат сообщения и связанные с ним коды состояния доставки определены в RFC 3461–3464 и 6522.

Уведомления о расположении сообщений

MDN предоставляют уведомление о "судьбе" сообщения, указывающее, например, было ли оно прочитано получателем, отклонено до прочтения и т.д. Однако, из соображений конфиденциальности, а также для обеспечения обратной совместимости, запросы на MDN носят исключительно рекомендательный характер, то есть получатели вправе игнорировать такие запросы. Формат и использование MDN определены в RFC 3798. Описание того, как несколько почтовых клиентских приложений (MUAs) должны обрабатывать генерацию MDN в среде протокола доступа к сообщениям в Интернете (IMAP4), приведено в RFC 3503. Нестандартный, но широко используемый способ запроса уведомлений о прочтении – это поле "Return Receipt To:" (RRT) в заголовке электронного письма с указанием адреса электронной почты для отправки уведомления. При первом открытии пользователем электронного письма, содержащего это поле в заголовке, клиент обычно предлагает пользователю отправить уведомление о прочтении.