Кіріспе

Электрондық пошта хабарламасының статусы туралы хабарлама

Электрондық поштада, қайтару түйіндемесі – алушының электрондық пошта бағдарламасының, электрондық хабарламаны алғандығы туралы жіберушіге берген хабарламасы. Алушы жіберушіге қандай хабарлама жіберсе, ол алушының электрондық пошта бағдарламасына байланысты. Электрондық пошта үшін екі хабарлама беру қызметі бар: жеткізілу статусы туралы хабарламалар (DSN) және хабарлама тағдыры туралы хабарламалар (MDN). Мұндай түйіндеме жіберіледі ме, жоқ әлде жіберілмейді ме, ол алушының электрондық пошта бағдарламалық жасақтамасының конфигурациясына байланысты.

Жеткізу жағдайы туралы хабарламалар

DSN – бұл Simple Mail Transfer Protocol (SMTP) протоколын пайдаланатын хабар алмасу агенттері (MTA) ұсынатын қосымша қызмет, сонымен қатар хабарламаны жіберушіге жеткізілу туралы хабарламаларды қайтару үшін қолданылатын хабарлама форматы. Атап айтқанда, DSN SMTP қызметі сәтті жеткізілуі немесе жеткізілмеуі (DSN форматында) туралы хабарламаларды қайтару үшін қолданылады. Жеткізілмеген жағдайда DSN беру – әдепкі шара, ал сәтті жеткізілген кезде DSN беру үшін жіберушіден арнайы сұрау қажет. Дегенмен, түрлі себептерге байланысты хабарлама жеткізілуі мүмкін, бірақ жіберушіге сәтті жеткізілгенін көрсететін DSN қайтарылып, кейіннен алушы оны көре алмай немесе оған қол жеткізе алмай қалуы мүмкін. DSN SMTP кеңейтімдері, хабарлама форматы және байланысты жеткізу күй кодтары RFC 3461–3464 және 6522 стандарттарында сипатталған.

Хабарламаларды орналастыру туралы хабарламалар

MDN хабарламаның "мәртебесі" туралы хабарлайды, мысалы, оны алушы оқыды ма, оқылмай жойылды ма, сияқты ақпараттарды көрсетеді. Бірақ, жеке құпиялылықты қорғау және кері үйлесімділік мақсатында, MDN сұраулары тек кеңес беру сипатында болады – яғни, алушы мұндай сұрауларды назарға алмауға құқылы. MDN форматы мен қолданылуы RFC 3798 ережесінде сипатталған. Бірнеше пошта клиенттерінің (MUA) Интернеттік хабарламаларға қол жеткізу протоколы (IMAP4) ортасында MDN құруды қалай жүзеге асыру керектігі RFC 3503-те түсіндірілген. Электрондық хаттың тақырып бөліміндегі "Return Receipt To:" (RRT) өрісі арқылы қайтару туралы хабарлама сұрау – бұл стандартты емес, бірақ кеңінен қолданылатын тәсіл, онда қайтару электрондық пошта мекенжайы көрсетіледі. Егер пайдаланушы осы өрісі бар электрондық хатты алғаш рет ашса, клиент әдетте одан қайтару хабарламасын жіберуге рұқсат сұрайды.