Введение

Электронная почта (email или e-mail) — это способ передачи и получения сообщений с использованием электронных устройств. Она была разработана в конце XX века как цифровая версия или аналог обычной почты (отсюда e + mail). Электронная почта является повсеместно распространенным и широко используемым средством связи; в настоящее время адрес электронной почты часто рассматривается как базовая и необходимая часть многих процессов в бизнесе, торговле, государственном управлении, образовании, развлечениях и других сферах повседневной жизни в большинстве стран. Электронная почта функционирует через компьютерные сети, прежде всего Интернет, а также локальные сети. Современные системы электронной почты основаны на модели «храни и пересылай». Серверы электронной почты принимают, пересылают, доставляют и хранят сообщения. Ни пользователям, ни их компьютерам не требуется одновременного подключения к сети; им необходимо подключаться, как правило, к почтовому серверу или веб-интерфейсу для отправки или получения сообщений или их загрузки. Изначально являясь средством связи, поддерживающим только текстовый формат ASCII, интернет-электронная почта была расширена с помощью многоцелевых расширений интернет-почты (MIME) для передачи текста в других кодировках и вложений мультимедийного контента. Международная электронная почта с интернационализированными адресами электронной почты, использующими UTF-8, стандартизована, но не получила широкого распространения. В настоящее время наиболее распространенной и рекомендуемой стилистическими руководствами формой является «email». Именно эта форма требуется в документах IETF Requests for Comments (RFC) и рабочих группах. Такое написание также встречается в большинстве словарей. «E-mail» является предпочтительной формой в отредактированных публикациях на американском и британском английском языках, что подтверждается данными Corpus of Contemporary American English, однако в некоторых стилистических руководствах эта форма постепенно выходит из употребления. Иногда используется «E mail». Первое упоминание датируется июнем 1979 года и содержится в журнале Electronics в связи с инициативой почтовой службы США под названием E COM, разработанной в конце 1970-х годов и запущенной в начале 1980-х годов. «EMail» — традиционная форма, используемая в RFC для указания «адреса автора». Саму службу часто называют просто «почтой», а отдельное электронное письмо — «сообщением». Правила оформления полей в электронных письмах — «Кому», «От кого», «Копия», «Скрытая копия» и т. д. — были установлены в RFC 680 в 1975 году. Интернет-письмо состоит из конверта и содержимого; содержимое включает заголовок и тело.

История

Компьютерный обмен сообщениями между пользователями одной и той же системы стал возможен после появления разделения времени в начале 1960-х годов, с заметной реализацией в проекте CTSS Массачусетского технологического института в 1965 году. Большинство разработчиков ранних мейнфреймов и миникомпьютеров создали аналогичные, но в основном несовместимые почтовые приложения. В 1971 году была отправлена первая сетевая почта ARPANET, представившая привычный синтаксис адреса с символом '@', обозначающим сетевой адрес пользователя. В серии RFC были уточнены соглашения об отправке почтовых сообщений через протокол передачи файлов. Вскоре стали появляться проприетарные системы электронной почты. IBM, CompuServe и Xerox использовали собственные почтовые системы в 1970-х годах; CompuServe продала коммерческий продукт для внутриофисной почты компании IBM в 1978 году, а компании Xerox – с 1981 года. DEC ALL IN 1 и HPMAIL от Hewlett Packard (позже HP DeskManager) были выпущены в 1982 году; работа над первым началась в конце 1970-х годов, а второй стал самой продаваемой в мире системой электронной почты. Протокол простого обмена почтой (SMTP) был реализован в ARPANET в 1983 году. Системы электронной почты для локальных сетей (LAN) появились в середине 1980-х годов. В конце 1980-х и начале 1990-х годов казалось вероятным, что доминировать будет либо проприетарная коммерческая система, либо система электронной почты X.400, являющаяся частью Government Open Systems Interconnection Profile (GOSIP). Однако после снятия последних ограничений на передачу коммерческого трафика через Интернет в 1995 году, сочетание факторов сделало стандартным современный набор интернет-протоколов электронной почты SMTP, POP3 и IMAP (см. «Войны протоколов»).

Формат сообщения

Основной формат сообщений в Интернете, используемый для электронной почты, определяется стандартом, с кодированием не-ASCII данных и вложений мультимедийного контента, описанным в RFC 2045 – RFC 2049, которые в совокупности называются многоцелевыми расширениями интернет-почты или MIME. Эти расширения для международной электронной почты применяются исключительно к электронной почте. RFC 5322 заменил более ранний RFC 2822 в 2008 году, а RFC 2822 в 2001 году заменил RFC 822 – стандарт для интернет-электронной почты на протяжении десятилетий. RFC 822, опубликованный в 1982 году, был основан на более раннем RFC 733 для сети ARPANET. Сообщения электронной почты в Интернете состоят из двух разделов: "заголовок" и "тело". Вместе они образуют "содержимое". Заголовок структурирован в поля, такие как "От", "Кому", "Копия", "Тема", "Дата" и другая информация о сообщении. В процессе передачи сообщений электронной почты между системами SMTP использует поля заголовка сообщения для передачи параметров доставки и информации. Тело содержит само сообщение в виде неструктурированного текста, иногда с блоком подписи в конце. Заголовок отделяется от тела пустой строкой.

Заголовок сообщения

RFC 5322 определяет синтаксис заголовка электронной почты. Каждое электронное сообщение имеет заголовок (в соответствии со спецификацией – "секция заголовка" сообщения), состоящий из нескольких полей ("поля заголовка"). Каждое поле имеет имя ("имя поля" или "имя поля заголовка"), за которым следует разделитель ":", и значение ("тело поля" или "тело поля заголовка"). Каждое имя поля начинается с первого символа новой строки в секции заголовка и начинается с печатного символа, не являющегося пробельным. Оно заканчивается разделителем ":". За разделителем следует значение поля ("тело поля"). Значение может продолжаться на последующих строках, если эти строки начинаются с пробела или табуляции. Имена полей и, без SMTPUTF8, тела полей ограничены 7-битными символами ASCII. Некоторые значения, не входящие в ASCII, могут быть представлены с использованием закодированных слов MIME.

Кодирование содержимого

Интернет-электронная почта изначально разрабатывалась для 7-битного ASCII. Большинство почтовых программ поддерживают 8-битные кодировки, но должны учитывать возможность взаимодействия с 7-битными серверами и почтовыми клиентами. Стандарт MIME представил спецификаторы наборов символов и два способа кодирования содержимого для передачи данных, отличных от ASCII: quoted-printable для преимущественно 7-битного контента с небольшим количеством символов вне этого диапазона и Base64 для произвольных двоичных данных. Расширения 8BITMIME и BINARY были разработаны для передачи почты без использования этих кодировок, однако многие почтовые транспортные агенты могут их не поддерживать. В некоторых странах почтовое программное обеспечение нарушает правила, отправляя необработанный текст в кодировке, отличной от ASCII, и сосуществует несколько схем кодирования. В результате, по умолчанию, сообщение на языке, использующем нелатинский алфавит, отображается в нечитаемом виде (исключение составляет случай, когда отправитель и получатель используют одну и ту же схему кодирования). Поэтому для международных наборов символов все большую популярность приобретает Unicode.

Обычный текст и HTML

Большинство современных графических почтовых клиентов позволяют пользователю выбирать между обычным текстом и HTML для тела сообщения. HTML-сообщения электронной почты часто содержат автоматически сгенерированную версию в виде обычного текста для обеспечения совместимости. Преимущества HTML включают возможность встраивать ссылки и изображения, выделять цитируемые сообщения, автоматически переносить текст на экранах разного размера, использовать различные стили оформления, такие как подчеркивание и курсив, и изменять шрифты. К недостаткам относятся увеличенный размер письма, вопросы конфиденциальности, связанные с веб-маяками, использование HTML-писем для фишинговых атак и распространения вредоносного ПО. Некоторые почтовые клиенты интерпретируют тело сообщения как HTML даже при отсутствии заголовка Content Type: html, что может приводить к проблемам. Некоторые веб-рассылки рекомендуют отправлять все сообщения в виде обычного текста, с ограничением длины строки до 72 или 80 символов, по всем вышеперечисленным причинам, а также из-за большого числа пользователей, использующих текстовые почтовые клиенты, такие как Mutt. Со временем для оформления обычного текста в электронной почте и Usenet сложились различные неформальные соглашения, которые впоследствии привели к созданию формальных языков, таких как setext (около 1992 года) и многих других, наиболее популярным из которых является Markdown. Некоторые почтовые клиенты Microsoft могут поддерживать расширенное форматирование с использованием их проприетарного формата Rich Text Format (RTF), однако его следует избегать, если нет уверенности, что у получателя есть совместимый почтовый клиент.

Серверы и клиентские приложения

Сообщения обмениваются между хостами с использованием протокола простой передачи почты (SMTP) посредством программ, называемых агентами передачи почты (MTA), и доставляются в хранилище почты программами, называемыми агентами доставки почты (MDA, также иногда называемыми локальными агентами доставки, LDA). Принятие сообщения обязывает MTA его доставить, а если доставка невозможна, MTA должен отправить сообщение о неудачной доставке (bounce message) обратно отправителю с указанием причины. Пользователи могут получать свои сообщения с серверов, используя стандартные протоколы, такие как POP или IMAP, или, что более вероятно в крупных корпоративных сетях, с помощью проприетарного протокола, специфичного для Novell Groupwise, Lotus Notes или Microsoft Exchange Servers. Программы, используемые пользователями для получения, чтения и управления электронной почтой, называются почтовыми клиентскими агентами (MUA). При открытии электронного письма оно помечается как "прочитанное", что обычно визуально отличает его от "непрочитанных" сообщений в пользовательском интерфейсе клиента. Почтовые клиенты могут позволять скрывать прочитанные письма из входящих, чтобы пользователь мог сосредоточиться на непрочитанных. Почта может храниться на клиентской стороне, на серверной стороне или в обоих местах. Стандартные форматы почтовых ящиков включают Maildir и mbox. Некоторые известные почтовые клиенты используют собственные форматы и требуют программного обеспечения для конвертации при переносе электронной почты между ними. Хранение на серверной стороне часто осуществляется в проприетарном формате, но поскольку доступ осуществляется через стандартный протокол, такой как IMAP, перенос электронной почты с одного сервера на другой можно выполнить с помощью любого MUA, поддерживающего этот протокол. Многие современные пользователи электронной почты не запускают программы MTA, MDA или MUA самостоятельно, а используют веб-интерфейс электронной почты, такой как Gmail или Yahoo! Mail, который выполняет те же функции. Такие веб-интерфейсы позволяют пользователям получать доступ к своей почте с помощью любого стандартного веб-браузера с любого компьютера, не полагаясь на локальный почтовый клиент.

схема URI mailto

Схема URI, зарегистрированная в IANA, определяет схему `mailto:` для адресов электронной почты SMTP. Несмотря на то, что её использование не строго регламентировано, URL-адреса такого формата предназначены для открытия нового окна сообщения в почтовом клиенте пользователя при активации URL, при этом адрес, указанный в URL, должен быть подставлен в поле «Кому:».

Электронная почта

Многие поставщики электронной почты предоставляют веб-интерфейс для работы с электронной почтой. Это позволяет пользователям получать доступ к своей учетной записи и отправлять и получать письма через любой совместимый веб-браузер. При этом почта обычно не загружается на компьютер пользователя, поэтому для ее чтения требуется постоянное подключение к Интернету.

Серверы почты POP3

Протокол POP3 (Post Office Protocol version 3) — это протокол доступа к почте, используемый клиентским приложением для чтения сообщений с почтового сервера. Полученные сообщения часто удаляются с сервера. POP поддерживает простые требования к загрузке и удалению для доступа к удалённым почтовым ящикам (именуемым maildrop в спецификациях RFC для POP). POP3 позволяет загружать сообщения на локальный компьютер и читать их даже без подключения к сети.

Серверы электронной почты IMAP

Протокол доступа к сообщениям в Интернете (IMAP) предоставляет возможности для управления почтовым ящиком с различных устройств. Компактные портативные устройства, такие как смартфоны, все чаще используются для проверки электронной почты в поездках и для отправки коротких ответов, в то время как устройства большего размера с удобным доступом к клавиатуре применяются для написания развернутых ответов. IMAP отображает заголовки сообщений, отправителя и тему, а для загрузки конкретных сообщений необходимо отправлять запрос. Как правило, электронная почта остается в папках на почтовом сервере.

Серверы электронной почты MAPI

Интерфейс программирования приложений обмена сообщениями (MAPI) используется Microsoft Outlook для связи с Microsoft Exchange Server, а также с широким спектром других почтовых серверов, таких как Axigen Mail Server, Kerio Connect, Scalix, Zimbra, HP OpenMail, IBM Lotus Notes, Zarafa и Bynari, в которых разработчики добавили поддержку MAPI, чтобы обеспечить прямой доступ к своим продуктам через Outlook.

Маркетинг по электронной почте

Маркетинг по электронной почте с использованием принципа "opt-in" часто успешно применяется для рассылки специальных предложений и информации о новых продуктах. В зависимости от культурных особенностей получателя, электронная почта, отправленная без согласия – в отличие от "opt-in" – скорее всего, будет воспринята как нежелательный "спам".

Персональный компьютер

Многие пользователи просматривают личную электронную почту от друзей и членов семьи, используя персональный компьютер у себя дома или в квартире.

Мобильные

Электронная почта стала широко использоваться на смартфонах и на всех типах компьютеров. Мобильные приложения для электронной почты повышают доступность этого средства связи для пользователей, находящихся вне дома. Если в первые годы существования электронной почты доступ к ней был возможен только с настольных компьютеров, то в 2010-х годах пользователи получили возможность проверять свою почту, находясь вдали от дома – будь то в другом конце города или в другой стране. Уведомления о новых сообщениях могут мгновенно отправляться на смартфон или другие устройства. Это сделало электронную почту более удобным средством для частого общения и позволило пользователям проверять почту и писать сообщения в течение дня. По состоянию на 2011 год в мире насчитывалось около 1,4 миллиарда пользователей электронной почты, ежедневно отправлялось 50 миллиардов не-спам сообщений. Люди часто проверяют электронную почту на смартфонах как для личных, так и для рабочих целей. Исследования показали, что взрослые американцы проверяют электронную почту чаще, чем просматривают веб-страницы или заходят в Facebook, что делает её самым популярным занятием на смартфонах. 78% респондентов в исследовании сообщили, что проверяют электронную почту на телефоне. Также было установлено, что 30% потребителей используют исключительно смартфон для проверки электронной почты, а 91% проверяют её хотя бы раз в день на смартфоне. Однако доля потребителей, использующих электронную почту на смартфоне, значительно варьируется в разных странах. Например, если в США её используют 75% потребителей, то в Индии – всего 17%.

Снижение употребления среди молодежи

В 2010 году число американцев, посещающих веб-сайты электронной почты, снизилось на 6 процентов после пикового значения в ноябре 2009 года. Среди людей в возрасте от 12 до 17 лет это снижение составило 18 процентов. Молодые люди предпочитали мгновенные сообщения, текстовые сообщения и социальные сети. Технологический обозреватель Мэтт Рихтел в статье для The New York Times отметил, что электронная почта устарела, как видеомагнитофоны, виниловые пластинки и пленочные фотоаппараты – это то, что используют люди старшего поколения. Опрос пользователей Android, проведенный в 2015 году, показал, что люди в возрасте от 13 до 24 лет использовали приложения для обмена сообщениями в 3,5 раза чаще, чем люди старше 45 лет, и значительно реже прибегали к электронной почте.

Ограничение размеров прикрепления

В электронных сообщениях может быть один или несколько вложений – это дополнительные файлы, добавляемые к электронному письму. Типичные вложения включают документы Microsoft Word, PDF-документы и отсканированные изображения бумажных документов. В принципе, технических ограничений на размер или количество вложений нет. Однако на практике почтовые клиенты, серверы и интернет-провайдеры устанавливают различные ограничения на размер файлов или всего электронного письма – как правило, до 25 МБ или меньше. Кроме того, по техническим причинам размер файлов, отображаемый этими системами передачи данных, может отличаться от того, что видит пользователь, что может сбивать с толку отправителей при оценке возможности отправки файла по электронной почте. Если необходимо передать большие файлы, можно воспользоваться различными сервисами файлового хостинга, которые широко используются.

Перегрузка информацией

Повсеместное распространение электронной почты среди специалистов, занятых интеллектуальным трудом, и офисных работников вызвало опасения, что получатели сталкиваются с "информационной перегрузкой" из-за постоянно растущего объема корреспонденции. С увеличением числа мобильных устройств сотрудники зачастую получают рабочие письма даже вне рабочего времени. Это может приводить к повышенному стрессу и снижению удовлетворенности работой. Некоторые эксперты даже полагают, что это может оказать существенное негативное влияние на экономику, поскольку время, затрачиваемое на чтение большого количества писем, может снижать производительность труда.

Спам

"Спам" – это нежелательная массовая рассылка электронной почты. Низкая стоимость отправки таких сообщений привела к тому, что к 2003 году на спам приходилось до 30% всего объема электронной почты, что угрожало полезности электронной почты как практичного инструмента. Закон США CAN-SPAM Act 2003 года и аналогичные законы в других странах оказали определенное влияние, и ряд эффективных методов борьбы со спамом сейчас в значительной степени снижают его воздействие, фильтруя или отклоняя его для большинства пользователей. Однако объем отправляемого спама остается очень высоким и все чаще состоит не из рекламы товаров, а из вредоносного контента или ссылок. Например, в сентябре 2017 года доля спама в общем объеме легитимной электронной почты возросла до 59,56%. По оценкам, в 2021 году спам составлял 85% от общего объема электронной почты.

Вредоносные программы

Существует множество типов вредоносных электронных писем. Они включают в себя различные виды мошенничества, такие как схемы "социальной инженерии", например, мошенничество с предоплатой ("Нигерийские письма"), фишинг, массовую рассылку спама и почтовые черви.

Подделка электронной почты

Подделка адреса электронной почты происходит, когда заголовок сообщения составлен таким образом, чтобы создать впечатление, будто сообщение отправлено от известного или доверенного источника. Спам и фишинговые атаки часто используют подделку адреса, чтобы ввести получателя в заблуждение относительно истинного отправителя сообщения. Подделка адреса электронной почты может быть совершена ради шутки или в рамках преступной схемы с целью обмана отдельного лица или организации. Примером потенциально мошеннической подделки может служить создание письма, имитирующего счет от крупной компании, и отправка его одному или нескольким получателям. В некоторых случаях такие мошеннические письма могут содержать логотип организации, от имени которой они якобы отправлены, и даже адрес электронной почты может выглядеть подлинным.

Бомбардировка по электронной почте

Email-бомба – это преднамеренная отправка огромного количества сообщений на целевой адрес. Перегрузка целевого почтового ящика может сделать его неработоспособным и даже привести к сбою почтового сервера.

Юридические контракты

Обмен электронными письмами может привести к заключению юридически обязывающего договора, поэтому пользователям следует внимательно относиться к содержанию отправляемых ими сообщений электронной почты. Блок подписи в электронном письме может быть расценен как выполнение требования о наличии подписи в договоре.

Пламя

Флейминг происходит, когда человек отправляет сообщение (или несколько сообщений) с яростным или конфронтационным содержанием. Этот термин возник из-за использования слова "подстрекательский" для описания особенно острых переписок по электронной почте. Простота и анонимность общения по электронной почте приводят к тому, что социальные нормы, способствующие вежливости при личном общении или по телефону, отсутствуют, и вежливость может быть забыта.

Банкротство электронной почты

Также известный как "утомление от электронной почты", "банкротство электронной почты" – это ситуация, когда пользователь перестает отвечать на большое количество электронных писем, накопившихся из-за того, что не успевает их просматривать и обрабатывать. Причиной такого отставания часто является информационная перегрузка и ощущение, что объем информации настолько велик, что прочитать всё просто невозможно. В качестве решения некоторые люди отправляют шаблонное сообщение, объясняющее, что их почтовый ящик переполнен и они занимаются очисткой входящих. Термин был введен профессором права Гарвардского университета Лоуренсом Лессигом, хотя возможно, он лишь способствовал его распространению.

Интернационализация

Изначально электронная почта в интернете была полностью основана на ASCII-тексте. MIME сейчас позволяет использовать текст в теле письма и в некоторых полях заголовка в международных кодировках, однако другие поля заголовков и адреса электронной почты, использующие UTF-8, хотя и стандартизированы, пока не получили широкого распространения.