Введение

Стандарт OSI для электронной почты. X.400 — это набор рекомендаций ITU-T, определяющих систему обработки сообщений (MHS) ITU-T. В свое время разработчики X.400 рассчитывали, что он станет основной формой электронной почты, но эту роль заняла электронная почта в Интернете на основе SMTP. Несмотря на это, он широко использовался внутри организаций и являлся ключевым компонентом Microsoft Exchange Server до 2006 года; его варианты по-прежнему важны в военной и авиационной сферах.

История

Первые рекомендации X.400 были опубликованы в 1984 году (Красная книга), а в 1988 году была опубликована существенно пересмотренная версия (Голубая книга). Новые функции были добавлены в 1992 году (Белая книга) и в последующих обновлениях. Хотя X.400 изначально был разработан для работы поверх транспортной службы OSI, адаптация для работы через TCP/IP, RFC 1006, стала наиболее популярным способом использования X.400. Разработанные в сотрудничестве с ISO/IEC, рекомендации серии X.400 определяют стандартные протоколы OSI для обмена и адресации электронных сообщений. Сопутствующая серия рекомендаций F.400 определяет службы обработки сообщений, построенные на системах обработки сообщений (MHS), а также доступ к MHS и из него для общедоступных служб. В конце 1990-х годов ITU-T консолидировал рекомендации F.400 и X.400 и опубликовал рекомендацию ITU-T F.400/X.400 (06/1999) "Обзор системы обработки сообщений и услуг". Рекомендации серии X.400 определяют технические аспекты MHS: ITU-T Rec. X.402 | (ISO/IEC 10021 2) определяет общую архитектуру системы MHS, ITU-T Rec. X.411 | (ISO/IEC 10021 4) определяет службу передачи сообщений (MTS) и ее функциональный компонент – агент передачи сообщений (MTA), а ITU-T Rec. X.413 | (ISO/IEC 10021 5) определяет хранилище сообщений. Все рекомендации ITU-T содержат конкретные термины для описания системных объектов и процедур. Например, сообщения (электронная почта), которыми обмениваются люди, называются межличностными сообщениями (IPM); электронные структурированные деловые документы (например, счета-фактуры, заказы на покупку, уведомления об отправке и т. д.), которыми обмениваются компьютеры торговых партнеров, подпадают под протоколы EDI. Обработка сообщений – это распределенная задача обработки информации, которая объединяет две связанные подзадачи: передачу сообщений и хранение сообщений. Рекомендации ITU-T определяют конкретные протоколы для широкого спектра задач связи. Например, протокол P1 используется специально для связи между MTA, P3 – между пользовательским агентом и MTA, а P7 – между пользовательским агентом и хранилищем сообщений. В версии 1994 года P7 был расширен для обеспечения папок в хранилище сообщений, хранения отправленных сообщений и предоставления множества автоматических действий, таких как автоматическая сортировка и сопоставление ответов, отчетов о доставке и уведомлений о получении с отправленными сообщениями. Стандарты содержания сообщений X.400 определены для связи между пользовательскими агентами. Они моделируются как концептуальные протоколы, рассматривающие P1 и P3/P7 как обеспечивающие надежную транспортировку содержимого сообщений. Стандарт содержания сообщений для межличностных сообщений, IPM, определенный в ITU-T Rec. X.420 | ISO/IEC 10021 7, был назван P2 в Красной книге. Расширенная версия IPM в Голубой книге получила тип содержания 22 (для версии P2) и часто неофициально упоминается как P22, хотя этот термин не используется в стандартах. Стандарт содержания сообщений для EDI определен в ITU-T Rec. F.435 | ISO/IEC 10021 8 и ITU-T Rec. X.435 | ISO/IEC 10021 9 и неофициально называется P35. Тип содержания голосовых сообщений определен в ITU-T Rec. F.440 и X.440. Exchange Server 2007 не использует объект MTA, а коннектор X.400 (который должен использовать MTA) отсутствует в Exchange Server 2007. В Exchange Server 2007 больше нет прокси-адресов X.400 по умолчанию. Важные особенности X.400 включают структурированную адресацию, двоичный код ASN.1, обеспечивающий поддержку мультимедийного контента (предшествующий и более эффективный, чем MIME), и встроенные возможности безопасности. Поскольку ITU-T предполагал, что службы междоменной ретрансляции X.400 будут управляться операторами связи (PTT), X.400 включал поля для автоматизированной передачи сообщений между X.400 и другими службами PTT, такими как телетайп, факсимильная связь и обычная почта. ISO позже добавил стандарты открытой маршрутизации (ITU-T Rec. X.412 | ISO/IEC 10021 10 и ITU-T Rec. X.404 | ISO/IEC 10021 11), но первоначальное заблуждение, что X.400 требует услуг ретрансляции PTT, в сочетании с тарифами PTT, основанными на объеме, стали факторами, которые препятствовали широкому распространению X.400.

Реализация

С конца 1980-х годов многие крупные страны взяли на себя обязательства по внедрению стека OSI через GOSIP (Government Open Systems Interconnection Profiles). В Соединенных Штатах это было реализовано в виде "Федерального стандарта обработки информации" NIST 1990 года (FIPS #146). Крупные производители компьютерной техники, в свою очередь, обязались выпускать продукты, соответствующие OSI, включая X.400. Microsoft Exchange Server был разработан в этот период и внутренне базировался на X.400/X.500, при этом первый релиз был "в равной степени готов отправлять сообщения через Messaging API (MAPI), X.400 или Simple Mail Transfer Protocol (SMTP)". Однако на практике большинство этих продуктов были разработаны некачественно и редко внедрялись. В Северной Америке многие крупные оборонные подрядчики и университеты уже перешли на Интернет и стандарты TCP/IP, включая SMTP для электронной почты. Там X.400 до сих пор используется в некоторых областях, таких как военное дело, спецслужбы и авиация, главным образом потому, что протокол X.400 поддерживает шифрование, а его функции обеспечения целостности и безопасности были разработаны и внедрены значительно раньше, чем аналогичные функции SMTP (S/MIME, PGP и SMTP TLS). По схожим причинам он иногда используется для передачи сообщений EDI между приложениями. В Европе, Южной Америке и Азии X.400 достаточно широко используется, особенно для EDI-сервисов. X.400 был расширен для применения в военных системах (см. Система обработки военных сообщений) и в авиации (см. Система обработки авиационных сообщений). Кроме того, НАТО использует STANAG 4406 в качестве стандарта для военных сообщений на основе X.400.

Справочники X.500

Запутанность, вызванная форматом адресации X.400, привела к созданию стандарта X.500 для служб каталогов. Идея заключалась в создании иерархического и стандартизированного каталога адресов электронной почты с функциями репликации и распространения, позволяющими нескольким организациям совместно поддерживать единый общедоступный каталог. Например, каждый домен управления администрацией (провайдер услуг) мог при желании загружать свой каталог на общий сервер X.500, а затем разрешить агентам пользователя X.400 осуществлять поиск в этой базе данных при создании электронного письма, что избавляло от необходимости знать что-либо об адресе, кроме имени получателя и названия организации, например, компании. К сожалению, протокол X.500 оказался таким же сложным и неуклюжим, как и X.400, что привело к созданию протокола Lightweight Directory Access Protocol (LDAP), стандартизировавшего упрощенный набор протоколов X.500, подходящий для использования пользовательским программным обеспечением при поиске адресов. LDAP широко используется в службах каталогов, таких как Microsoft Active Directory.

Общие ссылки

RFC 1615 Миграция с X.400(84) на X.400(88)
RFC 1649 Операционные требования к управляющим доменам X.400 в сообществе GO MHS

Рекомендации по ITU-T X.400

ITU T Rec. F.400/X.400 | ISO/IEC 10021 1 Обзор системы обработки сообщений и услуг
ITU T Rec. X.402 | ISO/IEC 10021 2 Системы обработки сообщений (MHS): Общая архитектура
ITU T Rec. X.411 | ISO/IEC 10021 4 Системы обработки сообщений (MHS): Система передачи сообщений: Абстрактное определение службы и процедуры
ITU T Rec. X.413 | ISO/IEC 10021 5 Системы обработки сообщений (MHS): Хранилище сообщений: Абстрактное определение службы
ITU T Rec. X.419 | ISO/IEC 10021 6 Системы обработки сообщений (MHS): Спецификации протоколов
ITU T Rec. X.420 | ISO/IEC 10021 7 Системы обработки сообщений (MHS): Система межличностной переписки
ITU T Rec. X.435 | ISO/IEC 10021 9 Системы обработки сообщений (MHS): Система обмена электронными данными
ITU T Rec. X.412 | ISO/IEC 10021 10 Системы обработки сообщений (MHS): Маршрутизация MHS
ITU T Rec. X.404 | ISO/IEC 10021 11 Системы обработки сообщений (MHS): Маршрутизация MHS: Руководство для менеджеров систем обмена сообщениями