Кіріспе

Принтерлер жұмыс тобы (PWG) – IEEE Industry Standard and Technology Organization (ISTO) бағдарламасының бір бөлігі болып табылады және құрамында принтерлер мен көп функциялы құрылғыларды өндірушілер, принтер серверлерін әзірлеушілер, операциялық жүйелерді ұсынатын компаниялар, баспаны басқару қолданбаларын жасаушылар және сала мамандары бар. 1991 жылы Network Printing Alliance ретінде құрылған PWG принтерлердің, көп функциялы құрылғылардың, сондай-ақ оларды қолдайтын қолданбалар мен операциялық жүйелердің үйлесімді жұмыс істеуін қамтамасыз етуге бағытталған. PWG ашық стандарттарды әзірлеу процесін қолдайды. Кез келген адам олардың құжаттары мен стандарттарын әзірлеуге қатыса алады, редакторлық қызмет атқарады және өзара сәйкестілікті сынауға көмектеседі. Мүшелер сонымен қатар түрлі жұмыс топтарында лауазымды тұлғалар ретінде де жұмыс істей алады. Дауыс беру құқығы бар мүшелер құжаттар мен стандарттарды жариялауға бекітеді және PWG басшылары болып тағайындалуы мүмкін.

Жұмыс топтары

PWG-де екі белсенді жұмыс тобы бар: Интернет-басып шығару протоколы жұмыс тобы және Бейнелеу құрылғыларының қауіпсіздігі жұмыс тобы. Интернет-басып шығару протоколы жұмыс тобы Интернет-басып шығару протоколын (IPP) әзірлейді және күзеді, сондай-ақ Принтер MIB, Жұмыс мониторингі MIB, Аяқтағыштар MIB және қарапайым желілік мониторинг протоколы (SNMP) арқылы қолданылатын түрлі PWG-ге арналған MIB-терді күзеді. IPP дерлік барлық желілік принтерлерде қолдауға ие, AirPrint, IPP Everywhere, Mopria және Wi Fi Direct Print Services сияқты түрлі драйверсіз басып шығару стандарттарының негізі болып табылады және CUPS сияқты әртүрлі басып шығару шпульдерімен қолданылады. Бейнелеу құрылғысының қауіпсіздігі (IDS) жұмыс тобы қауіпсіздікке қатысты стандарттар мен ең жақсы тәжірибелерді әзірлейді және күзеді, сондай-ақ қазіргі Қатты көшірме құрылғысының (HCD) Бірлескен қорғау профилін (cPP) әзірлеу және күзеу үшін Common Criteria ұйымымен байланыс орнатады.

Тарих

1990 жылдың ақпан айында IETF Network Printing Protocol жұмыс тобы құрылды. 1990 жылдың тамызында жұмыс тобы RFC 1179: Line Printer Daemon Protocol жариялады, ол сол кездегі кең таралған желілік басып шығару протоколын сипаттады. 1991 жылы принтер және желілік құрылғылар өндірушілерінің консорциумы (Insight Development, Intel, LAN Systems, Lexmark және Texas Instruments) Network Printing Alliance (NPA) құрды. Кейінірек QMS, Kyocera, GENICOM, Okidata, Unisys, Canon, IBM, Kodak, Adaptec, Tektronix, Digital Products, Pennant Systems, Extended Systems және NEC мүше болды. 1993 жылы NPA қайта ұйымдастырылып, Printer Working Group аталды және HP, Compaq, Microsoft, Xerox, Xircom, Farpoint Communications, Zenith, Castelle, Fujitsu, 3M, Cirrus Logic, Amp, National Semiconductor және Ricoh қосылды. 1994 жылдың қаңтар айында IETF Printer MIB жұмыс тобы құрылды. Бұл жұмыс тобы 1995 жылдан 2004 жылға дейін бірнеше SNMP MIB RFC-терді жариялады, содан кейін принтерге қатысты MIB-терді әзірлеу және күтіп ұстау Printer Working Group-қа жүктелді. 1997 жылдың наурыз айында IETF Internet Printing Protocol жұмыс тобы құрылды. Бұл жұмыс тобы 1999 жылдан 2005 жылға дейін бірнеше IPP RFC-терді жариялады, содан кейін IPP-ті дамыту және күтіп ұстау Printer Working Group-қа ауысты. 1999 жылдың қыркүйегінде IEEE, PWG-мен IEEE Industry Standards and Technology Organization (IEEE ISTO) аясында одақ құрды. Осыдан бері PWG басып шығару және принтерлерге қатысты 60-тан астам стандартты және ақпараттық құжатты жариялады. 2015 жылдың наурызында IETF, PWG IPP жұмыс тобы әзірлеген жаңа IPP RFC-ті жариялады – RFC 7472: IPP over HTTPS Transport Binary және ipps URI Scheme. 2017 жылдың қаңтар айында IETF, PWG IPP жұмыс тобы әзірлеген негізгі IPP RFC-лерді (RFC 2910, 2911, 3381 және 3382) жаңартты – RFC 8010: Internet Printing Protocol/1.1: Encoding and Transport және RFC 8011: Internet Printing Protocol/1.1: Model and Semantics. 2018 жылдың маусым айында IETF осы RFC-лерді Internet Standard 92 ретінде жариялады.