Введение

Рабочая группа по печати (PWG) — это программа Организации IEEE по промышленным стандартам и технологиям (ISTO), в которую входят производители принтеров и многофункциональных устройств, разработчики печатных серверов, поставщики операционных систем, разработчики приложений для управления печатью и отраслевые эксперты. Изначально основанная в 1991 году как Сетевой альянс печати, PWG имеет мандат на обеспечение более эффективного взаимодействия принтеров, многофункциональных устройств, а также приложений и операционных систем, которые их поддерживают. PWG использует открытый процесс разработки стандартов. Любой желающий может участвовать в разработке документов и стандартов, выступать в качестве редактора и участвовать в тестировании совместимости. Члены могут также занимать должности в различных рабочих группах. Члены с правом голоса утверждают документы и стандарты для публикации и могут занимать должности в PWG.

Рабочие группы

В PWG действуют две рабочие группы: рабочая группа по протоколу интернет-печати и рабочая группа по безопасности устройств обработки изображений. Рабочая группа по протоколу интернет-печати разрабатывает и поддерживает протокол интернет-печати (IPP), а также поддерживает MIB для принтеров, MIB для мониторинга заданий, MIB для финишеров и различные MIB, специфичные для PWG, используемые через Простой протокол сетевого управления (SNMP). IPP поддерживается практически всеми сетевыми принтерами, является основой различных стандартов печати без драйверов, включая AirPrint, IPP Everywhere, Mopria и Wi-Fi Direct Print Services, и используется различными спулерами печати, включая CUPS. Рабочая группа по безопасности устройств обработки изображений (IDS) разрабатывает и поддерживает стандарты и лучшие практики в области безопасности, а также поддерживает связь с организацией Common Criteria для разработки и поддержки текущего совместного профиля защиты устройств жесткой копии (HCD cPP).

История

В феврале 1990 года была учреждена рабочая группа IETF Network Printing Protocol. В августе 1990 года рабочая группа опубликовала RFC 1179: Line Printer Daemon Protocol для документирования преобладающего в то время протокола сетевой печати. В 1991 году консорциум производителей принтеров и сетевого оборудования (Insight Development, Intel, LAN Systems, Lexmark и Texas Instruments) сформировал Network Printing Alliance (NPA). Позже в состав альянса вошли QMS, Kyocera, GENICOM, Okidata, Unisys, Canon, IBM, Kodak, Adaptec, Tektronix, Digital Products, Pennant Systems, Extended Systems и NEC. В 1993 году NPA была реорганизована в Рабочую группу по принтерам (Printer Working Group) и к ней присоединились HP, Compaq, Microsoft, Xerox, Xircom, Farpoint Communications, Zenith, Castelle, Fujitsu, 3M, Cirrus Logic, Amp, National Semiconductor и Ricoh. В январе 1994 года была учреждена рабочая группа IETF Printer MIB. Эта рабочая группа опубликовала серию RFC SNMP MIB с 1995 по 2004 год, после чего разработка и поддержка MIB, связанных с принтерами, перешли к Рабочей группе по принтерам. В марте 1997 года была учреждена рабочая группа IETF Internet Printing Protocol. Эта рабочая группа опубликовала серию RFC IPP с 1999 по 2005 год, после чего разработка и поддержка IPP перешли к Рабочей группе по принтерам. В сентябре 1999 года IEEE официально заключил соглашение с PWG в рамках IEEE Industry Standards and Technology Organization (IEEE ISTO). С тех пор PWG опубликовала более 60 стандартов и информационных документов, касающихся печати и принтеров. В марте 2015 года IETF опубликовал новый RFC IPP, разработанный рабочей группой PWG IPP – RFC 7472: IPP over HTTPS Transport Binary и схема URI ipps. В январе 2017 года IETF опубликовал обновления основных RFC IPP (RFC 2910, 2911, 3381 и 3382), разработанные рабочей группой PWG IPP – RFC 8010: Internet Printing Protocol/1.1: Encoding and Transport и RFC 8011: Internet Printing Protocol/1.1: Model and Semantics. В июне 2018 года IETF опубликовал эти RFC как Internet Standard 92.