Кіріспе
Деректер байланысы қабатының байланыс протоколы Компьютерлік желілерде Point to Point Protocol (PPP) – екі маршрутизатор арасында тікелей, арасында хост немесе басқа желілік байланыссыз деректер байланысы қабатының (2-қабат) байланыс протоколы. Ол циклды анықтау, аутентификация, деректерді шифрлау және сығу мүмкіндіктерін ұсынады. PPP көптеген физикалық желілерде қолданылады, оның ішінде: тізбекті кабель, телефон желісі, магистральдық желі, ұялы телефон, арнайы радио байланыстары, ISDN және SONET сияқты оптикалық талшықты байланыстар. IP пакеттерін модем желісі арқылы, жіберілген кадрдың басталу және аяқталу орнын анықтайтын деректер байланысы протоколы болмаса, өздігінен жіберу мүмкін емес. Сондықтан, интернет-провайдерлер (ISP) клиенттердің интернетке қосылуы үшін PPP-ді пайдаланды. PPP бұрынғы телефондық қосылымдарда қолданылды. PPP-нің екі түрі – Ethernet арқылы Point to Point Protocol (PPPoE) және ATM арқылы Point to Point Protocol (PPPoA) – интернет-провайдерлер клиенттермен цифрлық абоненттік желі (DSL) интернет-қызметін орнату үшін ең көп қолданылады.
Сипаттама
PPP синхронды және асинхронды желілер арқылы қосылу үшін деректер байланысы қабатының протоколы ретінде кеңінен қолданылады, ол бұрынғы Serial Line Internet Protocol (SLIP) және телефон компанияларының талаптарын (мысалы, X.25 протоколы жиынтығындағы Link Access Protocol, Balanced (LAPB)) көптеп ығыстырды. PPP үшін жалғыз талап – ұсынылған желінің дуплекстік болуы. PPP көптеген желілік қабат протоколдарымен жұмыс істеуге құрылған, оның ішінде Интернет протоколы (IP), TRILL, Novell's Internetwork Packet Exchange (IPX), NBF, DECnet және AppleTalk. SLIP сияқты, бұл модем арқылы телефон желілері арқылы толық интернет байланысын қамтамасыз етеді. PPP, SLIP-ке қарағанда сенімдірек, себебі интернет пакеттерінің толық күйінде келгенін қамтамасыз ету үшін екі рет тексеріледі. Бұл көрсетілген физикалық қабат арқылы дерек пакеттерін жіберуге арналған инкапсуляция компоненті. Байланысты орнату, конфигурациялау және тестілеу, сондай-ақ параметрлерді, опцияларды және мүмкіндіктерді келісу үшін байланыс басқару протоколы (LCP) қолданылады. Желілік қабат үшін қосымша конфигурация параметрлері мен мүмкіндіктерін келісу үшін бір немесе бірнеше желілік басқару протоколдары (NCP) пайдаланылады. PPP қолдайтын әрбір жоғары деңгейлі протокол үшін бір NCP қарастырылған.
Автоматты түрде өзін-өзі баптау
LCP қосылымдарды әдепті түрде бастайды және аяқтайды, хосттарға қосылым опцияларын келісуге мүмкіндік береді. Ол PPP-нің ажырамас бөлігі болып табылады және бірдей стандартты сипаттамада анықталған. LCP әр шеттегі интерфейстерді автоматты түрде конфигурациялауды қамтамасыз етеді (мысалы, дерек пакетінің мөлшерін, қашқыш символдарды және сиқырлы сандарды орнатуды) және қосымша аутентификацияны таңдауға мүмкіндік береді. LCP протоколы PPP-нің үстінде жұмыс істейді (PPP протоколы нөмірі 0xC021), сондықтан LCP оны конфигурациялай алмас бұрын негізгі PPP қосылымы орнатылуы керек. RFC 1994 Challenge Handshake Authentication Protocol (CHAP) хаттамасын сипаттайды, ол интернет-провайдерлермен телефондық қосылыстарды орнату үшін ұсынылады. Ескіргенімен, парольді аутентификациялау протоколы (PAP) кейде қолданыла береді. PPP арқылы аутентификациялаудың тағы бір нұсқасы – RFC 2284-те сипатталған Extensible Authentication Protocol (EAP) хаттамасы. Қосылыс орнатылғаннан кейін қосымша желілік (3-ші қабат) конфигурация жүргізілуі мүмкін. Көбінесе Internet Protocol Control Protocol (IPCP) қолданылады, бірақ Internetwork Packet Exchange Control Protocol (IPXCP) және AppleTalk Control Protocol (ATCP) бір кезде танымал болған. Internet Protocol Version 6 Control Protocol (IPv6CP) болашақта кеңінен қолданылады, IPv6 IPv4-ті 3-ші қабаттың басым протоколы ретінде алмастырғанда.
Бұраулы байланысты анықтау
PPP циклдік байланыстарды сиқырлы сандарды қолданатын мүмкіндік арқылы анықтайды. Түйін PPP LCP хабарламаларын жібергенде, бұл хабарламалар сиқырлы санды қамтуы мүмкін. Егер байланыс желісінде цикл болса, түйін өзінің сиқырлы саны бар LCP хабарламасын алады, қарсы тараптың санының орнына.
Конфигурация параметрлері
Алдыңғы бөлімде WAN қосылысының нақты талаптарын қанағаттандыру үшін LCP опцияларын пайдалану туралы мәлімет берілді. PPP келесі LCP опцияларын қамтуы мүмкін:
Аутентификация – Пирлік маршрутизаторлар аутентификациялық хабарламаларды алмасады. Екі аутентификация таңдауы бар: Парольді аутентификациялау протоколы (PAP) және Шақыру-құптау аутентификациялау протоколы (CHAP). Аутентификация туралы мәліметтер келесі бөлімде түсіндіріледі.
Қысымдалу – BSD қысымдалуы немесе Deflate сияқты келісілген алгоритмді пайдалану арқылы, сілтеме арқылы жіберілуі тиіс кадрдың дерек көлемін азайту арқылы PPP қосылымдарының тиімді өткізу қабілетін арттырады. Протокол кадрды түйір жерінде қысымнан босатады. Толығырақ мәліметтер үшін қараңыз.
Қателерді анықтау – Ақаулық жағдайларын анықтайды. Сапа және Сиқырлы сан опциялары сенімді, қайта оралмастан деректерді қамтамасыз етуге көмектеседі. Сиқырлы сан өрісі, қайта оралып қалған жағдайдағы сілтемелерді анықтауға көмектеседі. Сиқырлы сан конфигурациясы опциясы сәтті келісілгенге дейін, сиқырлы сан нөл ретінде жіберілуі керек. Қосылымның әр шетінде сиқырлы сандар кездейсоқ түрде жасалады.
Multilink – Multilink PPP арқылы PPP пайдаланатын бірнеше интерфейстердің жүктемесін теңестіруді қамтамасыз етеді (төменде қараңыз).
Authentication Peer routers exchange authentication messages. Two authentication choices are Password Authentication Protocol (PAP) and Challenge Handshake Authentication Protocol (CHAP). Authentication is explained in the next section. Compression Increases the effective throughput on PPP connections by reducing the amount of data in the frame that must travel across the link, using a agreed on algorithm such as BSD compress or Deflate. The protocol decompresses the frame at its destination. See for more details. Error detection Identifies fault conditions. The Quality and Magic Number options help ensure a reliable, loop free data link. The Magic Number field helps in detecting links that are in a looped back condition. Until the Magic Number Configuration Option has been successfully negotiated, the Magic Number must be transmitted as zero. Magic numbers are generated randomly at each end of the connection. Multilink Provides load balancing several interfaces used by PPP through Multilink PPP (see below).
Желілерді іске қосу және фазалары
Сілтеме бұзылу фазасы Бұл фаза сілтеме сәтсіз аяқталғанда немесе бір тарапқа байланысты үзу туралы хабарланғанда (мысалы, пайдаланушы диал-ап қосылысын аяқтағанда) пайда болады. Сілтеме орнату фазасы Бұл фазада сілтеме басқару протоколы бойынша келіссөздер жүргізіледі. Егер сәтті аяқталса, басқару аутентификация фазасына немесе желілік қабат протоколы фазасына көшеді, бұл аутентификация қажеттігіне байланысты. Аутентификация фазасы Бұл фаза міндетті емес. Ол тараптарға қосылыс орнатылғанға дейін бір-бірін аутентификациялауға мүмкіндік береді. Егер сәтті аяқталса, басқару желілік қабат протоколы фазасына көшеді. Желілік қабат протоколы фазасы Бұл фазада қажетті протоколдардың Желілік басқару протоколдары іске қосылады. Мысалы, IPCP желі арқылы IP қызметін орнату үшін қолданылады. Желілік басқару протоколдарымен сәтті іске қосылған барлық протоколдар үшін деректерді тасымалдау да осы фазада жүзеге асырылады. Желілік протоколдарды жабу да осы фазада жүреді. Сілтемені тоқтату фазасы Бұл фаза осы қосылысты жабады. Бұл аутентификация сәтсіз аяқталса, егер тексеру сомасының қателер саны көп болса және екі тарап сілтемені автоматты түрде үзуге шешім қабылдаса, сілтеме кенеттен бұзылса немесе пайдаланушы қосылысты тоқтатуға шешім қабылдаса болуы мүмкін.
Көптірікті ЖЖБ
Көпті байланыс PPP (MLPPP, MP, MPPP, MLP немесе Multilink деп те аталады) трафикті бірнеше жеке PPP қосылымдары арқылы тарату әдісін ұсынады. Ол RFC 1990 стандартында анықталған. Мысалы, екі дәстүрлі 56k модем арқылы үй компьютерін Интернет-провайдерге қосуға немесе екі жалға алынған арна арқылы компанияны қосуға болады. Жеке PPP желісінде кадрлар ретінен шыға алмайды, бірақ кадрлар бірнеше PPP қосылымдарына бөлінген кезде мұндай мүмкіндік туындайды. Сондықтан, Multilink PPP фрагменттерді нөмірлеп отыруы керек, осылай келген кезде оларды дұрыс ретке келтіруге болады. Көпті байланыс PPP – байланыс агрегациясы технологиясының мысалы. Cisco IOS 11.1 және одан кейінгі нұсқалары Multilink PPP-ді қолдайды.
Көп сыныпты ЖЖҚ
PPP арқылы бір желіде бірнеше жеке PPP байланысын бір уақытта орнатуға болмайды. Көп байланысты PPP (Multilink PPP) арқылы да бұл мүмкін емес. Көп байланысты PPP пакеттің барлық бөліктері үшін тізбектелген нөмірлерді пайдаланады, сондықтан бір пакеттің бөліктерінің тізбегін тоқтатып, басқа пакетті жіберуге болмайды. Бұл бір байланыста Көп байланысты PPP-ны бірнеше рет іске қосуға кедерес келтіреді. Көп сыныпты PPP – бұл әрбір "сынып" трафигі үшін жеке реттік нөмірлер жиынтығы мен қайта құрастыру буферін пайдаланатын Көп байланысты PPP түрі. Көп сыныпты PPP RFC 2686 стандартында сипатталған.
Туынды протоколдар
PPTP (Point to Point Tunneling Protocol) – екі хост арасында шифрлау (MPPE) және сығылу (MPPC) қолданылып, GRE арқылы құрылатын PPP түрі.
Туннельдің екі ұшы арасындағы 2-қабат протоколы ретінде
IP желілер арқылы деректерді туннельдеу үшін көптеген протоколдар қолданылуы мүмкін. Олардың кейбіреулері, мысалы SSL, SSH немесе L2TP виртуалды желі интерфейстерін құрайды және туннельдің екі шеті арасында тікелей физикалық байланыс бар сияқты әсер қалдырады. Мысалы, Linux жүйесінде осы интерфейстер tun0 немесе ppp0 деп аталады. Туннельде тек екі шет болғандықтан, туннель нүктеден нүктеге байланыс болып табылады және PPP виртуалды желі интерфейстері арасындағы деректер байланысы қабатының протоколы ретінде табиғи таңдау болып келеді. PPP осы виртуалды интерфейстерге IP-адрестерін тағайындауға болады, ал осы IP-адрестерін, мысалы, туннельдің екі жағындағы желілер арасында маршрутизация жасау үшін пайдалануға болады. IPsec туннельдеу режимінде туннельдің соңында виртуалды физикалық интерфейстерді құрмайды, себебі туннель тікелей TCP/IP стегімен басқарылады. L2TP осы интерфейстерді қамтамасыз ету үшін қолданылуы мүмкін, бұл техника L2TP/IPsec деп аталады. Осы жағдайда да PPP туннельдің шеттеріне IP-адрестерін береді.
IETF стандарттары
PPP RFC 1661 (The Point to Point Protocol, 1994 жылдың шілдесі) құжатында анықталған. RFC 1547 (Интернет стандартты нүктеден нүктеге протоколына қойылатын талаптар, 1993 жылғы желтоқсан) PPP қажеттілігі мен оның даму тарихы туралы ақпарат береді. TCP/IP, DECnet, AppleTalk, IPX сияқты әртүрлі желілік басқару протоколдарының PPP-мен қалай жұмыс істейтінін анықтайтын бірнеше байланысты RFC құжаттары жазылған; оларды Datatracker IETF веб-сайтында табуға болады.