Введение

Протокол управления шлюзом (Megaco, H.248) — это реализация архитектуры протокола управления шлюзами для предоставления телекоммуникационных услуг через конвергентную сеть, состоящую из традиционной общедоступной коммутируемой телефонной сети (PSTN) и современных пакетных сетей, таких как Интернет. H.248 — обозначение рекомендаций, разработанных Сектором стандартизации телекоммуникаций МСЭ (ITU-T), а Megaco — сокращение от "media gateway control protocol", используемое в самых ранних спецификациях рабочей группы по инженерным задачам в Интернете (IETF). Стандарт, опубликованный ITU-T в марте 2013 года, называется H.248.1: Протокол управления шлюзами: версия 3. Megaco/H.248 соответствует рекомендациям, опубликованным в RFC 2805 в апреле 2000 года, под названием "Media Gateway Control Protocol Architecture and Requirements". Протокол выполняет те же функции, что и протокол управления шлюзами медиа (MGCP), однако является формальным стандартом, в то время как MGCP имеет лишь информационный статус. Ввиду различного синтаксиса и символического представления, эти два протокола не обеспечивают прямой совместимости. Они оба дополняют протоколы H.323 и протокол инициирования сеанса (SIP). H.248 стал результатом сотрудничества рабочей группы MEGACO IETF и 16-й исследовательской группы по телекоммуникациям Международного союза электросвязи (ITU). IETF первоначально опубликовал стандарт как RFC 3015, который был заменен RFC 3525. Термин "Megaco" является обозначением, используемым IETF. Megaco объединяет концепции MGCP и протокола управления медиа-устройствами (MDCP). MGCP возник в результате объединения протокола Simple Gateway Control Protocol (SGCP) с протоколом управления устройствами IP (IPDC). После того, как ITU взяла на себя ответственность за поддержку протокола, IETF переклассифицировал свои публикации как исторические в RFC 5125. ITU опубликовала три версии H.248, последняя из которых датируется сентябрем 2005 года. H.248 охватывает не только базовую спецификацию протокола H.248.1, но и множество расширений, определенных в подсерии H.248.

Сравнение с MGCP

Модель H.248/Megaco сложнее, чем модель Media Gateway Control Protocol (MGCP), и обеспечивает большую гибкость в определении управления мультимедиа. Например, в MGCP вызов может использовать конференцсвязь в режиме конечной точки для управления смешиванием потоков, но не обеспечивает такого же детального контроля над потоками мультимедиа, как H.248/Megaco. Модель H.248/Megaco упрощает настройку соединений внутри MG и с внешними сущностями. Она упрощает механизм, посредством которого контроллер шлюза (MGC) может указывать связанные потоки мультимедиа, а также направление потока мультимедиа. Таким образом, H.248/Megaco способен обеспечить более широкую поддержку на уровне приложений, чем MGCP. Например, настройка многосторонней конференции с использованием H.248 включает в себя простое добавление нескольких терминаций в контекст. В случае MGCP, однако, MGC необходимо установить несколько соединений со специальным типом конечной точки, называемой конференц-мостом. Ниже приведены основные различия между Megaco/H.248 и MGCP:

H.248/Megaco | MGCPA вызов представлен терминациями в контексте вызова | Вызов представлен конечными точками и соединениями
Типы вызовов включают любую комбинацию мультимедиа и конференцсвязи | Типы вызовов включают соединение точка-точка и многоточка
Кодирование – текстовое или двоичное | Кодирование – текстовое
Протокол передачи – TCP, UDP или SCTP | Протокол передачи – UDP
Стандартный протокол для управления медиашлюзом, статус IETF – информационный | MGCP не определяет интернет-стандарт
Определен ITU (ранее ITU и IETF) | Управляется разработчиками, существует множество независимых расширений протокола.