Введение

Американский учёный-компьютерщик (1943–1998)

Джонатан Брюс Постел (/p//ə/'s//t//ɛ//l/; 6 августа 1943 – 16 октября 1998) – американский учёный-компьютерщик, внесший значительный вклад в развитие Интернета, особенно в области стандартизации. Он наиболее известен как редактор серии документов Request for Comment (RFC), протокола Simple Mail Transfer Protocol (SMTP) и администратор Internet Assigned Numbers Authority (IANA) до своей смерти. При жизни его называли «богом Интернета» за его огромное влияние; сам Постел заметил, что этот «комплимент» содержал скрытую критику – предложение заменить его «профессионалом», и ответил в свойственной ему скромной и деловой манере: «Разумеется, никакого «Бога Интернета» не существует. Интернет работает благодаря сотрудничеству множества людей».

Карьера

Постел учился в средней школе Ван-Нюйс, а затем в Калифорнийском университете в Лос-Анджелесе (UCLA), где получил степень бакалавра (1966) и магистра (1968) в области инженерии. Там же он защитил докторскую диссертацию по компьютерным наукам в 1974 году, под руководством Дэйва Фарбера. Постел начал работать в UCLA 23 декабря 1969 года в качестве инженера-исследователя (I), где принимал участие в ранних разработках ARPANET. Он участвовал в создании системы доменных имен Интернета, и по его инициативе Винт Серф и Боб Кан разработали второй набор протоколов для передачи данных между сетями, который сейчас известен как семейство протоколов TCP/IP. Вместе с Серфом и Стивом Крокером Постел работал над реализацией большинства протоколов ARPANET. Впоследствии Серф стал одним из основных разработчиков стандарта TCP/IP.

Постел работал с ARPANET до 24 августа 1973 года, после чего перешел в корпорацию MITRE. Он оказывал помощь в создании Сетевого информационного центра, который организовывала Элизабет Файнлер в SRI. В марте 1977 года он присоединился к Институту информационных наук Университета Южной Калифорнии в качестве научного сотрудника. Постел был редактором RFC с 1969 года до своей смерти, написав и отредактировав множество важных RFC, включая RFC 791, RFC 792 и RFC 793, определяющие базовые протоколы семейства протоколов TCP/IP, и RFC 2223, Instructions to RFC Authors. В период с 1982 по 1984 год Постел был соавтором RFC, которые легли в основу современной DNS (RFC 819, RFC 881, RFC 882 и RFC 920), к которым в 1995 году присоединился RFC 1591, также написанный им в соавторстве. Всего он написал или был соавтором более 20 RFC. Постел на протяжении многих лет работал в Совете по архитектуре Интернета и его предшественниках. Он был директором центра регистрации имен и номеров, Управления назначенными номерами Интернета (IANA), с момента его основания. Он был первым членом Интернет-сообщества и входил в его Совет директоров. Он был первым и долгое время администратором доменов верхнего уровня. Он также управлял сетью Los Nettos. Все вышеперечисленное он выполнял в качестве дополнительной нагрузки, совмещая с основной должностью директора Отдела компьютерных сетей, Отдела 7, Института информационных наук Университета Южной Калифорнии.

Тест DNS Root Authority, ответ США

28 января 1998 года Постель, в рамках тестирования, по собственной инициативе отправил электронные письма восьми из двенадцати операторов региональных корневых серверов Интернета и распорядился им перенастроить свои серверы, изменив сервер корневой зоны с A. ROOT SERVERS. NET (198.41.0.4), принадлежавшего тогда дочерней компании SAIC Network Solutions, на DNSROOT. IANA. ORG (198.32.1.98). Операторы выполнили указания Постеля, тем самым разделив контроль над системой доменных имен Интернета между негосударственными операторами, связанными с IANA, и четырьмя оставшимися корневыми серверами, находящимися под управлением правительства США в NASA, DoD и BRL с NSI. Несмотря на то, что работа Интернета не была прервана, научный советник президента США Айра Магазинер пригрозил Постелю словами: "Вы больше никогда не будете работать в Интернете", и потребовал прекратить эксперимент, что Постель и сделал. В течение недели американское NTIA опубликовало предложение по улучшению технического управления именами и адресами в Интернете, включающее изменения в полномочиях над корневой зоной DNS Интернета, что в конечном итоге, и весьма противоречиво, усилило контроль США.

Смерть

16 октября 1998 года Постел скончался в Лос-Анджелесе от осложнений после операции на сердце. Он восстанавливался после операции по замене протекающего сердечного клапана.